My laptop (possibly just display adapter) do not appear to be supported.

Asked by Ashley Verinder

Hey guys,

I've tried the regular ubuntu discs, the alternate cd and just about every linux distribution available and none of them seem to work on my laptop. It is:

Advent 9315
Intel Core 2 Duo T5250 1.5ghz
2GB Ram
SiS Mirage 3 Graphics Adapter
Generic PnP Monitor

Every installation I try freezes at some point or another, sometimes with funky flashing "crashing screens". This is regardless to whether I run in text mode or normal.

So my question is basically this: Am I right in assuming that this hardware config is just not supported? If that is the case, is there any chance it will be in the future?

I've searched high and low for info, but neither this laptop model or the graphics chip inside seem to be popular choices. Nobody on the IRC support channels could offer any advice either unfortunately. Any advice or guidance received will be hugely appreciated.

Question information

English Edit question
Ubuntu xserver-xorg-driver-sis Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Alan Jenkins (aj504) said :

In text mode, any VGA graphics adaptor should be supported. But I think you're right about SiS not being very common. It might not get much testing.

I can't find anything about a Mirage 3 either. Can you see if theres an associated chipset number? Either from documentation you have or online, or maybe the windows device manager?

You say these crash screens happen during the text-mode installer. So as far as you know, this does *not* happen when the graphical X-server tries to run?

I think X would only be started after installation and the final reboot. If you wanted to be sure you might be able to try the server installation instead, which would not include X at all.

You really want to get some more information out of these crashes.
Does the screen show any kind of error message, or is it totally scrambled?
Do they generally happen at the same point in the text-mode installer, and if so where?
Does anything happen to the keyboard LEDs? Does the hard drive LED do anything?

It might also be useful to know how crashed the computer is exactly. Unfortunately this is easier to tell on an installed system. Can you reproduce this crash on the LiveCD system, after it's finished booting?
E.g. On a fully installed system, you coulf keep a terminal open and focused, or use the alt-f2 "run command" shortcut, and try to run "eject". If the CD tray ejects you know it's just the screen that's crashed. Now "eject" won't work on a LiveCD, but "sudo halt" would shutdown the system, which should provoke some observable activity even if it fails to finish for some reason. I think "sudo" works without a password on the LiveCD, but you'll have to check that.

Revision history for this message
Ashley Verinder (averinder) said :

Hi Alan, thanks for your reply!

I've actually now managed to get Ubuntu running, although not very well.

To get the install to work, I needed to select "safe graphics" mode and use the noapic and acpi=off options at boot. Following the install, Ubuntu would not boot and was freezing in the same place (ubuntu load screen with the progress bar). To boot linux, I need to press esc at grub, select "recovery" and add the same options again (noapic and acpi=off).

This successfully boots me into ubuntu, but I am limited to 800x600 resolution. I tried changing the device in xorg.conf (as per #Ubuntu irc instructions - thanks Cky and Nickrud!) from Vesa to sis, which then causes a window to pop up in ubuntu informing me I'm in low graphics mode and allowing me to configure my display settings. "Vesa Generic VGA" is selected, but after going through the entire list of sis adapters listed, I'm getting nowhere. Selecting SiS generic etc just freezes the screen for a sec, then gives an error message saying it's not supported.

As a result, I'm stuck in 800x600 and seem unable to boot ubuntu without booting in recovery mode with those earlier mentioned options. This is by far the managed I've gotten Ubuntu so far, so it's tantalizingly close now! Really hope someone can give some more advice!


(also, I can't turn on my wireless card, as the "Function+F10" keyboard function does not appear to be mapped in Ubuntu! - this is not a huge problem right now as I'm connected with a cable, but obviously if someone knows a simple solution :))


Revision history for this message
Alan Jenkins (aj504) said :

Good luck.

I'm sure you'll be doing some amount of rebooting in your current state; you may want to try editing (as root) /boot/grub/menu.lst to at least add the noapic and acpi=off options so you don't have to keep on re-entering them. Scroll down past all the comments and find the entry for the recovery mode. You can make a copy of the entry so you still have the old version - don't forget to change the title on the new one so you can tell the difference. Then add the options to the kernel line, just like when you boot.

If you scroll back up there's a "default" entry as well, so you can set it to boot into recovery mode by default. If you placed your new recovery section below the old one, that probably makes it section number 2.

Back to video drivers - I think it's unlikely that selecting a specific SiS adaptor would work better than "SiS generic". I don't think there's more than one driver, and it will autodetect which adaptor you have.

You should be able to configure higher resolutions than 800x600 using the VESA driver. The disadvantage is it will tend to lack any sort of hardware acceleration, which can make it slow especially at higher resolutions.

What you have to do is configure your monitor manually - where modern drivers would auto-detect it. Bring up the Ubuntu X configuration popup again. On Ubuntu Hardy, you should be able to do this by booting into recovery mode and selecting the "xfix" option from the recovery. Now configure a monitor; look for your specific monitor or try an appropriate generic monitor with the right resolution / refresh rate (or by trial and error :-).

W.r.t. wireless, as with the graphics adaptor you first need to identify what it is. Many wireless adaptors are supposed to be configured out of the box. Unless your laptop requires special laptop-specific ACPI fiddling, the wireless should be enabled automatically. If it _does_ require a laptop-specific ACPI enable, you may be out of luck given that your laptop is not very widely used. I'm thinking of kernel modules which are described as "XXX laptop extras" like "asus-laptop".

I'm not very familiar with this new Ubuntu X configuration popup, but on my computer it's not been very specific with error messages. If you still want to investigate the SiS driver, please post:

1) the output from running the "lspci" command in a terminal, which should provide identifying information for your graphics adaptor among other things

2) the contents of /var/log/Xorg.0.log, immediately after changing the xorg.conf device from "vesa" to "sis". This should show the *precise* error messages from the sis driver. Unfortunately I suspect going through the "low resolution" popup will restart the X server, overwriting this logfile. Therefore I would ask you to

i) set the device driver to sis in xorg.conf
ii) restart X, e.g. by rebooting.
iii) switch to a text console using Ctrl+Alt+F1, log in, and make a copy of the current logfile contents. E.g. "cp /var/log/X0rg.0.log ." will put it in the current directory, .

Revision history for this message
Ashley Verinder (averinder) said :

Thanks again for your help Alan! I'll post the requested outputs below:

1) lspci output -

2) xorg.0.log -

3) xorg.conf -

I'm sorry, but I couldn't find the area in xorg.conf where I should change! I ran x-fix from recovery console, but cannot see now where to change to sis like you said I should (and like I did last night). Hopefully the outputs above will be enough to point us in the right direction.

Thanks again for your help!!

(BTW - Wifi is Realtek 8187B)


Revision history for this message
Ashley Verinder (averinder) said :

Sorry - forgot to mention - editing the boot script worked nicely - no longer have to manually input those commands

Thanks again


Revision history for this message
Alan Jenkins (aj504) said :

Good work!

You can't find the option to specify SiS instead of Vesa in xorg.conf because it is indeed not there :-D. Interestingly, X is autodetecting the Vesa driver and not SiS, which makes me wonder. In case I waffled too much and wasn't clear - I've no particular reason to believe the SiS driver can be made to work, but - if you manually specify your monitor - the Vesa driver will be able to drive it at it's native resolution.

Anyway, you can try adding the driver option back in the device section of xorg.conf:

Section "Device"
        Identifier "Configured Video Device"
        Driver "sis"

(I assume the driver name is just "sis"; hopefully you can remember if that's not the case).

Revision history for this message
Alan Jenkins (aj504) said :

W.r.t. rtl8178B: there are success reports for internal laptop wireless with ndiswrapper, but you have to set that up yourself. <>

I actually have the external USB version of the 8178, which I believe is supported under Ubuntu. (I installed a more recent kernel myself, 2.6.25, which definitely supports it). Unfortunately the final "B" is significant and requires a new driver.

If you look at <>, there is a third-party linux driver for the 8178B available as source code, against kernel 2.6.24 (which is presumably what you're running). I would hope Ubuntu have packaged it - they did so with the original 8178 driver before it was merged into the mainline kernel. I don't know whether they have, but if you find they haven't then you should file a bug.

I should warn you that old versions of the original 8178 driver was unreliable and burnt out one of my adaptors after prolonged experimentation. I suspect your internal wireless is not replaceable :-). If you try the native linux driver for the 8178B and it gets hot, disconnects and has to cool down before it works again - I'd recommend you report that and stop using it.

Can you help with this problem?

Provide an answer of your own, or ask Ashley Verinder for more information if necessary.

To post a message you must log in.