nvidia module doesn't build agains 2.6.33-rc

Asked by mokabar on 2010-01-04

trying to compile the nvidia module with dkms fails:

dkms build -m nvidia -v 190.53 -k 2.6.33-rc2 --kernelsourcedir /usr/src/linux-headers-2.6.33-rc2/

DKMS make.log for nvidia-190.53 for kernel 2.6.33-rc2 (x86_64)
Mon Jan 4 23:54:22 CET 2010
If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Error 1

any idea, why?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-driver-nv Edit question
Assignee:
No assignee Edit question
Last query:
2010-01-05
Last reply:
2010-02-17

Just add the nvidia ppa:
https://launchpad.net/~nvidia-vdpau/+archive/ppa

Then run:
sudo apt-get install nvidia-glx-190

You could even try the 195 driver.

mokabar (tim-klingt) said : #2

actually, i _am_ using the nvidia ppa:

apt-cache show nvidia-glx-190 | grep Version
Version: 190.53-0ubuntu1~karmic~nvidiavdpauppa8

btw, trying to build nvidia-glx-195, i get the exact error message as with 190.

You neerd the kernel sources package for kernel 2.6.33-rc2 installing

I am on Lucid and have kernel:
Linux fileserver 2.6.32-9-generic #13-Ubuntu SMP Thu Dec 17 17:01:59 UTC 2009 x86_64 GNU/Linux

So you have installed a custom kernel from somewhere which we cannot really support. I use the 195 driver on my nvidia 6150 and it compiles and installs perfectly

mokabar (tim-klingt) said : #4

the kernel headers are installed and the nvidia module compiles fine against various kernel versions (most notably 2.6.32.2 and 2.6.31.6-rt19. of course, i can start bisecting the kernel for the commit, that breaks dkms, but this would be quite time-consuming.

betas are not supported by definition ... it is fine with me to just wait until 2.6.33 is out and people will start complaining about this ...

btw, all nvidia module versions i tried, compiled against every kernel headers below 2.6.33-rc1. the dkms script just stopped working with 2.6.33-rcX

Then log a bug so it gets attended.

chef (adotei) said : #6

I get the same error. I have posted the message below.

--------------------------------------------------------------------------------------------------------
Unpacking replacement nvidia-195-kernel-source ...
Setting up nvidia-195-kernel-source (195.30-0ubuntu1~karmic~nvidiavdpauppa5) ...
Removing all DKMS Modules
Done.
Adding Module to DKMS build system
driver version= 195.30
Doing initial module build

Error! Bad return status for module build on kernel: 2.6.33-rc5-allotey (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/nvidia/195.30/build/ for more information.
Installing initial module

Error! Could not locate nvidia.ko for module nvidia in the DKMS tree.
You must run a dkms build for kernel 2.6.33-rc5-allotey (x86_64) first.
Done.
--------------------------------------------------------------------------------------------------------

The make.log of the build has the same output as stated by th original bug poster.

Are there any solutions to this that I have missed?

Have you compiled your own kernel?

chef (adotei) said : #9

Yes, I compiled my own kernel with some help from the forums. How do I apply the suggested patch? Thanks for the help.

GeuS (pibgeus) said : #10

That patch is only applicable to nvidia-glx-190, and not the 195. And the fact is that it didn't worked for me too:

geus@geuset:/$ sudo patch -p0< /usr/src/patch.p
patching file usr/src/nv/conftest.sh
patching file usr/src/nv/nvacpi.c

but dpkg --configure and dpkg-reconfigure give me the same errors.

Can you help with this problem?

Provide an answer of your own, or ask mokabar for more information if necessary.

To post a message you must log in.