unable to install nvidia-linux-x86-71.86.11.pkg1.run

Asked by lptester on 2009-11-21

I would like to install the nvidia-linux driver to try to accelerate google earth display in Ubuntu 9.10. I tried to follow the steps in the nvidia instructions but get a cannot install error. My lspci output is: user@GDS:~$ lspci | grep -i vga
01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15).
This card works fine with google earth in WinXP. But when I load google earth in Ubuntu I get a message about emulation mode and need to upgrade the driver.
Advice would be appreciated.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-driver-nv Edit question
Assignee:
No assignee Edit question
Last query:
2009-11-23
Last reply:
2009-11-23

if you run:

gksudo jockey-gtk

are you offered the driver?

if not run:

sudo apt-get install nvidia-71-modaliases nvidia-glx-71

then reboot.

lptester (lptester) said : #2

I get this error:
user@GDS:~$ gksudo jockey-gtk

no driver offered

user@GDS:~$ sudo apt-get install nvidia-71-modaliases nvidia-glx-71
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package nvidia-71-modaliases

how do we get the package?

Can you please give the output of:

lsb_release -a

Thanks

Cristi Nistor (cristi-nistor) said : #4

http://packages.ubuntu.com/search?keywords=nvidia&searchon=names&suite=karmic&section=all

In Karmic nvidia-71 is not available anymore, but it can be found in Jaunty packages.

lptester (lptester) said : #5

Here is the lsb output:

user@GDS:~$ lsb_release -a
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch:cxx-3.0-ia32:cxx-3.0-noarch:cxx-3.1-ia32:cxx-3.1-noarch:cxx-3.2-ia32:cxx-3.2-noarch:cxx-4.0-ia32:cxx-4.0-noarch:desktop-3.1-ia32:desktop-3.1-noarch:desktop-3.2-ia32:desktop-3.2-noarch:desktop-4.0-ia32:desktop-4.0-noarch:graphics-2.0-ia32:graphics-2.0-noarch:graphics-3.0-ia32:graphics-3.0-noarch:graphics-3.1-ia32:graphics-3.1-noarch:graphics-3.2-ia32:graphics-3.2-noarch:graphics-4.0-ia32:graphics-4.0-noarch:qt4-3.1-ia32:qt4-3.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 9.10
Release: 9.10
Codename: karmic
user@GDS:~$

Should we be looking for nvidia-71 in jaunty packages?

ok I suggest booting to recovery root console and running the package from there

You will need to run:

chmod +x nvidia-linux-x86-71.86.11.pkg1.run

to make it executable then run it with

./nvidia-linux-x86-71.86.11.pkg1.run

(assuming your PWD is the folder containing the file)

It will then install, you may get a warning about the correct run level but simply follow the instructions given

lptester (lptester) said : #7

Thanks for your input. The nvidia-71 file is now executable script but it seems that to run the nvidia installer I would have to stop the X server. I am reluctant to mess with this without a better understanding of editing the X config file. I am also struggling to boot to "recovery root console" and can't find any pointers on how to do this. Can you help?

Reboot and when grub shows up select recovery mode, the system will boot some and you can select root console

You can now launch the script and install the driver. As I said earlier, you may get a warning about being in the wrong runlevel but you will get told how to change it

Once installed you will need to manually run:

sudo apt-get install nvidia-settings

which you can then use to configure the settings

lptester (lptester) said : #9

Well nvidia driver 71.88.11 seemed to install in level 3 without errors.
However sudo apt-get install nvidia-settings did not result in any nvidia settings to configure. Instead I get this message: "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server".
Please advise.

run:

sudo nvidia-xconfig

like it tells you to. You can now run:

gksudo nvidia-settings

To configure the device.

lptester (lptester) said : #11

No joy, reboot stalled with a black screen. I think we have spent enough time on this project that turned out to be more difficult than anticipated. I don't understand the run codes well enough to fix what went wrong. Maybe kernel 2.6.31.15 doesn't like the nvidia-71 driver. So after format/reinstall/update I have a working system again with the default driver.
Thanks for your help and patience.

Can you help with this problem?

Provide an answer of your own, or ask lptester for more information if necessary.

To post a message you must log in.