Cannot Download/Install Third Party Open Source Software & GPU Driver

Asked by Pabs on 2009-10-23

Hello! I've been using Ubuntu 9.04 in my office for quite some time and found it to be quite useful.

I installed the same software using the "Install within Windows" option. Now I'm running the software in dual boot and I wanted to install some 3rd Party software. I've been trying to install KDENLIVE and AUDACIOUS since last night, but I just cannot download from the Add/Remove feature. I have no problem in doing the same thing in the office, but the connection there is worse than dial-up. Here at home on the other hand, I cant take advantage of the connection speed.

The error goes this way:
-------------------------------------------------------
AN ERROR OCCURED
The following details are provided:

E: Could not get lock /var/cache/apt/archives/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the download directory
==================================================
Another problem is that the hardware driver window hangs when I click "Activate" on the nVidia 180 driver. And when I try closing the window, I can't. This does not happen in my office also.

Could my PC have something to do with it?

OFFICE PC SPECS:
> C2Q 6600
> 2gb DDR2-533 RAM
> 160gb HDD
> nGF 8500GT DDR2 GPU
> Ubuntu 9.04 (upgraded from 8.10) OS with no dual boot

HOME PC SPECS:
> Pentium D 820 (dual core)
> 4gb DDR2-1066 RAM
> 640gb HDD
> nGF 8600GT DDR3 GPU
> Ubuntu 9.04 (installed from USB boot drive) OS, secondary boot from Win Vista

Sorry for trying to post 2 problems at the same time. But I think the reason why I can't download the software/driver is rooted on the same problem. Thank you!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-driver-nv Edit question
Assignee:
No assignee Edit question
Solved by:
Pabs
Solved:
2009-10-23
Last query:
2009-10-23
Last reply:
2009-10-23

There are many ways to install and update the software on your computer, but they all use the same back-end called apt. The system only allows one application at a time to manipulate installed software.
The "Could not get lock" error indicates that another process is using apt. Note that adding the nVidia driver also counts as adding software. The solution would be: make sure that all package managers, driver installers have stopped. Then install the driver and after it's finished, install extra software.

Pabs (olbap3) said : #2

Wow! I'm impressed at the speed of the response. I'll try to see if I could install the nVidia driver later since I'm in the office now.

1] Just an observation that I remember: The progress bar for the nVidia installation suddenly disappeared while it was installing. Little did I know that there was another error (I forgot what it said) in another workspace.

2] When I clicked on System>Administration>Hardware Drivers to reinstall the driver for nVidia, it said "there are no proprietary drivers installed in your system", or something to that effect (again, I forgot the exact message).

Pabs (olbap3) said : #3

Hello again. After the Nth time trying to resolve my problem, I did the following:

1) Fell back to 8.04 Hardy Heron version (after 3 installs, I got the process to go beyond "Scanning the Mirror" stage @ 82%)
2) After finishing the installation, Ubuntu detected my hardware, particularly my GPU, an 8600GT. Problem is, it says that the GPU driver I'm using is glx-new, but the driver is "Not in Use"
3) I changed DNS from open to the DNS offered by our ISP
4) After changing DNS, I got to update my OS. Still updating as of now. Hopefully, the upgrade will solve the problem in #2.

Thank you very much for your help!

It's a shame you had to fall back to 8.04. I like to think it wasn't necessary, but I can't be sure. The fact that you had to change your DNS settings is at least interesting. If you can't download anything from the Ubuntu servers, this would imply that jockey is trying in vain to install the nVidia driver and thus locking the apt system, so you can't install anything.
I've had problems with installing drivers too. Usually a reboot solved them. Anyway, I hope you'll try out 9.10. Good luck!