Ubuntu 9.10 cant find root device after Nvidia install

Asked by johan stenlund on 2009-10-16

Couldn't find were to add the Bug report so i write it here... hope it's useful any way.

After installing 9.10 beta everything works fine, updating works fine.
Then i install the proprietary Nvidia driver, the recommended one out of three. (newest one, higest ver. number i think)

After the computer restart it cant find root device..

From screen:

Gave up waiting for root device. Common problems:
- Boot args (cat /proc/cmdline)
  - Check rootdelay=(did the system wait long enough?)
  - Check root= (did the system wait for the right device?)
-Missing modules (cat /proc/modules; ls /dev)

Alert /dev/disk/by-uuid/xxxxx-xxx-xx-xxx dones not exist
Dropping to a shell!

(initramfs)

I have tryed reinstall but same thing happens again then installing Nvidia driver

New thing happend during writing this... after rebooting a couple of times i tryed an older Kernel from GRUB,
It dident work, But i did come to Terminal loggin prmomt and the screen was flickering.
Reboted and 9.10 started up again, (but the Nvidia proprietary driver Was not installed)

Hope it does any sens.

Best Regards
Johan Stenlund
Happy ubuntu user! ;O)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-driver-nv Edit question
Assignee:
No assignee Edit question
Solved by:
johan stenlund
Solved:
2009-10-17
Last query:
2009-10-17
Last reply:
2009-10-17
johan stenlund (info-dj-johan) said : #1

Have to add some ifo....

The driver i first installed was version 185,
Now then i locked ones more after rebooting some times another driver 173 is installed and working.

Best to you all

How are you installing the driver?

Have you dropped to root terminal to run:

sudo blkid

to check the IDs are right?

As long as you get the gold its cool. WTG :D

I too exactly have the same problem after installing the latest NVIDIA drivers. Can't figure out how to solve it. Any help would be appreciated.

johan stenlund (info-dj-johan) said : #5

Hi again!

Im not that familiar with the terminaltrix...
I use it sometime then i found a solution on the forum.

The installation of the Nvida driver was made buy the Proprietary Hardware(gnome) installer.
I picked the version 185 (rekomended driver) that made it crash....

How i solved it im not shure... I think ubuntu fixed it buy itself som way...
and changed t to Nvidia version 173 driver

But to Sreenivas Devaraju i could give the proposal to reinstall (its quite quick anyway)
And then install the Nvidia version 173 driver. this one works for me now...

Hope its solves your problem to!