nvidia driver in Ubuntu 9.04

Asked by Ivan on 2009-08-24

I have notebook Asus K50IN, and problems with installing nvidia driver in Ubuntu 9.04.
First let me describe how I installed OS on my notebook (read problems about installation on Asus K50IN here https://answers.launchpad.net/ubuntu/+question/76133).

I've decided to download and install earlier version (ubuntu-8.04.3-desktop-i386). Installation was successful. After that I've updated my system to v8.10 via Update manager - but the same bug appeared after rebooting.
But this bug appeared when grub loaded Ubuntu 8.10, kernel 2.6.27-14-generic, and there was one more item in menu - with kernel 2.6.24-24-generic - and it was working, Ubuntu have been loaded successfully.
Then I've updated to v9.04, but after reboot the same bug.
But again this bug appeared when grub loaded kernel 2.6.28-15-generic, and when I choose another one from list - kernel 2.6.24-24-generic - Ubuntu have loaded successfully. But OS loading indicator was like in v8.10 :) And turn-off indicator is native 9.04 :)

After that I've tried to install nvidia drivers for my video adapter. The default version 180 didn't work - after reboot display was blinking with different coloured squares and lines, when gdm should be started. So I've booted in recovery mode and fixed graphic problems (switched nvidia drivers off).
I've tried to install versions 185.18.31 and 185.18.14 manually, but had bad luck - installer told me that:
no precompiled kernel...
And I don't know what to do with it. Here is the dialog between me and installer:

1. You are ruuning in runlevel 1...... It's recommended to switch runlevel3. Quit installation? (Y|N) -> N
2. Licence (Accept|Decline) -> Accept
3. Download kernel? (Y|N) -> N
4. No precompiled kernel interface was found (OK) -> OK
5. The CC version check failed (требуется gcc4.2, у меня - 4.3) Abort? (Y|N) -> N
6. ERROR: unable to find the kernel source tree for the currently running kernel...... (OK) -> OK
7. ERROR: Installation has failed. Please see the log file...... (OK) -> OK

I've tried to download kernel on step 3, but there is no suitable one on nvidia site - and dialog continues the same way.
So any recommendations?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-driver-nv Edit question
Assignee:
No assignee Edit question
Last query:
2009-08-25
Last reply:
2009-10-31
Daniel Drummond (dmdrummondx) said : #1

What video card exactly is in this laptop?

To help you better we need some infos about your hardware so please open a Terminal from the menu Applications → Accessories → Terminal and type:

lspci

lspci is lower of LSPCI

copy and paste result here.

Thank you

Ivan (somerussian) said : #3

~$ lspci
00:00.0 Host bridge: nVidia Corporation MCP79 Host Bridge (rev b1)
00:00.1 RAM memory: nVidia Corporation MCP79 Memory Controller (rev b1)
00:03.0 ISA bridge: nVidia Corporation MCP79 LPC Bridge (rev b3)
00:03.1 RAM memory: nVidia Corporation MCP79 Memory Controller (rev b1)
00:03.2 SMBus: nVidia Corporation MCP79 SMBus (rev b1)
00:03.3 RAM memory: nVidia Corporation MCP79 Memory Controller (rev b1)
00:03.5 Co-processor: nVidia Corporation MCP79 Co-processor (rev b1)
00:04.0 USB Controller: nVidia Corporation MCP79 OHCI USB 1.1 Controller (rev b1)
00:04.1 USB Controller: nVidia Corporation MCP79 EHCI USB 2.0 Controller (rev b1)
00:08.0 Audio device: nVidia Corporation MCP79 High Definition Audio (rev b1)
00:09.0 PCI bridge: nVidia Corporation MCP79 PCI Bridge (rev b1)
00:0b.0 SATA controller: nVidia Corporation MCP79 AHCI Controller (rev b1)
00:0c.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
00:10.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
00:15.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
00:16.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
03:00.0 VGA compatible controller: nVidia Corporation Device 0873 (rev b1)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
05:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

I have read an italian post on a forum http://telperion.wordpress.com/2007/05/09/nnn-unaltra-guida-per-installare-i-driver-nvidia-debian-ubuntu/ but think you can install and give a try to "envy" package https://launchpad.net/envy

To install envy please using a terminal

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install envyng-qt

You will find envy into the menu item i don't remember the position.

Hoe this helps

terrysadel (merryterrys) said : #5

Hmm, In Jaunty, the Nvidia 173 and 96 drivers were offered under `hardware drivers' for my FX550, and 173 worked fine, however on the `karmic' upgrade, I just got a blinking TTY log-on, and my key presses were only intermittently recognized under the default 2.6.31.14 kernel offered. I booted to the 2.6.31.16 [second offer] kernel, and had video, but no DBT tuner [haup. 1100] or modem [huawei E3553. Setting the Xorg to "nv" gave me a boot in ~14, and choosing driver version 96 worked fine on reboot.
YMMV. Hope this is some help

Can you help with this problem?

Provide an answer of your own, or ask Ivan for more information if necessary.

To post a message you must log in.