Updates installed today broke nvidia

Asked by Jim on 2009-07-29

I allowed Ubuntu to update this morning, without really paying attention to what was updated. After the required reboot, I got error messages relating to graphics and I only get one monitor working. Here is the error Message:

<b>Ubuntu is running in low-graphics mode</b>

The following error was encountered. You may need to update your configuration to solve this.

(EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
(EE) NVIDIA: system's kernle log for additional error messages.
(EE) Failed to load module "nvidia" (module-specific error, 0)
(EE) No drivers available.

<Error message ends>

After I clear that, I get a message box with 4 choices:
1) Run Ubuntu in low-graphics mode for just one session (I get full resolution but only 1 screen)
2) Reconfigure graphics (This runs, but a reboot puts me in the same place)
3) Troubleshoot the error (Takes me to another screen)
4) Exit to console login (Self-explanatory)

Selecting 3 gives me a new message box with 4 choices:
1) Review the xserver log file
2) Review the startup errors
3) Edit the configuration file
4) Archive configuration and logs

Graphics = nvidia 8800GT, Driver: Linux-x86_64 185.18.14 (nvidia-installer --update reports it's the latest version despite the fact that the nvidia website says there's a 185.18.19)

Let me know if any further info is required (log files, etc.) Thanks in advance.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-driver-nv Edit question
Assignee:
No assignee Edit question
Solved by:
Larry Jordan
Solved:
2009-09-22
Last query:
2009-09-22
Last reply:
2009-07-30
Best Larry Jordan (larryjor) said : #1

     Yep. Had Nvidia on my old computer (not same card, but had one). From what I remember, it depends on the kernel, so your best bet is to re-install Nvidia driver. If you had changed anything major in the configuration, you might want to use the "Archive configuration and logs" option before you do, but after reinstalling I think your problem will be taken care of.

Jim (jjcanaday) said : #2

Thanks Larry Jordan, that solved my question.

Alex (ahammond9260) said : #3

Okay total rookie question here, I'm having the exact same issue. I followed all the instructions then I clicked the archive configuration and logs button and it told me to look at org_backup_file. I tried running that in the terminal and I searched the computer for that. I'm at a total loss.

Alex (ahammond9260) said : #4

Okay total rookie question here, I'm having the exact same issue. I followed all the instructions then I clicked the archive configuration and logs button and it told me to look at org_backup_file. I tried running that in the terminal and I searched the computer for that. I'm at a total loss.

Jim (jjcanaday) said : #5

Alex,

If you are having the exact same problem I described in the original post, this should help you. (Apologies to Ubuntu experts if I'm not entirely correct - this is just what I understand....) If you've recently installed an update to Ubuntu that required a reboot, it is most likely that the update required a kernel re-compile. For whatever reason, the NVidia driver does not automatically incorporate into that new kernel. All you have to do is re-install the driver.

If you know where you've got a copy of the NVidia driver, skip this step. If you don't know where the driver file is, boot to the "low-resolution" graphics mode, go the web and download a copy. (You may want to do this just to get the latest version anyway.) Here is the site for the latest 64 bit version that I would download:

http://www.nvidia.com/object/linux-display-amd64-256.35-driver.html
(Downloads the file NVIDIA-Linux-x86_64-256.35.run)

Make sure you know the full path to this file.

Now you need quit the graphical shell. I don't remember how to do that off the top of my head - if you don't know, just re-start your computer but, at the error message where you give options on how to contiue, select "Exit to console login" and use your regular login credentials.

Now, from the terminal, run the command:

sudo sh <name of nvidia driver.run> where the name of the file includes the full path to the file.

That should launch the NVidia install routine. I don't remember if tells you that you need to restart after it's done but, you do.

I hope this helps.