Ubuntu 9.04 x86_64, crashed after update to kernel 2.6.28-13 generic, because Nvidia driver.

Asked by ubuntin on 2009-06-21

Hi!

Everything was working fine until today, updated Ubuntu 9.04 x86_64, from (kernel 2.6.28-11 / Nvidia driver version 96.43.10), to Kernel 2.6.28-13, then after restart, It just didn't work. I have an error message window saying:

EE NVIDIA (0) Failed to load the NVIDIA Kernel module!

I tried many things to make it work, but each time I try, the system crashed after attempt to Login with the new Kernel. Some how Kernel 2.6.28-13, conflicts with the Nvidia Driver, the only way to use this kernel, is to Login with a lower resolution for one session.

I went back to the previous Kernel and everything works fine.

I have never been able with any kernel to change the automatic resolution of 1280x800, to a lower resolution and save it, to keep it that way. For some reason it can not be saved, the next time I login, it goes back to the default 1280x800???

Any help, will be very much appreciated,

Ubuntin
Laptop Presario R3000
AMD 64

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-driver-nv Edit question
Assignee:
No assignee Edit question
Solved by:
Petr Jendrejovský
Solved:
2009-06-26
Last query:
2009-06-26
Last reply:
2009-06-26
Outdooralex (alex-outdooralex) said : #1

I have the same problem.

Also 9.04, 64bit, after update to 2.6.28-13 Nvidia failed to load

Outdooralex (alex-outdooralex) said : #2

I have the same problem.

Also 9.04, 64bit, after update to 2.6.28-13 Nvidia failed to load

trungly (temp-trungly) said : #3

I too have the same problem.
Jaunty 9.04, 64bit
kernel version: 2.6.28-13
nVidia driver version: 185.18.10, using TwinView
dual GeForce 8600GTS cards

booting to kernel 2.6.28-11 works fine.

Jeruvy (jeruvy) said : #4

I too noticed the same problem and created a bug report for it. I'm not entirely sure it's valid as the nvidia drivers were not installed via apt, but from manual download and do not show up properly in the restricted driver area. But I figured it could not hurt.

When this error occurred I attempted to continue to boot into low-res mode, but the boot process simply hung forcing a hard reboot.

For now, boot into the 2.6.28-11 kernel, which works fine

Jean Noel (jeannoelsand) said : #5

I just installed the latest updates. To my dismay, I had to boot on th previous kernel 2.6.8-11. My Nvidia card failed to load. Too bad...
Any idea where to start?

Outdooralex (alex-outdooralex) said : #6

hello,
i solved it then but I'm very sorry that now I can't remember how i did it.

I think I installed all the updates and the kernel again and also updated the Nvidia drivers

Weirdly the first kernel-update put 2.6.8-13 server which doesn't work and is still in my boot-menu. The second entry that works now reads 2.6.8-13 generic. I think it doesn't have to do with that though...

good luck
Alex

Just run "apt-get install linux-restricted-modules-2.6.28-13-server". When it's done, nvidia module will reinstall automatically and then everything works fine.

Oh, sorry, I've made a mistake. Run "apt-get install linux-headers-2.6.28-13-server" instead. Header files are required to recompile(?) that module.

Jean Noel (jeannoelsand) said : #9

I really don't know what to say. I started up my pc on the new kernel, and to my amazement, everything was back to normal. Was the driver not loading before?

ubuntin (sotoananda) said : #10

Hello everybody!

I was following all the comments, waiting for a solution until now.

Thanks to Petr Jendrejovský, who gave me a hint, I solved the problem.

For some strange reason, when I did the update to Kernel 2.6.28-13 x86_64, the updater forgot (I guess), to install these modules, and that was the reason why the system crashed when trying to load the Nvidia driver.

Modules:

1. linux-headers-2.6.28-13 (2.6.28-13.44)
2. linux-headers-2.6.28-13-generic (2.6.28-13.44)
3. linux-restricted-modules-2.6.28-13-generic (2.6.28-13.17)

Today, from Kernel 2.6.28-11, I installed those modules mentioned above, restarted to Kernel 2.6.28-13, and booted system without trouble, this time everything is working fine so far... Yeah!!, Fiesta!!!

I hope this help,

Ubuntin.

ubuntin (sotoananda) said : #11

Thanks Petr Jendrejovský, that solved my question.

MikeMc (mikecmcleod) said : #12

I have the same problem, but reverting to previous kernel 2.6.28-11, still does not work.
What I would like to know is how do I revert from the last upgrade?

MikeMc (mikecmcleod) said : #13

I have just fixed the problem by rebooting in to recovery mode, dropping to root shell and taking the option to fix x errors. Two reboots later and I have the X windows running as normal.

MikeMc (mikecmcleod) said : #14

I plucked up the courage to turn on the nvidia (180) driver and it works! And my wobbly windows are back with the 2.6.28-13 kernel.

Richard Ponce (rwponce) said : #15

I had the same problem (I originally downloaded and installed drivers from the nVidia site). I installed linux-headers-2.6.28-13-server per Petr Jendrejovský's instructions (thanks Petr). It didn't work out of the gate, but then after some digging I found and followed sdennie's post at: http://ubuntuforums.org/showthread.php?t=835573 which includes a script and instructions to automate creation of nVidia's module after any kernel updates are applied. To fix my existing problem I booted up in low-res mode, invoked his script manually, passing it the new kernel name: 2.6.28-13-server (in my case). Reboot, it worked. I now have the script in place for future kernel changes.

Jeruvy (jeruvy) said : #16

Yup I can confirm also that getting an update on the machine and allowing it to get into the low-res options and attempting recovery fixed it. I've not got the nvidia drivers working yet, but that is the next step. Why it hung twice attempting to login to recovery was very strange but it's working fine now.