Ubuntu is running in low graphics mode with low resolution.

Asked by Ethan

Hi, I'm fairly new to Linux and am running Ubuntu 8.04. When i installed it, it said it was running in low graphics mode. My friend was able to get the resolution to 1024 instead of 800 but thats still low for my computer. Windows gets 1280. Also, all of the updated kernels want to run in low graphics mode now too. How do i get my resolution/ graphics fixed?
HP Pavillion dv6700 (Laptop) AMD Dual core 1.9ghz tk-57, nVidia mcp67m (graphics card),

Question information

English Edit question
Ubuntu xserver-xorg-driver-nv Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
marcobra (Marco Braida) (marcobra) said :

Have you already tried System → Admin → Hardware drivers... ? To see if there are any restricted drivers available ?

Hope this helps

Revision history for this message
Ethan (esymonds47) said :

Yes. there weren't any.

Revision history for this message
Ethan (esymonds47) said :

hey, i just fixed the problem by downloading envyNG. Graphics work great now.

Revision history for this message
Jonathan Hamelin (jonobugs) said :

I'm a Ubuntu newbie and I decided that I wanted to run my old laptop with Linux.

I downloaded the 386 32 bit version and ran a live test with the CD and it appeared to work fine.

Since I'm new to all this, I didn't want to give up my old Windows XP OS, so I ran a dual boot system.

The installation seemed to go fine, but I think there were some error messages. They went by so quickly, I was unable to read them and I'm not sure how to get to the log files.

Anyway, upon boot up I get the message that Ubuntu is running in low graphics mode and when I press okay, I get the option to run it in low graphics mode reconfigure or troubleshoot the error.

Well, I tried reconfiguring, but nothing happens. I just get the same screen when I click it.

When I select "run it in low graphics mode this time only, I get a blank screen with a blinking cursor at the top left. I can type, but nothing seems to happen otherwise. I was able to switch to another window tty1 and login to a command prompt, but I'm unable to do much there. I then see another error (as follows)

The following error was encountered. You may need to update your configuration to solve this.

(EE) Preinit returned NULL for ""PS/2 Mouse"
(EE) Preinit returned NULL for ""AlpsPS/2 ALPS GlidePoint""
(EE) Preinit returned NULL for ""Macintosh mouse button emulation""

One message appears

Your CPU appears to be lacking expected security protections. Please check your BIOS settings, or for more information, run: /usr/bin/check-bios-nx --verbose

After running that command, the following information comes up.
This CPU is family 15, model 4, and has NX capabilities but is unable to use these protective features because the BIOS is configured to disable the capability. Please enable this in your BIOS. For more details, see: http://wiki.ubuntu.com/Security/CPUFeatures

I checked out the site but I'm unable to change anything like that in my BIOS. There simply is no NX entry.

Anyway, here is my laptop specifications:
Toshiba Satellite P30
Mobile Intel® Pentium® 4 processor 538 supporting Hyper-Threading technology 3.20 GHz, 533MHz PSB
L1 Cache 12KB/8KB (instruction/data), L2 Cache 1MB
 Operating System

ATI MOBILITY™ RADEON™ 9700 with 128MB DDR video memory.

As I said before, I'm a newbie to Linux, but I'm comfortable around computers, etc.

PS: I searched the forums, but I was unable to find a solution to this problem.

Revision history for this message
bidibulle (vendredidread) said :

 morning,i have a82852/82855 graphic card(intel) that run inLOW MODE,i went in xorg conf and it seem to be intel the driver so where is the lizzard?on a forum some people say cut the 3dim option and other fonctions,i dont want a restrictive version!!I'm waiting for 1004 ubuntu for the best of it!! mostly about video and sound:my activity! I've seen that intel is now seriously workin in the new version of ubuntu,is it effective for the 1004 vversion?do we get a link for that experience?

Revision history for this message
Jonathan Hamelin (jonobugs) said :

Hi Bidibulle,

This is a solved question, so it's unlikely you will get any help for your problem here. It's best to start a new thread and clearly state what you want.

As for the original problem, it had nothing to do with the graphics card so this solution won't help you at all.

Good luck!