NVIDIA Failed to Load the NVIDIA Kernel Module

Asked by Sanford on 2009-02-14

New install, first boot and all subsequent boots, "nvidia failed to load kernel" and defaults to low res 800x600 mode. I installed all updates. Tried installing, removing, and reinstalling each nvidia driver 173, 177, and two builds of 180. All list my chipset as supported by the driver. I tried removing all and using Envy. Envy reports that it install successfully, but it still does not work on reboot. All manual installs as root in recovery init 1 return the same "nvidia.ko" error after compiling the nvidia kernel it says likely due to "different gcc" versions.

The system reports that nvidia-xconfig is not running and xorg.conf does not see my nVidia Geforce:

Section "Device"
 Identifier "Configured Video Device"
 Driver "nvidia"

lspci returns:

00:10.0 VGA compatible controller: nVidia Corporation GeForce 7050/nForce 610i (rev a2)

Ubuntu 2.6.27-11-generic
gcc 4.3

Googled the error and found nvidia users have been reporting "nvidia.ko" and "nvidia failed to load" install errors with Ubuntu for three years or more and it is still not fixed. Very, very disappointed and very frustrating. If I don't get a fix to this soon I will wipe my install and move to SUSE or Fedora. Life is too short to waste banging my head against this wall.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-driver-nv Edit question
Assignee:
No assignee Edit question
Last query:
2009-02-15
Last reply:
2013-05-26
A. Denton (aquina) said : #1

Hy Sanford,

what Ubuntu realase exactly are you operating? Is it 8.10 with a 2.6.27 Kernel and i686 GNU/Linux? Obviously you're a bit more advanced than the typical GNU/Linux user. So please tell me what the compiller output was like. Any errors or warnings? I'm using an ATI graphics adapter. Isn't there a NVidia driver from the Ubuntu project available for you? Remember that Kernel updates require you to ALWAYS recompile the driver manually. This isn't probably your intetntion!? Finally is the result of lspci correct?

PS: SuSe is a good OS but requires some tweaking when it comes to multimedia. I strictly recommend you the latest v11 OpenSUSE. Fedora is a bitch with it's stupid RPM (dependency hells) and the short update cycles of 6 months. It's multimedia and driver capabilities are very good though -- especially for portable computers. PCLinuxOS (choose ext3, avoid ext2) is a tru alternative for KDE lovers and multimedia enthusiasts as well as gamers. It's also advised to choose the latest version (v2008), but don't forget it uses RPM underneath.

See also:
1] http://en.wikipedia.org/wiki/Comparison_of_Linux_distributions
2] http://futurist.se/gldt/gldt76.png

Sanford (schoolfield) said : #2

When I did a manual install I did recompile the the driver, this is
when I would get the "unable to find nvidia.ko" error (also complains
about the gcc being incompatible) and the compile failed - so it will
not compile cleanly (all three driver versions gave the same errors).
I failed to state that when I boot with the "standard" drivers (173,
177, or 180) my log file shows that the boot probe finds the nVidia
GPU and every step of the boot looks good until the very end where it
stops with the "failed to load" error. I am an old SCO UNIX guy, that
has been away for about seven or eight years from using Unix/linux
(and a bit behind and rusty/foggy), but it smells like a permission
error in the file structure that is possibly preventing access to a
needed file - except that I wiped the install clean and did a
complete fresh install and it does the same thing.

On Feb 14, 2009, at 9:46 PM, Aquina wrote:

> Your question #61016 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/61016
>
> Status: Open => Answered
>
> Aquina proposed the following answer:
> Hy Sanford,
>
> what Ubuntu realase exactly are you operating? Is it 8.10 with a
> 2.6.27
> Kernel and i686 GNU/Linux? Obviously you're a bit more advanced
> than the
> typical GNU/Linux user. So please tell me what the compiller output
> was
> like. Any errors or warnings? I'm using an ATI graphics adapter. Isn't
> there a NVidia driver from the Ubuntu project available for you?
> Remember that Kernel updates require you to ALWAYS recompile the
> driver
> manually. This isn't probably your intetntion!? Finally is the
> result of
> lspci correct?
>
> PS: SuSe is a good OS but requires some tweaking when it comes to
> multimedia. I strictly recommend you the latest v11 OpenSUSE.
> Fedora is
> a bitch with it's stupid RPM (dependency hells) and the short update
> cycles of 6 months. It's multimedia and driver capabilities are very
> good though -- especially for portable computers. PCLinuxOS (choose
> ext3, avoid ext2) is a tru alternative for KDE lovers and multimedia
> enthusiasts as well as gamers. It's also advised to choose the latest
> version (v2008), but don't forget it uses RPM underneath.
>
> See also:
> 1] http://en.wikipedia.org/wiki/Comparison_of_Linux_distributions
> 2] http://futurist.se/gldt/gldt76.png
>
> --
> If this answers your question, please go to the following page to
> let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/61016/+confirm?
> answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/61016
>
> You received this question notification because you are a direct
> subscriber of the question.

i dont understand, ...this command always works for me:

sudo apt-get install nvidia-glx-177

Why you dont set/install the needed version of GCC ??
Synaptic--->Packages--->Force Version...

Sanford (schoolfield) said : #4

Well I was sort-of-right, it is an access error, but a hardware
access error:

Feb 15 00:36:54 Ubuntu-desktop kernel: [ 11.680464] nvidia: module
license 'NVIDIA' taints kernel.
Feb 15 00:36:54 Ubuntu-desktop kernel: [ 11.971147] ACPI: PCI
Interrupt Link [SGRU] enabled at IRQ 23
Feb 15 00:36:54 Ubuntu-desktop kernel: [ 11.971221] nvidia
0000:00:10.0: PCI INT A -> Link[SGRU] -> GSI 23 (level, low) -> IRQ 23
Feb 15 00:36:54 Ubuntu-desktop kernel: [ 11.971302] NVRM: This PCI
I/O region assigned to your NVIDIA device is invalid:
Feb 15 00:36:54 Ubuntu-desktop kernel: [ 11.971303] NVRM: BAR1 is
0M @ 0x00000000 (PCI:0000:10.0)
Feb 15 00:36:54 Ubuntu-desktop kernel: [ 11.971455] NVRM: The
system BIOS may have misconfigured your graphics card.
Feb 15 00:36:54 Ubuntu-desktop kernel: [ 11.971539] nvidia: probe
of 0000:00:10.0 failed with error -1
Feb 15 00:36:54 Ubuntu-desktop kernel: [ 11.971636] NVRM: The
NVIDIA probe routine failed for 1 device(s).
Feb 15 00:36:54 Ubuntu-desktop kernel: [ 11.971703] NVRM: None of
the NVIDIA graphics adapters were initialized!

What is a probe error -1?

On Feb 15, 2009, at 2:02 AM, juancarlospaco wrote:

> Your question #61016 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/61016
>
> Status: Open => Answered
>
> juancarlospaco proposed the following answer:
> i dont understand, ...this command always works for me:
>
> sudo apt-get install nvidia-glx-177
>
>
> Why you dont set/install the needed version of GCC ??
> Synaptic--->Packages--->Force Version...
>
> --
> If this answers your question, please go to the following page to
> let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/61016/+confirm?
> answer_id=2
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/61016
>
> You received this question notification because you are a direct
> subscriber of the question.

Try passing some Kernel parameter, you know...

noapic nolapic noapm pci=noacpi

Cian Davis (davisc) said : #6

It seems that the nvidia-glx-177 and 180 packages need the linux-headers package. This is not a dep and probably should be. I will file a bug as well.

A. Denton (aquina) said : #7

Unfortunately I do not have the powers to change the state of this question to SOLVED, EXPIRED or INVALID. Someone here at Launchpad either grant me that permission or simply apply the change in state to this question, please.

Can you help with this problem?

Provide an answer of your own, or ask Sanford for more information if necessary.

To post a message you must log in.