Screen resolution I am trying to make 1440x900@60hz work

Asked by James B on 2007-04-05

I am attempting to setup Ubuntu with a benq FP92W monitor and a nvidia 7300LE, on the occasion I have managed to get it working at 60hz my fonts do not appear correct, numerous people have attempted to help be in #ubuntu none of which have managed to solve the problem..
Here is my xorg.conf

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
 FontPath "/usr/share/X11/fonts/misc"
 FontPath "/usr/share/X11/fonts/cyrillic"
 FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
 FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
 FontPath "/usr/share/X11/fonts/Type1"
 FontPath "/usr/share/X11/fonts/100dpi"
 FontPath "/usr/share/X11/fonts/75dpi"
 FontPath "/usr/share/fonts/X11/misc"
 # path to defoma fonts
 FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
 Load "bitmap"
 Load "ddc"
 Load "dri"
 Load "extmod"
 Load "freetype"
 Load "glx"
 Load "int10"
 Load "type1"
 Load "vbe"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "us"
 Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ExplorerPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "stylus"
  Option "Device" "/dev/wacom" # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option "Type" "stylus"
  Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "eraser"
  Option "Device" "/dev/wacom" # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option "Type" "eraser"
  Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "cursor"
  Option "Device" "/dev/wacom" # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option "Type" "cursor"
  Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
 Identifier "NVIDIA Corporation GeForce 7300"
 Driver "nvidia"
 BusID "PCI:2:0:0"
 VideoRam 262144
 Option "UseFBDev" "true"
EndSection

Section "Monitor"
 Identifier "BenQ FP92W"
 Option "DPMS"
 HorizSync 31-81
 VertRefresh 50-60
EndSection

Section "Screen"
 Identifier "Default Screen"
 Device "NVIDIA Corporation GeForce 7300"
 Monitor "BenQ FP92W"
 DefaultDepth 24
 SubSection "Display"
  Depth 1
  Modes "1440x900"
 EndSubSection
 SubSection "Display"
  Depth 4
  Modes "1440x900"
 EndSubSection
 SubSection "Display"
  Depth 8
  Modes "1440x900"
 EndSubSection
 SubSection "Display"
  Depth 15
  Modes "1440x900"
 EndSubSection
 SubSection "Display"
  Depth 16
  Modes "1440x900"
 EndSubSection
 SubSection "Display"
  Depth 24
  Modes "1440x900"
 EndSubSection
EndSection

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "Default Screen"
 InputDevice "Generic Keyboard"
 InputDevice "Configured Mouse"
 InputDevice "stylus" "SendCoreEvents"
 InputDevice "cursor" "SendCoreEvents"
 InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
 Mode 0666
EndSection

Does anyone have a possible fix for this?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-driver-nv Edit question
Assignee:
No assignee Edit question
Last query:
2007-04-05
Last reply:
2009-10-09
trylik (marek-nasionka) said : #1

i had :)

in 7.04 you need to go to the system settings -> monitor & display -> Hardware

then change the display #1 settings (you must run administrator mode) and choose standard section and flat panle 1440x900

also you have to change 4:3 to 16:9 now restart X and go again to this setting now you should be able to change the resolution to 1440x900

James B (jamesb-fernie) said : #2

I can use 1440x900 at 75hz but I need 60hz, if I can help it I don't want to download feisty until the full version is released.

obi (obi22) said : #3

When I was setting my Samsung 931BW all the resolution and refreshrate problems nvidia's driver solved. All xorg.conf modifications was useles for me, just install gfx card driver and (if You don't have it in the menu) run:
sudo nvidia-settings
set what you need and save to xorg.conf (that's why you need run this with sudo).

James B (jamesb-fernie) said : #4

Unfortunatly that solution has not worked for me either, when I run nvidia-settins it produces a number of errors such as the following: ERROR: Unable to assign attribute XVideoSyncToDisplay specified on line 47 of
       configuration file '/home/james/.nvidia-settings-rc' (no Display
       connection).

Robert Clipsham (mrmonday) said : #5

How have you installed your drivers? If you use envy, it will automatically set up your xorg, so that you can get the right resolution. http://www.albertomilone.com/nvidia_scripts1.html

obi (obi22) said : #6

... or visit http://www.xorg-conf.org/ - that service is trying to collect all possible xorg.conf files, because it is started couple of days ago you can check this config: http://aleks.vigio.pl/xorg_pl/files/silmethule_xorg.conf.txt :

# SPECYFIKACJA:
# Grafika: Gigabyte GeForce 7600 GS, sterownik nvidia
# Monitor: LCD Samsung SyncMaster 940MW, ekran: 16:10, 19"
# Mysz: standardowe ze scrollem, Logitech, kulka
# Klawiatura: standardowa, Chlcony
# Rozdzielczosc@Odswiezanie: 1440x900@60
# Wykomentowane wszystkie niepotrzebne mody, ustawienia, dorzucane
automatycznie przez konfiguratory...
#
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
  # path to defoma fonts
    FontPath "/usr/share/fonts/X11/misc"
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath "/usr/local/share/fonts"
EndSection

Section "Module"
  Load "i2c"
  Load "bitmap"
  Load "ddc"
  # Load "dri"
  Load "extmod"
  Load "freetype"
  Load "int10"
  Load "type1"
  Load "vbe"
  load "glx"
  load "v4l"
EndSection

Section "InputDevice"
  Identifier "Generic Keyboard"
  Driver "kbd"
  option "CoreKeyboard"
  option "XkbRules" "xorg"
  option "XkbModel" "pc105"
  option "XkbLayout" "pl"
  option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
  Identifier "Configured Mouse"
  Driver "mouse"
  option "CorePointer"
  option "Device" "/dev/input/mice"
  option "Protocol" "ExplorerPS/2"
  option "ZAxisMapping" "4 5"
  option "Emulate3Buttons" "true"
EndSection

#Section "InputDevice"
# Driver "wacom"
# Identifier "stylus"
# option "Device" "/dev/wacom"# Change to
# option "Type" "stylus"
# option "ForceDevice" "ISDV4"# Tablet PC ONLY
# # /dev/input/event
# # for USB
#EndSection

#Section "InputDevice"
# Driver "wacom"
# Identifier "eraser"
# option "Device" "/dev/wacom"# Change to
# option "Type" "eraser"
# option "ForceDevice" "ISDV4"# Tablet PC ONLY
# # /dev/input/event
# # for USB
#EndSection

#Section "InputDevice"
# Driver "wacom"
# Identifier "cursor"
# option "Device" "/dev/wacom"# Change to
# option "Type" "cursor"
# option "ForceDevice" "ISDV4"# Tablet PC ONLY
# # /dev/input/event
# # for USB
#EndSection

Section "Device"
  identifier "NVIDIA Corporation NVIDIA Default Card"
  boardname "nv"
  busid "PCI:1:0:0"
  driver "nvidia"
  screen 0
EndSection

Section "Monitor"
  identifier "SyncMaster"
  vendorname "Generic"
  modelname "1600x1200 @ 70 Hz"
  HorizSync 31.5-88.0
  VertRefresh 50-90
# modeline "640x400@85" 31.5 640 672 736 832 400 401 404 445 -hsync +vsync
# modeline "640x350@85" 31.5 640 672 736 832 350 382 385 445 +hsync -vsync
# modeline "720x400@85" 35.5 720 756 828 936 400 401 404 446 -hsync +vsync
# modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
# modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
# modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
# modeline "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
# modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
# modeline "1280x768@60" 80.14 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
# modeline "1280x720@60" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
# modeline "1280x800@75" 107.21 1280 1360 1496 1712 800 801 804 835 -hsync +vsync
# modeline "1280x768@75" 102.98 1280 1360 1496 1712 768 769 772 802 -hsync +vsync
# modeline "1280x720@50" 60.47 1280 1328 1456 1632 720 721 724 741 -hsync +vsync
# modeline "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
# modeline "1440x900@75" 136.49 1440 1536 1688 1936 900 901 904 940 -hsync +vsync
  modeline "1440x900@60" 106.47 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
# modeline "1600x1024@60" 136.36 1600 1704 1872 2144 1024 1025 1028 1060 -hsync +vsync
# modeline "1680x1050@60" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -hsync +vsync
# modeline "1680x1050@75" 188.07 1680 1800 1984 2288 1050 1051 1054 1096 -hsync +vsync
# modeline "1920x1200@60" 193.16 1920 2048 2256 2592 1200 1201 1204 1242 -hsync +vsync
  gamma 1.0
EndSection

Section "Screen"
  Identifier "Default Screen"
  Device "NVIDIA Corporation NVIDIA Default Card"
  Monitor "SyncMaster"
  DefaultDepth 24
  SubSection "Display"
    depth 24
    modes "1440x900@60"
# modes "1440x900@75" "1440x900@60" "1280x800@60" "1600x1024@60" "1280x720@50" "1680x1050@60" "1280x768@75" "1680x1050@75" "1280x800@75" "1920x1200@60" "1280x720@60" "1280x768@60" "800x600@60" "800x600@85" "800x600@75" "800x600@72" "800x600@56" "720x400@85" "640x350@85" "640x400@85"
  EndSubSection
EndSection

Section "ServerLayout"
  Identifier "Default Layout"
  screen 0 "Default Screen" 0 0
  InputDevice "Generic Keyboard"
  InputDevice "Configured Mouse"
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
  Mode 0666
EndSection
Section "ServerFlags"
EndSection

optimix (io-fx) said : #7

Hello,

I don't know if this helps, but I never managed to set up "Samsung 931BW" on my debian box with the vga cable.
I have switched on a dvi cable and everything works great at 1440x900.

Alex

I've just got BenQ FP92W working with 1440x900 on Ubuntu!!!

All you have to do (If you've already installed NVIDIA X driver) is to write to xorg.conf correct Monitor settings:

Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "CRT-0"
    HorizSync 31.0 - 81.0
    VertRefresh 50.0 - 76.0
    Option "DPMS"
EndSection

The main parts in monitor description are: HorizSync and VertRefresh . I've found their correct values in BenQ FP92W description.

I've forgot to mention:

After modifying xorg.conf you should chouse 1440x900 in NVIDIA X Server Settings

Can you help with this problem?

Provide an answer of your own, or ask James B for more information if necessary.

To post a message you must log in.