Help, my NVIDIA drivers are completely borked

Asked by Yang on 2011-11-10

I'm on Ubuntu 10.04 LTS and everything was fine up till about two hours ago, since when I've spent all my time trying to make things work again. I was trying to install the latest drivers from the NVIDIA website, v285.05.09 (since I'm currently using the latest drivers available in Ubuntu, nvidia-current v195.36.24, yet WebGL doesn't work in either Chrome or Firefox, and they always suggest that I try the latest driver versions).

But after installing this and rebooting, X starts with an error, prompting me to run in reduced graphics mode and/or restore my graphics settings. When I checked /var/log/kern.log I saw:

    NVRM: API mismatch: the client has the version 285.05.09, but
    NVRM: this kernel module has the version 195.36.24. Please
    NVRM: make sure that this kernel module and all NVIDIA driver
    NVRM: components have the same version.

My questions has two parts:

1. How do I actually make these latest NVIDIA drivers work?

2. If I try this out and it doesn't work...how do I roll back what I had before? Here's what I tried, all to no avail:

    - picking the restore graphics settings option in the initial error prompt from X

    - under Administration > Hardware Drivers, I see that the "NVIDIA (current)" option is already chosen/active, so I can't do anything here

    - ran `sudo dpkg-reconfigure nvidia-current`

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-driver-nv Edit question
Assignee:
No assignee Edit question
Solved by:
Yang
Solved:
2011-11-10
Last query:
2011-11-10
Last reply:
2011-11-10

Can you give the output of:

lsb_release -a; uname -a; dpkg -l | grep nvidia

Thanks

Yang (yaaang) said : #2

Sure:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.3 LTS
Release: 10.04
Codename: lucid

$ uname -a
Linux zs 2.6.32-35-generic #78-Ubuntu SMP Tue Oct 11 16:11:24 UTC 2011 x86_64 GNU/Linux

$ dpkg -l | grep nvidia
ii nvidia-173 173.14.22-0ubuntu11 NVIDIA binary Xorg driver, kernel module and VDPAU li
ii nvidia-173-modaliases 173.14.22-0ubuntu11 Modaliases for the NVIDIA binary X.Org driver
ii nvidia-96-modaliases 96.43.17-0ubuntu1.1 Modaliases for the NVIDIA binary X.Org driver
ii nvidia-common 0.2.23 Find obsolete NVIDIA drivers
ii nvidia-current 195.36.24-0ubuntu1~10.04.1 NVIDIA binary Xorg driver, kernel module and VDPAU li
ii nvidia-current-modaliases 195.36.24-0ubuntu1~10.04.1 Modaliases for the NVIDIA binary X.Org driver
ii nvidia-settings 195.36.08-0ubuntu2 Tool of configuring the NVIDIA graphics driver

ok let's clean this up and we can then reinstall the driver:

sudo apt-get --purge remove nvidia-173 nvidia-current nvidia-settings; sudo apt-get --purge autoremove

Then you can reboot and then run:

sudo apt-get update; sudo apt-get -y install nvidia-current

Yang (yaaang) said : #4

After uninstalling all nvidia* packages plus more fidgeting/reinstalling (at some point the NVIDIA installer started prompting me to install a modprobe.d file that would disable nouveau - I think this was key), everything just started working with 285. Thanks for your help, actionparsnip.