Failed to load nVidia Driver after kernel upgrade (Feisty Fawn 2.6.20-16)

Asked by soma4me on 2007-09-04

Hi,

Need help with nVidia Driver failure in X Server startup. First, some background:

1. I've installed Feisty Fawn with kernel version 2.6.20-15 couple of months ago.
2. Video card is nVidia GeForce 7300 GT
3. Installation of Feisty Fawn under kernel 2.6.20-15 went flawless. The video card was recognized and configured properly without any tweaking at all
4. System worked perfectly until last night when Update Manager prompted to upgrade to kernel 2.6.20-16.
5. From GRUB menu, I can still use 2.6.20-15 without any issue (what I'm using now). However, I'm getting the following error when 2.6.20-16 kernel is selected (from Xorg.0.log):

--BEGIN--
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "True"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "ramdac"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
--END--

On the other hand, under kernel 2.6.20-15, the nVidia driver is loaded correctly (from Xorg.0.log):

--BEGIN--
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "True"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce 7300 GT at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 524288 kBytes
(--) NVIDIA(0): VideoBIOS: 05.73.22.51.07
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 7300 GT at PCI:1:0:0:
(--) NVIDIA(0): Gateway FPD2275W (CRT-0)
(--) NVIDIA(0): Gateway FPD2275W (CRT-0): 400.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "1680x1050"
(II) NVIDIA(0): "1400x1050"
(II) NVIDIA(0): "1280x1024"
(II) NVIDIA(0): "1152x864"
(II) NVIDIA(0): "1024x768"
(II) NVIDIA(0): "832x624"
(II) NVIDIA(0): "800x600"
(II) NVIDIA(0): "640x480"
(II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
(--) NVIDIA(0): DPI set to (88, 88); computed from "UseEdidDpi" X config
(--) NVIDIA(0): option
(--) Depth 24 pixmap format is 32 bpp
--END--

I've posted this question in the forum, and got some help to installed the new glx package in the new kernel: Log into recovery mode of kernel 2.6.20-16, execute 'sudo apt-get install nvidia-glx-new', the installation was successful, and I can see the driver was updated from 1.0.9631 to 1.0.9755, however, I am still getting the same error starting X server when trying to get into the new kernel.

Is this a kernel bug? Do I need to get the driver from nVidia site? How do I fix it? Or, should I just stay in kernel 2.6.20-15 for now, and may be the next kernel upgrade will fix it?

Thanks for any help.

Thanks for any help!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-driver-nv Edit question
Assignee:
No assignee Edit question
Solved by:
soma4me
Solved:
2007-09-07
Last query:
2007-09-07
Last reply:
2007-09-06
rickyrockrat (rickyrockrat) said : #1

Somehow, the Nvidia driver is not bein re-compiled for the new kernel. The fast way (for me, anyway) would be to just download the driver from Nvidia and install it. If you still get the error, you can add nvidia to your /etc/modules file

soma4me (stairs2roof-yahoo) said : #2

rickyrockrat,

Thanks. Someone in the Forum also recommended the same. But I'd like to exhaust all possibilities within the 'Ubuntu channel' (for lack of a better term) first. Besides, there is risk involved in using the native nVidia driver -- I don't know the effect of it on the 2.6.20-15 kernel which is still working for me now -- hope this is understandable.

There are other guys in the forum recommending uninstall 20-16 then reinstalling it, what do you think?

Also, how do I specify nvidia in /etc/modules (I have nvidia-glx-new package installed)? What effect does this do?

Thanks for your help.

What I would try:

-uninstall the Nvidia driver
-modify the Xorg.conf file to put another driver for the first reboot (otherwise you will not be able to start the graphical interface). Maybe the unnistallation of the driver will do it, but I can't be sure.
-reboot in the new kernel
-use the Restricted Manager tool to try to install the Nvidia driver again.

If that's not working, download and install the Nvidia driver from Nvidia website.

Please note that solution #1 requires some basic knowledge of the terminal, because if the alternative driver you are trying is not working, you will need to change it using the command line.

soma4me (stairs2roof-yahoo) said : #4

Hi,

I finally fixed the problem by re-installing the restricted modules for 2.6.20-16. Here is what I learned:

If nVidia driver is giving you trouble and you 'need' to get into GDM, you can simply change the driver definition in xorg.conf file from 'nvidia' to 'nv'. Here is how:

(I'm using root terminal, if you are using regular terminal then you need to add 'sudo' in front of every command except 'cd')

cd /etc/X11/
cp xorg.conf xorg.conf.backup
vi xorg.conf

Then find the following section:

Section "Device"
    Identifier "nVidia Corporation G70 [GeForce 7300 GT]"
    Driver "nvidia"
    Busid "PCI:1:0:0"
EndSection

and change it to:

Section "Device"
    Identifier "nVidia Corporation G70 [GeForce 7300 GT]"
    Driver "nv"
    Busid "PCI:1:0:0"
EndSection

You now should be able to boot into the new kernel in normal mode. NOTE: since you are now not using restricted module, your OpenGL application (such as the screen saver) will not work properly, and you refresh rate may be limited. And, restricted-manager will not help, it will simply tell you that you don't need it.

To permanently fix the driver issue, you need to first boot into the recovery mode from GRUB menu. At command line, do the following:

apt-get update
apt-get install --reinstall linux-restricted-modules-2.6.20-16-generic

now you can boot into the new kernel normally :)

hanselang (lesnah) said : #5

Does not work for me...
Used as per instructed

hanselang, could you please first give us the content of your /etc/X11/xorg.conf file?
Just to check what driver you are using.
Also, what are your symptoms? Exactly the same?
How did you install the Nvidia driver? Using the restricted drivers manager (or Synaptic maybe), or did you download the driver from Nvidia website?

Please remember this:
-if you are using the nvidia driver installed by Ubuntu, it should be updated with the kernel update. So typically, no problem during update, one reboot, and here you go
-if you install the nvidia driver manually, you MUST recompile it each time you change to a new kernel. That's a bit troublesome, but the driver offers more possibilities with its graphical interface to change settings.

andersbrink (andersbrink) said : #7

The fix for me when the screen went black on 7.04 with updates (and no nvidia logo shows up)
during x startup was to add two "Option" to /etc/X11/xorg.conf in the device section:

Section "Device"
    Identifier "EN7300GS"
    Driver "nvidia"
    Option "Nologo" "true"
    Option "ConnectedMonitor" "CRT"
    Option "IgnoreDisplayDevices" "DFP,TV" # i guess this is redundant, bwtf...
EndSection

besides doing everything mentioned @ https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia