Lucid - trying to get nVidia drivers installed, incredibly frustrating

Asked by Don Cosler on 2010-09-27

Ok, first off.... I'm not an idiot. I'm a software developer, I have a rudimentary understanding of *nix commands, and I'm willing to learn. I'm also willing to spend hours digging through forums, trying to find answers.

1. I had an older machine sitting around, figured I would trying to get Ubuntu running on it. Ubuntu install went great of course.
2. On the FIRST reboot, I get a little dialog box telling me that Nouveau has some issue, and it forces me into "low-graphics mode". This old machine is probably 6 years old, and some digging tells me that it has ancient TNT/TNT2 graphics from nVidia. Awesome.
3. Low-graphics mode looks like crap, so I start digging to see if there is a better solution. Pretty quickly, I find out that nVidia actually DOES produce Linux drivers for my ancient hardware. Very cool. So I download them.
4. I'll spare you the horrid details of what happened next... but suffice to say, NOTHING that ANY of the forums/blogs has suggested will work for me. And I've been reading/trying for 3 days.

Will the nVidia installer work? Sometimes.
Will the "nvidia" module load? Never.
Will the "X server" do what it is supposed to do? I haven't a clue.
What would possess someone to name their software "X"? No idea there either.
How many more hours will I spend trying to fight this stupid driver? Depends if I can get any help. Obviously I'm making no progress by myself. :(

Thanks everyone.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-driver-nv Edit question
Assignee:
No assignee Edit question
Solved by:
Don Cosler
Solved:
2010-09-30
Last query:
2010-09-30
Last reply:
2010-09-30
delance (olivier-delance) said : #1

Go to System->Administration->Proprietary Drivers, and looks if you are proposed an NVidia driver for your graphic card.
I think it's first and easier step to do.

Don Cosler (dcosler) said : #2

I have. "No proprietary drivers are in use on this system." :(

delance (olivier-delance) said : #3

It's logical if you use "Nouveau". But are you proposed some proprietary driver from NVidia ?

Don Cosler (dcosler) said : #4

I will use ANY driver that WORKS. Problem is, the Nouveau driver does not work. As I stated before, a clean install of Ubuntu forces me into "low-graphics mode" EVERY TIME. I'm just looking for ANY solution that works. Obviously, nVidia has a driver that should work, but I can't seem to install it correctly.

delance (olivier-delance) said : #5

Go to System->Administration->Proprietary Drivers, and looks if you are proposed an proprietary NVidia driver for your graphic card.

Don Cosler (dcosler) said : #6

delance, thanks for the help.... but did you read my response before?

When I go to System->Administration->Hardware Drivers, I get this...
"No proprietary drivers are in use on this system."

delance (olivier-delance) said : #7

Perhaps my English is poor, but "No in use" is not "Not available".
My question was "Are you proposed to change to a proprietary driver ?"
It seems not, from your answer.
Usually, I don't help on driver issues. I will have a look tomorrow about TNT.
Did you download directly from NVidia site or from Synaptic ?
If you downloaded directly from NVidia, could you check both have same version ?
If you are not proposed proprietary driver, I presume Ubuntu is not aware you installed it.

Don Cosler (dcosler) said : #8

1. My Ubuntu install boots into "low-graphics mode" every time.
2. Yes, I am trying to change to a proprietary driver (nVidia). (to fix #1 above)
3. Yes, I downloaded the driver install package from nVidia.
4. Yes, I have tried to install the driver.
5. No, Ubuntu does not detect that I've installed the driver.

The lowest the closed source drivers go to is a GeForce2 so the nouveau driver will need to be blacklisted so the nv driver can run instead

if you run:

gksudo gedit /etc/modprobe.d/blacklist.conf

add this line:

blacklist nouveau

Save the new file and reboot it should then use:
xserver-xorg-video-nv
instead of:
xserver-xorg-video-nouveau

and may run.

Don Cosler (dcosler) said : #10

actionparsnip,
Thanks for the help! I already had blacklisted nouveau yesterday. Clearly the nv driver will work (although it doesn't look that good), but I'm more concerned with getting the nvidia driver working. The nv driver looks like it has some issues with my setup.

Mika Wahlroos (mpw) said : #11

I'm afraid you're out of luck with the proprietary nvidia driver. NVidia hasn't supported hardware older than the GeForce 2 in their new driver releases in a while, and the releases (71.86.x) that are old enough to support the TNT and TNT2 are not compatible with most recent Linux distributions.

Unfortunately I'm not familiar with the nouveau driver so I can't help directly with that, but could you try switching back to it and checking out if you can find any clues in /var/log/Xorg.0.log? Any errors or such? Also, you could try and see if there are any NVidia or NV related errors in /var/log/messages or in the output from the dmesg command.

Sam_ (and-sam) said : #13

Follow-up regarding Nvidia and xorg-1.9 incl. a list of concerned graphic cards: Bug #626974

Don Cosler (dcosler) said : #14

Thanks for clearing that up Mika. Saved me lots of hours of anguish. :)

Thanks everyone!

Sam_ (and-sam) said : #15

> I will use ANY driver that WORKS

In case you like testing this regards Maverick RC Ubuntu (not Kubuntu).
Afair on german forum (someone announced to all nvidia users on 2nd of october), nouveau tested with libgl1-mesa-dri-experimental runs very well, nvida-current needs to be deactivated.
http://packages.ubuntu.com/search?suite=default&section=all&arch=any&searchon=names&keywords=libgl1-mesa-dri-experimental