how to install a nvidia .run linux driver on ubuntu 10.04

Asked by Jack P Arason on 2010-09-22

I used the sudo apt-get install NVIDIA-Linux-x86_64-260.19.04.run
at the $ prompt

file:///home/jackdevon/Desktop/nvidia/NVIDIA-Linux-x86_64-260.19.04.run

and it all ways gives me this

jackdevon@jackdevon-desktop:~$ sudo su
[sudo] password for jackdevon:
ot@jackdevon-desktop:/home/jackdevon# sudo apt-get install NVIDIA-Linux-x86_64-260.19.04.run
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package NVIDIA-Linux-x86_64-260.19.04.run
root@jackdevon-desktop:/home/jackdevon#

I set the permissions all so.
I turned of the Xserver the file is not wrong it is in the fold on my desktop,
I log out and log back in using c and at the prompt
I used the
sudo apt-get install NVIDIA-Linux-x86_64-260.19.04.run

I have all the headers installed, and the Kernal I think is the same
Yes this file is on my desktop.

I tried everything I could I followed the instructions but I can not get this to install what should I do???????????
what should i do.

confussed

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-driver-nv Edit question
Assignee:
No assignee Edit question
Last query:
2010-09-22
Last reply:
2010-09-22

From the "ADDITIONAL INFORMATION" tab on the http://www.nvidia.com/object/linux-display-amd64-260.19.04-driver.html

"Installation instructions: Once you have downloaded the driver, change to the directory containing the driver package and install the driver by running, as root, sh ./NVIDIA-Linux-x86_64-260.19.04.run
One of the last installation steps will offer to update your X configuration file. Either accept that offer, edit your X configuration file manually so that the NVIDIA X driver will be used, or run nvidia-xconfig"

sudo -i
sh ./apt-get install NVIDIA-Linux-x86_64-260.19.04.run

Hope this help

dishantbt05 (dishantbt05) said : #2

One more easy process to install nvidia.
System>Administration>hardware drivers> search for drivers listed and installed> it will download drivers directly from internet and install>Check if you like.

Jack P Arason (devonsfindings) said : #3

root@jackdevon-desktop:/home/jackdevon# sh apt-get install NVIDIA-Linux-x86_64-260.19.04.run
sh: Can't open apt-get
root@jackdevon-desktop:/home/jackdevon#

This is the message I got after I but in the code in root.
sh: Can't open apt-get
Why? did I get this message

Jack P Arason (devonsfindings) said : #4

I tried this and this did not work either.

root@jackdevon-desktop:/home/jackdevon# find . | grep NVIDIA-Linux-x86_64-260.19.04.run
./Desktop/NVIDIA-Linux-x86_64-260.19.04.run
./Downloads/NVIDIA-Linux-x86_64-260.19.04.run
./NVIDIA-Linux-x86_64-260.19.04.run
root@jackdevon-desktop:/home/jackdevon# ./NVIDIA-Linux-x86_64-260.19.04.run
bash: ./NVIDIA-Linux-x86_64-260.19.04.run: Permission denied
root@jackdevon-desktop:/home/jackdevon# sh ./NVIDIA-Linux-x86_64-260.19.04.run
root@jackdevon-desktop:/home/jackdevon# sh ./NVIDIA-Linux-x86_64-260.19.04.run
root@jackdevon-desktop:/home/jackdevon#

sudo add-apt-repository ppa:nvidia-vdpau/ppa; sudo apt-get update; sudo apt-get install nvidia-graphics-drivers-260

Can you help with this problem?

Provide an answer of your own, or ask Jack P Arason for more information if necessary.

To post a message you must log in.