howto install with "super-user"

Asked by Rosky

im trying to install "" the file is in 2 locations /home/dawei

I also have another copy on /home/dawei/desktop

Im trying to install the ati Radeon drivers for my 4870 graphics card. This is my first linux install and im using Linux mint, I really want my graphics card to be working right because I love Linux so far and I want everything to work perfect so I can start loading some video games and compiz effects.

Whenever i try to install by double clicking the terminal pops up then stops at "You need to run this installer as super-user"

Ive tried all kids of commands from the forums but to no avail.

1st try
dawei@dawei-desktop ~ $ sudo
[sudo] password for dawei:
sudo: command not found

dawei@dawei-desktop ~ $ sudo chmod 4755
[sudo] password for dawei:

dawei@dawei-desktop ~ $ sudo visudo
[sudo] password for dawei:
 username ALL=(ALL) ALL, NOPASSWD: /home/dawei------ did something similar to that to give acess to the directory, then i tried it again for the individual file, but i dont think i typed it in correctly. I tried to save with control x then would try and double click the file but still didnt work.

Hopefully i didnt mess up my computer already.

here is my xorg.config, I have no idea if its necessary but people in other posts put it down.

# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
 Identifier "Configured Monitor"

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"

Section "Device"
 Identifier "Configured Video Device"

Section "ServerFlags"
 Option "DontZap" "False"

heres a breif exerpt from my xorg.0.log

(II) RADEON(0): Output: DVI-0, Detected Monitor Type: 3
(II) RADEON(0): EDID data from the display on output: DVI-0 ----------------------
(II) RADEON(0): Manufacturer: BNQ Model: 7726 Serial#: 21573
(II) RADEON(0): Year: 2008 Week: 46
(II) RADEON(0): EDID Version: 1.3
(II) RADEON(0): Digital Display Input
(II) RADEON(0): Max Image Size [cm]: horiz.: 48 vert.: 27
(II) RADEON(0): Gamma: 2.20
(II) RADEON(0): DPMS capabilities: Off
(II) RADEON(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
(II) RADEON(0): Default color space is primary color space
(II) RADEON(0): First detailed timing is preferred mode
(II) RADEON(0): redX: 0.648 redY: 0.339 greenX: 0.282 greenY: 0.603
(II) RADEON(0): blueX: 0.143 blueY: 0.070 whiteX: 0.312 whiteY: 0.329
(II) RADEON(0): Supported VESA Video Modes:
(II) RADEON(0): 720x400@70Hz
(II) RADEON(0): 640x480@60Hz
(II) RADEON(0): 640x480@75Hz
(II) RADEON(0): 800x600@60Hz
(II) RADEON(0): 800x600@75Hz
(II) RADEON(0): 1024x768@60Hz
(II) RADEON(0): 1024x768@75Hz
(II) RADEON(0): 1280x1024@75Hz
(II) RADEON(0): Manufacturer's mask: 0

Question information

English Edit question
Ubuntu xserver-xorg-driver-ati Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
marcobra (Marco Braida) (marcobra) said :

Please try:

sudo -i

cd /home/subtitute_this_with_your_username/Desktop

chmod 700

and to reboot your pc


Hope this helps

Revision history for this message
Rosky (daviduerkvitz) said :


Amazing work and I was about to go crazy. Thank you so much for your help you have no idea how much time ive spent trying to find that solution. So once again i appreciate your help.