HP F2280 scanner not detected in Karmic

Asked by Casper Kowalczyk

Hello, I've got a problem with HP Deskjet f2280 device. On Jaunty it was working perfectly, but since I upgraded to Karmic few days ago, the scanner is not detected by XSane anymore. I tried to force it with sane-find-scanner, but no device was detected.
I never had any problems with either XSane and F2280.

Question information

English Edit question
Ubuntu xsane Edit question
No assignee Edit question
Solved by:
Casper Kowalczyk
Last query:
Last reply:
Revision history for this message
TorpeJG52 (sito-torpe) said :

I have the same exact problem, after upgrading to Karmik, f2280 prints well, but scanner is not recognized, i have installed hplip-3.9.10 but this not helped. Please help!

Revision history for this message
TorpeJG52 (sito-torpe) said :

I have just found a little solution, at least worked for me, before opening Xsane, turn OFF printer and then turn ON it again, then open xsane and it will run and scan.

I hope it works for you too.

Revision history for this message
Casper Kowalczyk (atrctr) said :

I have the solution of my problem: I had been running Karmic with old kernel (2.6.2x-xx), which also caused problems with audio. When I set newest kernel (2.6.3x-xx) to be used, everything is fine. XSane detects scanner as it should,