Brother 7420 MFC and Xsane Imaging

Asked by M2C on 2009-07-23

Hi I'm using Ubuntu 9.04 and my capability to use the scanner in a Brother 7240 MFC has just gone. I have re-loaded the relevant drivers to no effect. On firing up Xsane the application sees the MFC as an available device and when I click to connect the following error message comes up "failed to open device 'brother2:bus4;dev1': error during device I/O".

I can print but not scan. Scanner has worked since loading Ubnutu 9.04 but this condition has just appeared in the past couple of days. Any suggestions please.

thanks

M2C

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xsane Edit question
Assignee:
No assignee Edit question
Solved by:
M2C
Solved:
2009-07-28
Last query:
2009-07-28
Last reply:
M2C (mike-m2c) said : #1

Hi I've solved this with the help of the people from Brother Support - As per:

This is a premissions issue. Please follow the steps below to resolve the issue:

Ubuntu 9.04

1. Open "/lib/udev/rules.d/50-udev-default.rules" file.

2. Edit "0664" to "0666" in "libusb device nodes" section.

Before the edit---------------------------------

# libusb device nodes

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ... , MODE="0664"

 After the edit----------------------------------

# libusb device nodes

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ... , MODE="0666"

 3. Restart the OS.

regards

M2C

Thanks M2C, very helpful. In June of this year I helped a friend set up Ubuntu 9.04 with Brother MFC-7340. I thought we'd changed the permissions above to 0666 as a part of that initial process, as instructed on the Brother website:

http://solutions.brother.com/linux/en_us/instruction_scn1c.html

Was all working fine including scanner to start with.

Then about a week ago my friend reported the same error message you mention above, when trying to start the XSane image scanning program (printing was still fine).

Didn't really know where to start looking, but found your post after trying a couple of other things. Made the permissions change (again?)... now all sorted.

We're "back on the road," so thanks.