ubuntu 17.04 to 17.10 then xsane doesn't install

Asked by Phil on 2017-11-04

hi,
I upgrade from ubuntu 17.04 to ubuntu 17.10, then I want to reuse xsane but do not find it anymore.
I look deeper and found that xsane is not more there.

$ sudo apt-get install xsane
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xsane : Depends: libsane1 (>= 1.0.24) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried:
$ sudo dpkg --configure -a
$ sudo apt-get install -f
but always the same error.

I also tried:
$ sudo apt-get install xsane libsane1 xsane-common libsane
Reading package lists... Done
Building dependency tree
Reading state information... Done
libsane is already the newest version (1.0.27+git20171029-zesty0).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libsane1 : Depends: libsane-common (= 1.0.27-1~experimental2ubuntu1) but 1.0.27+git20171029-zesty0 is to be installed
E: Unable to correct problems, you have held broken packages.

but no success
Thanks in advance for your answer and time
Phil

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xsane Edit question
Assignee:
No assignee Edit question
Last query:
2017-11-11
Last reply:
2017-11-11

This question was reopened

Manfred Hampl (m-hampl) said : #1

What is the output of the commands

uname -a
lsb_release -crid
sudo apt-get update
sudo dpkg --audit
apt-cache policy xsane libsane1 libsane-common
apt-get --simulate dist-upgrade

Phil (ph35sm) said : #2

Hi, here it is:

$ uname -a
Linux aptiva-linux 4.13.0-16-generic #19-Ubuntu SMP Wed Oct 11 18:33:49 UTC 2017 i686 i686 i686 GNU/Linux

$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 17.10
Release: 17.10
Codename: artful

$ sudo apt-get update
[sudo] password for phil:
Get:1 http://security.ubuntu.com/ubuntu artful-security InRelease [70.3 kB]
Hit:2 http://fr.archive.ubuntu.com/ubuntu artful InRelease
Hit:3 http://fr.archive.ubuntu.com/ubuntu artful-updates InRelease
Hit:4 http://fr.archive.ubuntu.com/ubuntu artful-backports InRelease
Get:5 http://security.ubuntu.com/ubuntu artful-security/universe i386 DEP-11 Metadata [2184 B]
Fetched 72.5 kB in 0s (114 kB/s)
Reading package lists... Done

$ sudo dpkg --audit
phil@aptiva-linux:~$

$ apt-cache policy xsane libsane1 libsane-common
xsane:
  Installed: (none)
  Candidate: 0.999-5ubuntu2
  Version table:
     0.999-5ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu artful/universe i386 Packages
libsane1:
  Installed: (none)
  Candidate: 1.0.27-1~experimental2ubuntu1
  Version table:
     1.0.27-1~experimental2ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu artful/main i386 Packages
libsane-common:
  Installed: 1.0.27+git20171029-zesty0
  Candidate: 1.0.27+git20171029-zesty0
  Version table:
 *** 1.0.27+git20171029-zesty0 100
        100 /var/lib/dpkg/status
     1.0.27-1~experimental2ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu artful/main i386 Packages

$ apt-get --simulate dist-upgrade
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  colord simple-scan
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

Thank you
Phil

Manfred Hampl (m-hampl) said : #3

Try the following command:

sudo apt-get install xsane libsane-common=1.0.27-1~experimental2ubuntu1

and report the results.

Phil (ph35sm) said : #4

Hi,

$ sudo apt-get install xsane libsane-common=1.0.27-1~experimental2ubuntu1
[sudo] password for phil:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  colord libsane1 simple-scan xsane-common
Suggested packages:
  colord-sensor-argyll hplip gv hylafax-client | mgetty-fax
Recommended packages:
  sane-utils
The following packages will be REMOVED:
  libsane libsane-dev sane-utils
The following NEW packages will be installed:
  libsane1 xsane xsane-common
The following packages will be upgraded:
  colord simple-scan
The following packages will be DOWNGRADED:
  libsane-common
2 upgraded, 3 newly installed, 1 downgraded, 3 to remove and 0 not upgraded.
Need to get 3140 kB/4515 kB of archives.
After this operation, 11.7 MB disk space will be freed.
Do you want to continue? [Y/n] y
Get:1 http://fr.archive.ubuntu.com/ubuntu artful/main i386 colord i386 1.3.3-2build1 [205 kB]
Get:2 http://fr.archive.ubuntu.com/ubuntu artful/main i386 libsane-common all 1.0.27-1~experimental2ubuntu1 [273 kB]
Get:3 http://fr.archive.ubuntu.com/ubuntu artful/main i386 libsane1 i386 1.0.27-1~experimental2ubuntu1 [2185 kB]
Get:4 http://fr.archive.ubuntu.com/ubuntu artful/main i386 simple-scan i386 3.26.1-0ubuntu1 [180 kB]
Get:5 http://fr.archive.ubuntu.com/ubuntu artful/universe i386 xsane i386 0.999-5ubuntu2 [298 kB]
Fetched 3140 kB in 1s (3102 kB/s)
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
 LANGUAGE = (unset),
 LC_ALL = (unset),
 LC_TIME = "fr_FR.UTF-8",
 LC_MONETARY = "fr_FR.UTF-8",
 LC_ADDRESS = "fr_FR.UTF-8",
 LC_TELEPHONE = "fr_FR.UTF-8",
 LC_NAME = "fr_FR.UTF-8",
 LC_MEASUREMENT = "fr_FR.UTF-8",
 LC_IDENTIFICATION = "fr_FR.UTF-8",
 LC_NUMERIC = "fr_FR.UTF-8",
 LC_PAPER = "fr_FR.UTF-8",
 LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
locale: Cannot set LC_ALL to default locale: No such file or directory
(Reading database ... 411227 files and directories currently installed.)
Removing sane-utils (1.0.27+git20171029-zesty0) ...
(Reading database ... 411213 files and directories currently installed.)
Preparing to unpack .../colord_1.3.3-2build1_i386.deb ...
Unpacking colord (1.3.3-2build1) over (1.3.3-2) ...
(Reading database ... 411213 files and directories currently installed.)
Removing libsane-dev (1.0.27+git20171029-zesty0) ...
dpkg: libsane:i386: dependency problems, but removing anyway as you requested:
 simple-scan depends on libsane (>= 1.0.24); however:
  Package libsane:i386 is to be removed.

Removing libsane:i386 (1.0.27+git20171029-zesty0) ...
dpkg: warning: downgrading libsane-common from 1.0.27+git20171029-zesty0 to 1.0.27-1~experimental2ubuntu1
(Reading database ... 410758 files and directories currently installed.)
Preparing to unpack .../libsane-common_1.0.27-1~experimental2ubuntu1_all.deb ...
Unpacking libsane-common (1.0.27-1~experimental2ubuntu1) over (1.0.27+git20171029-zesty0) ...
Selecting previously unselected package libsane1:i386.
Preparing to unpack .../libsane1_1.0.27-1~experimental2ubuntu1_i386.deb ...
Unpacking libsane1:i386 (1.0.27-1~experimental2ubuntu1) ...
Preparing to unpack .../simple-scan_3.26.1-0ubuntu1_i386.deb ...
Unpacking simple-scan (3.26.1-0ubuntu1) over (3.24.0-0ubuntu1) ...
Selecting previously unselected package xsane-common.
Preparing to unpack .../xsane-common_0.999-5ubuntu2_all.deb ...
Unpacking xsane-common (0.999-5ubuntu2) ...
Selecting previously unselected package xsane.
Preparing to unpack .../xsane_0.999-5ubuntu2_i386.deb ...
Unpacking xsane (0.999-5ubuntu2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Setting up xsane-common (0.999-5ubuntu2) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3) ...
Processing triggers for libglib2.0-0:i386 (2.54.1-1ubuntu1) ...
Setting up libsane-common (1.0.27-1~experimental2ubuntu1) ...
Installing new version of config file /etc/sane.d/agfafocus.conf ...
Installing new version of config file /etc/sane.d/artec.conf ...
Installing new version of config file /etc/sane.d/artec_eplus48u.conf ...
Installing new version of config file /etc/sane.d/avision.conf ...
Installing new version of config file /etc/sane.d/canon_dr.conf ...
Installing new version of config file /etc/sane.d/canon_pp.conf ...
Installing new version of config file /etc/sane.d/dc210.conf ...
Installing new version of config file /etc/sane.d/dc240.conf ...
Installing new version of config file /etc/sane.d/dc25.conf ...
Installing new version of config file /etc/sane.d/dell1600n_net.conf ...
Installing new version of config file /etc/sane.d/epjitsu.conf ...
Installing new version of config file /etc/sane.d/epson.conf ...
Installing new version of config file /etc/sane.d/epson2.conf ...
Installing new version of config file /etc/sane.d/fujitsu.conf ...
Installing new version of config file /etc/sane.d/gphoto2.conf ...
Installing new version of config file /etc/sane.d/gt68xx.conf ...
Installing new version of config file /etc/sane.d/hp3900.conf ...
Installing new version of config file /etc/sane.d/hpsj5s.conf ...
Installing new version of config file /etc/sane.d/kodakaio.conf ...
Installing new version of config file /etc/sane.d/leo.conf ...
Installing new version of config file /etc/sane.d/magicolor.conf ...
Installing new version of config file /etc/sane.d/matsushita.conf ...
Installing new version of config file /etc/sane.d/mustek.conf ...
Installing new version of config file /etc/sane.d/mustek_pp.conf ...
Installing new version of config file /etc/sane.d/mustek_usb.conf ...
Installing new version of config file /etc/sane.d/plustek.conf ...
Installing new version of config file /etc/sane.d/plustek_pp.conf ...
Installing new version of config file /etc/sane.d/sharp.conf ...
Installing new version of config file /etc/sane.d/tamarack.conf ...
Installing new version of config file /etc/sane.d/teco2.conf ...
Installing new version of config file /etc/sane.d/u12.conf ...
Installing new version of config file /etc/sane.d/umax.conf ...
Installing new version of config file /etc/sane.d/umax_pp.conf ...
Installing new version of config file /etc/sane.d/xerox_mfp.conf ...
Processing triggers for bamfdaemon (0.5.3+17.10.20170810-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for libc-bin (2.26-0ubuntu2) ...
Processing triggers for udev (234-2ubuntu12.1) ...
Processing triggers for doc-base (0.10.7) ...
Processing 1 removed doc-base file, 1 added doc-base file...
Registering documents with scrollkeeper...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up libsane1:i386 (1.0.27-1~experimental2ubuntu1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu5) ...
Processing triggers for dbus (1.10.22-1ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-1) ...
Setting up xsane (0.999-5ubuntu2) ...
Setting up simple-scan (3.26.1-0ubuntu1) ...
Setting up colord (1.3.3-2build1) ...
colord.service is a disabled or a static unit, not starting it.
Processing triggers for libc-bin (2.26-0ubuntu2) ...

seems better for the installation step however xsane does'nt find any device at startup. One message when runs from command line:
/usr/share/themes/Ambiance/gtk-2.0/apps/mate-panel.rc:30: error: invalid string constant "murrine-scrollbar", expected valid string constant

I also an hp-check and the result is:
---
-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'libsane-dev' package is missing/incompatible
error: 'libcups2' package is missing/incompatible

Missing Optional Dependencies
-----------------------------
error: 'sane-utils' package is missing/incompatible

Total Errors: 3
Total Warnings: 0

---
Thank you

Manfred Hampl (m-hampl) said : #5

What do you get for the command

apt-get --simulate install libsane-dev libcups2 sane-utils

Phil (ph35sm) said : #6

Hi,
I really apologize for delay, was abroad for my job.

$ apt-get --simulate install libsane-dev libcups2 sane-utils
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
libcups2 is already the newest version (2.2.4-7ubuntu2).
Suggested packages:
  libsane-extras-dev unpaper
The following NEW packages will be installed:
  libsane-dev sane-utils
0 upgraded, 2 newly installed, 0 to remove and 11 not upgraded.
Inst libsane-dev (1.0.27-1~experimental2ubuntu1 Ubuntu:17.10/artful [i386])
Inst sane-utils (1.0.27-1~experimental2ubuntu1 Ubuntu:17.10/artful [i386])
Conf libsane-dev (1.0.27-1~experimental2ubuntu1 Ubuntu:17.10/artful [i386])
Conf sane-utils (1.0.27-1~experimental2ubuntu1 Ubuntu:17.10/artful [i386])

$ sudo apt-get --simulate install libsane-dev libcups2 sane-utils
[sudo] password for phil: debug3: Received SSH2_MSG_IGNORE
Reading package lists... Done
Building dependency tree
Reading state information... Done
libcups2 is already the newest version (2.2.4-7ubuntu2).
Suggested packages:
  libsane-extras-dev unpaper
The following NEW packages will be installed:
  libsane-dev sane-utils
0 upgraded, 2 newly installed, 0 to remove and 11 not upgraded.
Inst libsane-dev (1.0.27-1~experimental2ubuntu1 Ubuntu:17.10/artful [i386])
Inst sane-utils (1.0.27-1~experimental2ubuntu1 Ubuntu:17.10/artful [i386])
Conf libsane-dev (1.0.27-1~experimental2ubuntu1 Ubuntu:17.10/artful [i386])
Conf sane-utils (1.0.27-1~experimental2ubuntu1 Ubuntu:17.10/artful [i386])

seems mean that the command should be run without the --simulate option. Right ?
Phil

Manfred Hampl (m-hampl) said : #7

yes, the simulation looks promising, now execute

sudo apt-get libsane-dev libcups2 sane-utils

and then re-execute hp-check and copy/paste all output.

Phil (ph35sm) said : #8

Hi,

seems the verb install was missing ;-) no problem of course

first step : ok
second step : no scan devices found so I have done :
  step2 A : hp-check as root
  step2 B : hp-check as user
  step2 C : hp-check as su from user

I have another computer running ubuntu 14.04.5 LTS and it works with no problem with the scanne (I made several scans today)

************************* STEP 1 *************************
$ sudo apt-get install libsane-dev libcups2 sane-utils
Reading package lists... Done
Building dependency tree
Reading state information... Done
libcups2 is already the newest version (2.2.4-7ubuntu2).
Suggested packages:
  libsane-extras-dev unpaper
The following NEW packages will be installed:
  libsane-dev sane-utils
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 2376 kB of archives.
After this operation, 14.8 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://fr.archive.ubuntu.com/ubuntu artful/main i386 libsane-dev i386 1.0.27-1~experimental2ubuntu1 [2188 kB]
Get:2 http://fr.archive.ubuntu.com/ubuntu artful/main i386 sane-utils i386 1.0.27-1~experimental2ubuntu1 [188 kB]
Fetched 2376 kB in 0s (3351 kB/s)
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
 LANGUAGE = (unset),
 LC_ALL = (unset),
 LC_TIME = "fr_FR.UTF-8",
 LC_MONETARY = "fr_FR.UTF-8",
 LC_ADDRESS = "fr_FR.UTF-8",
 LC_TELEPHONE = "fr_FR.UTF-8",
 LC_NAME = "fr_FR.UTF-8",
 LC_MEASUREMENT = "fr_FR.UTF-8",
 LC_IDENTIFICATION = "fr_FR.UTF-8",
 LC_NUMERIC = "fr_FR.UTF-8",
 LC_PAPER = "fr_FR.UTF-8",
 LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
locale: Cannot set LC_ALL to default locale: No such file or directory
Preconfiguring packages ...
Selecting previously unselected package libsane-dev:i386.
(Reading database ... 411076 files and directories currently installed.)
Preparing to unpack .../libsane-dev_1.0.27-1~experimental2ubuntu1_i386.deb ...
Unpacking libsane-dev:i386 (1.0.27-1~experimental2ubuntu1) ...
Selecting previously unselected package sane-utils.
Preparing to unpack .../sane-utils_1.0.27-1~experimental2ubuntu1_i386.deb ...
Unpacking sane-utils (1.0.27-1~experimental2ubuntu1) ...
Processing triggers for ureadahead (0.100.0-20) ...
Setting up libsane-dev:i386 (1.0.27-1~experimental2ubuntu1) ...
Processing triggers for systemd (234-2ubuntu12.1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up sane-utils (1.0.27-1~experimental2ubuntu1) ...
Installing new version of config file /etc/default/saned ...
Installing new version of config file /etc/init.d/saned ...
locale: Cannot set LC_ALL to default locale: No such file or directory
Adding user saned to group scanner
Processing triggers for ureadahead (0.100.0-20) ...
Processing triggers for systemd (234-2ubuntu12.1) ...

************************* STEP 2A *************************

# hp-check
Saving output in log file: /root/hp-check.log

HP Linux Imaging and Printing System (ver. 3.17.10)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies are
installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball has the
proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
    OK
    MISSING - Missing Dependency or Permission or Plug-in
    INCOMPAT - Incompatible dependency-version or Plugin-version

-/usr/share/themes/Ambiance/gtk-2.0/apps/mate-panel.rc:30: error: invalid string constant "murrine-scrollbar", expected valid string constant
\/usr/share/themes/Ambiance/gtk-2.0/apps/mate-panel.rc:30: error: invalid string constant "murrine-scrollbar", expected valid string constant
warning: 12-17.10 version is not supported. Using 12-17.04 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 4.13.0-16-generic #19-Ubuntu SMP Wed Oct 11 18:33:49 UTC 2017 GNU/Linux
 Host: aptiva-linux
 Proc: 4.13.0-16-generic #19-Ubuntu SMP Wed Oct 11 18:33:49 UTC 2017 GNU/Linux
 Distribution: 12 17.10
 Bitness: 32 bit

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.17.10
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 12 distro 17.10 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.17.10

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.17.10
html=/usr/share/doc/hplip-3.17.10
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.17.10
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
qt5=no
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=yes

Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[upgrade]
notify_upgrade = true
last_upgraded_time = 1509795256
pending_upgrade_time = 0
latest_available_version = 3.17.10

[last_used]
device_uri = "hp:/net/Photosmart_2600_series?ip=192.168.1.103"
printer_name = Photosmart_2600_2
working_dir = .

[settings]
systray_visible = 0
systray_messages = 0

[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[refresh]
rate = 30
enable = false
type = 1

[polling]
enable = false
interval = 5
device_list =

[fax]
voice_phone =
email_address =

[installation]
date_time = 11/11/17 18:28:42
version = 3.17.10

 <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

--------------
| COMPILEDEP |
--------------

 gcc gcc - GNU Project C and C++ Compiler REQUIRED - 7.2.0 OK -
 make make - GNU make utility to maintain groups of programs REQUIRED 3.0 4.1 OK -
 libtool libtool - Library building support services REQUIRED - 2.4.6 OK -

------------------------
| General Dependencies |
------------------------

 libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.0.2 OK -
 python-xml Python XML libraries REQUIRED - 2.2.3 OK -
 libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 5.7.3 OK -
 sane-devel SANE - Scanning library development files REQUIRED - - OK -
 pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
 pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 REQUIRED 4.0 4.11.4 OK -
 libpthread libpthread - POSIX threads library REQUIRED - 2.26 OK -
 python-devel Python devel - Python development files REQUIRED 2.2 2.7.14 OK -
 cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - 2.2.4 OK -
 python-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.4 OK -
 cups-ddk CUPS DDK - CUPS driver development kit OPTIONAL - - OK -
 reportlab Reportlab - PDF library for Python OPTIONAL 2.0 3.4.0 OK -
 pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 4.11.4 OK -
 libusb libusb - USB library REQUIRED - 1.0 OK -
 cups-image CUPS image - CUPS image development files REQUIRED - 2.2.4 OK -
 python2X Python 2.2 or greater - Python programming language REQUIRED 2.2 2.7.14 OK -
 python-notify Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
 libjpeg libjpeg - JPEG library REQUIRED - - OK -
 sane SANE - Scanning library REQUIRED - - OK -

----------------------
| Scan Configuration |
----------------------

 scanext Scan-SANE-Extension REQUIRED - 3.17.10 OK -
 hpaio HPLIP-SANE-Backend REQUIRED - 3.17.10 OK 'hpaio found in /etc/sane.d/dll.conf'

-------------------------
| External Dependencies |
-------------------------

 gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.21 OK -
 cups CUPS - Common Unix Printing System REQUIRED 1.1 2.2.4 OK 'CUPS Scheduler is running'
 network network -wget OPTIONAL - 1.19.1 OK -
 scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.27 OK -
 policykit PolicyKit - Administrative policy framework OPTIONAL - 0.105 OK -
/usr/share/themes/Ambiance/gtk-2.0/apps/mate-panel.rc:30: error: invalid string constant "murrine-scrollbar", expected valid string constant
/usr/share/themes/Ambiance/gtk-2.0/apps/mate-panel.rc:30: error: invalid string constant "murrine-scrollbar", expected valid string constant
 xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 0.999 OK -
 dbus DBus - Message bus system REQUIRED - 1.10.22 OK -
 avahi-utils avahi-utils OPTIONAL - 0.6.32 OK -

---------------------
| Python Extentions |
---------------------

 hpmudext IO-Extension REQUIRED - 3.17.10 OK -
 cupsext CUPS-Extension REQUIRED - 3.17.10 OK -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

Photosmart_2600
---------------
Type: Printer
Device URI: hp:/net/Photosmart_2600_series?zc=HP2610
PPD: /etc/cups/ppd/Photosmart_2600.ppd
PPD Description: HP Photosmart 2600 Series, hpcups 3.16.3
Printer status: printer Photosmart_2600 is idle. enabled since Fri 21 Dec 2012 11:17:00 AM CET
Communication status: Good

Photosmart_2600_fax
-------------------
Type: Fax
Device URI: hpfax:/net/Photosmart_2600_series?zc=HP2610
PPD: /etc/cups/ppd/Photosmart_2600_fax.ppd
PPD Description: HP Fax hpcups
Printer status: printer Photosmart_2600_fax is idle. enabled since Fri 21 Dec 2012 11:16:59 AM CET
Communication status: Good

--------------
| PERMISSION |
--------------

No errors or warnings.

Done.

************************* STEP 2B *************************

$ hp-check
Saving output in log file: /home/phil/hp-check.log

HP Linux Imaging and Printing System (ver. 3.17.10)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies are
installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball has the
proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
    OK
    MISSING - Missing Dependency or Permission or Plug-in
    INCOMPAT - Incompatible dependency-version or Plugin-version

-
(process:26488): Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale.
/usr/share/themes/Ambiance/gtk-2.0/apps/mate-panel.rc:30: error: invalid string constant "murrine-scrollbar", expected valid string constant
\
(process:26522): Gdk-WARNING **: locale not supported by C library

(process:26522): Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale.
/usr/share/themes/Ambiance/gtk-2.0/apps/mate-panel.rc:30: error: invalid string constant "murrine-scrollbar", expected valid string constant
warning: 12-17.10 version is not supported. Using 12-17.04 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 4.13.0-16-generic #19-Ubuntu SMP Wed Oct 11 18:33:49 UTC 2017 GNU/Linux
 Host: aptiva-linux
 Proc: 4.13.0-16-generic #19-Ubuntu SMP Wed Oct 11 18:33:49 UTC 2017 GNU/Linux
 Distribution: 12 17.10
 Bitness: 32 bit

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.17.10
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 12 distro 17.10 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.17.10

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.17.10
html=/usr/share/doc/hplip-3.17.10
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.17.10
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
qt5=no
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=yes

Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[upgrade]
notify_upgrade = true
last_upgraded_time = 1509795256
pending_upgrade_time = 0
latest_available_version = 3.17.10

[last_used]
device_uri = "hp:/net/Photosmart_2600_series?ip=192.168.1.103"
printer_name = Photosmart_2600_2
working_dir = .

[settings]
systray_visible = 0
systray_messages = 0

[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[refresh]
rate = 30
enable = false
type = 1

[polling]
enable = false
interval = 5
device_list =

[fax]
voice_phone =
email_address =

[installation]
date_time = 11/11/17 18:45:21
version = 3.17.10

 <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

--------------
| COMPILEDEP |
--------------

 gcc gcc - GNU Project C and C++ Compiler REQUIRED - 7.2.0 OK -
 make make - GNU make utility to maintain groups of programs REQUIRED 3.0 4.1 OK -
 libtool libtool - Library building support services REQUIRED - 2.4.6 OK -

------------------------
| General Dependencies |
------------------------

 libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.0.2 OK -
 python-xml Python XML libraries REQUIRED - 2.2.3 OK -
 libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 5.7.3 OK -
 sane-devel SANE - Scanning library development files REQUIRED - - OK -
 pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
 pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 REQUIRED 4.0 4.11.4 OK -
 libpthread libpthread - POSIX threads library REQUIRED - 2.26 OK -
 python-devel Python devel - Python development files REQUIRED 2.2 2.7.14 OK -
 cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - - OK -
 python-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.4 OK -
 cups-ddk CUPS DDK - CUPS driver development kit OPTIONAL - - OK -
 reportlab Reportlab - PDF library for Python OPTIONAL 2.0 3.4.0 OK -
 pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 4.11.4 OK -
 libusb libusb - USB library REQUIRED - 1.0 OK -
 cups-image CUPS image - CUPS image development files REQUIRED - - OK -
 python2X Python 2.2 or greater - Python programming language REQUIRED 2.2 2.7.14 OK -
 python-notify Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
 libjpeg libjpeg - JPEG library REQUIRED - - OK -
 sane SANE - Scanning library REQUIRED - - OK -

----------------------
| Scan Configuration |
----------------------

 scanext Scan-SANE-Extension REQUIRED - 3.17.10 OK -
 hpaio HPLIP-SANE-Backend REQUIRED - 3.17.10 OK 'hpaio found in /etc/sane.d/dll.conf'

-------------------------
| External Dependencies |
-------------------------

 gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.21 OK -
 error: cups CUPS - Common Unix Printing System REQUIRED 1.1 - INCOMPAT 'CUPS may not be installed or not running'
 network network -wget OPTIONAL - 1.19.1 OK -
 scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.27 OK -
 policykit PolicyKit - Administrative policy framework OPTIONAL - 0.105 OK -

(process:26697): Gdk-WARNING **: locale not supported by C library

(process:26697): Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale.
/usr/share/themes/Ambiance/gtk-2.0/apps/mate-panel.rc:30: error: invalid string constant "murrine-scrollbar", expected valid string constant

(process:26698): Gdk-WARNING **: locale not supported by C library

(process:26698): Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale.
/usr/share/themes/Ambiance/gtk-2.0/apps/mate-panel.rc:30: error: invalid string constant "murrine-scrollbar", expected valid string constant
 xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 0.999 OK -
 dbus DBus - Message bus system REQUIRED - 1.10.22 OK -
 avahi-utils avahi-utils OPTIONAL - 0.6.32 OK -

---------------------
| Python Extentions |
---------------------

 hpmudext IO-Extension REQUIRED - 3.17.10 OK -
 cupsext CUPS-Extension REQUIRED - 3.17.10 OK -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

Photosmart_2600
---------------
Type: Printer
Device URI: hp:/net/Photosmart_2600_series?zc=HP2610
PPD: /etc/cups/ppd/Photosmart_2600.ppd
warning: Failed to read /etc/cups/ppd/Photosmart_2600.ppd ppd file
PPD Description:
Printer status: printer Photosmart_2600 is idle. enabled since Fri Dec 21 11:17:00 2012
Communication status: Good

Photosmart_2600_fax
-------------------
Type: Fax
Device URI: hpfax:/net/Photosmart_2600_series?zc=HP2610
PPD: /etc/cups/ppd/Photosmart_2600_fax.ppd
warning: Failed to read /etc/cups/ppd/Photosmart_2600_fax.ppd ppd file
PPD Description:
Printer status: printer Photosmart_2600_fax is idle. enabled since Fri Dec 21 11:16:59 2012
Communication status: Good

--------------
| PERMISSION |
--------------

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'libcups2' package is missing/incompatible

Missing Optional Dependencies
-----------------------------
None

Total Errors: 1
Total Warnings: 0

Done.

************************* STEP 2C *************************
$ cat test.log

$ sudo hp-check
Saving output in log file: /media/phil/Disque D/famille/hp-check.log

HP Linux Imaging and Printing System (ver. 3.17.10)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if
the proper dependencies are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP
supplied tarball has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and
run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
    OK
    MISSING - Missing Dependency or Permission or Plug-in
    INCOMPAT - Incompatible dependency-version or Plugin-version

-Invalid MIT-MAGIC-COOKIE-1 key/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
  warnings.warn(str(e), _gtk.Warning)
\Invalid MIT-MAGIC-COOKIE-1 key
(xsane:27127): Gtk-WARNING **: cannot open display: :0
warning: 12-17.10 version is not supported. Using 12-17.04 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 4.13.0-16-generic #19-Ubuntu SMP Wed Oct 11 18:33:49 UTC 2017 GNU/Linux
 Host: aptiva-linux
 Proc: 4.13.0-16-generic #19-Ubuntu SMP Wed Oct 11 18:33:49 UTC 2017 GNU/Linux
 Distribution: 12 17.10
 Bitness: 32 bit

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.17.10
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 12 distro 17.10 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.17.10

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.17.10
html=/usr/share/doc/hplip-3.17.10
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.17.10
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
qt5=no
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=yes

Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[upgrade]
notify_upgrade = true
last_upgraded_time = 1509795256
pending_upgrade_time = 0
latest_available_version = 3.17.10

[last_used]
device_uri = "hp:/net/Photosmart_2600_series?ip=192.168.1.103"
printer_name = Photosmart_2600_2
working_dir = .

[settings]
systray_visible = 0
systray_messages = 0

[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[refresh]
rate = 30
enable = false
type = 1

[polling]
enable = false
interval = 5
device_list =

[fax]
voice_phone =
email_address =

[installation]
date_time = 11/11/2017 18:48:24
version = 3.17.10

 <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

--------------
| COMPILEDEP |
--------------

 gcc gcc - GNU Project C and C++ Compiler REQUIRED - 7.2.0 OK -
 make make - GNU make utility to maintain groups of programs REQUIRED 3.0 4.1 OK -
 libtool libtool - Library building support services REQUIRED - 2.4.6 OK -

------------------------
| General Dependencies |
------------------------

 libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.0.2 OK -
 python-xml Python XML libraries REQUIRED - 2.2.3 OK -
 libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 5.7.3 OK -
 sane-devel SANE - Scanning library development files REQUIRED - - OK -
 pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
 pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 REQUIRED 4.0 4.11.4 OK -
 libpthread libpthread - POSIX threads library REQUIRED - 2.26 OK -
 python-devel Python devel - Python development files REQUIRED 2.2 2.7.14 OK -
 cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - 2.2.4 OK -
 python-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.4 OK -
 cups-ddk CUPS DDK - CUPS driver development kit OPTIONAL - - OK -
 reportlab Reportlab - PDF library for Python OPTIONAL 2.0 3.4.0 OK -
 pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 4.11.4 OK -
 libusb libusb - USB library REQUIRED - 1.0 OK -
 cups-image CUPS image - CUPS image development files REQUIRED - 2.2.4 OK -
 python2X Python 2.2 or greater - Python programming language REQUIRED 2.2 2.7.14 OK -
 python-notify Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
 libjpeg libjpeg - JPEG library REQUIRED - - OK -
 sane SANE - Scanning library REQUIRED - - OK -

----------------------
| Scan Configuration |
----------------------

 scanext Scan-SANE-Extension REQUIRED - 3.17.10 OK -
 hpaio HPLIP-SANE-Backend REQUIRED - 3.17.10 OK 'hpaio found in /etc/sane.d/dll.conf'

-------------------------
| External Dependencies |
-------------------------

 gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.21 OK -
 cups CUPS - Common Unix Printing System REQUIRED 1.1 2.2.4 OK 'CUPS Scheduler is running'
 network network -wget OPTIONAL - 1.19.1 OK -
 scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.27 OK -
 policykit PolicyKit - Administrative policy framework OPTIONAL - 0.105 OK -
Invalid MIT-MAGIC-COOKIE-1 key
(xsane:27302): Gtk-WARNING **: cannot open display: :0
Invalid MIT-MAGIC-COOKIE-1 key
(xsane:27303): Gtk-WARNING **: cannot open display: :0
 error: xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 - MISSING 'xsane needs to be installed'
 dbus DBus - Message bus system REQUIRED - 1.10.22 OK -
 avahi-utils avahi-utils OPTIONAL - 0.6.32 OK -

---------------------
| Python Extentions |
---------------------

 hpmudext IO-Extension REQUIRED - 3.17.10 OK -
 cupsext CUPS-Extension REQUIRED - 3.17.10 OK -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

Photosmart_2600
---------------
Type: Printer
Device URI: hp:/net/Photosmart_2600_series?zc=HP2610
PPD: /etc/cups/ppd/Photosmart_2600.ppd
PPD Description: HP Photosmart 2600 Series, hpcups 3.16.3
Printer status: printer Photosmart_2600 is idle. enabled since Fri 21 Dec 2012 11:17:00 AM CET
Communication status: Good

Photosmart_2600_fax
-------------------
Type: Fax
Device URI: hpfax:/net/Photosmart_2600_series?zc=HP2610
PPD: /etc/cups/ppd/Photosmart_2600_fax.ppd
PPD Description: HP Fax hpcups
Printer status: printer Photosmart_2600_fax is idle. enabled since Fri 21 Dec 2012 11:16:59 AM CET
Communication status: Good

--------------
| PERMISSION |
--------------

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
None

Missing Optional Dependencies
-----------------------------
error: 'gtk2-engines-pixbuf' package is missing/incompatible
error: 'xsane' package is missing/incompatible

Total Errors: 1
Total Warnings: 0

Done.

hope this helps

Many many thanks for your time, patience and answer
Phil

Phil (ph35sm) said : #9

forgot these information (regarding the results) :

$ dpkg -l gtk2-engines-pixbuf
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-===================================-======================-======================-===========================================================================
ii gtk2-engines-pixbuf:i386 2.24.31-2ubuntu1 i386 pixbuf-based theme for GTK+ 2.x

$ dpkg -l xsane
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-===================================-======================-======================-===========================================================================
ii xsane 0.999-5ubuntu2 i386 featureful graphical frontend for SANE (Scanner Access Now Easy)

Phil (ph35sm) said : #10

I also test a print (test page) from the HPLIP : ok
a scan failed from this tool however the message displays in a new window :
"failed to open deice 'hpaio:/net/Photosmart_2600_series?zc=HP2610': Operation not supported.

I can share the screenshot if needed
Phil

Manfred Hampl (m-hampl) said : #11

A remark:
According to an answer in https://answers.launchpad.net/hplip/+question/660039

"Ubuntu 17.10 is not yet supported by HPLIP. Kindly wait for the next release for this support"

Phil (ph35sm) said : #12

ok, so wait and see.
thank you

Can you help with this problem?

Provide an answer of your own, or ask Phil for more information if necessary.

To post a message you must log in.