[8.10] xsane not working as normal user works as root. How to fix?

Asked by Uqbar

I've just installed an USB scanner with its front-end, back-end and related firmware file.
I've already used this very scanner with Kubuntu 8.04 with no problem.
What happens is that by launching xsane (either from the menu or from a console shell) I get a dialog saying:

Failed to opern device `v4l:/dev/video0': Invalid argument

I've checked the device:

crw-rw----+ 1 root video 81, 0 2009-03-09 08:27 /dev/video0

as well as my own current memberships:

uid=1000(uqbar) gid=1000(uqbar)

The latter seem to be compatible with the former.
If I run the xsane frontend from the shell with "sudo" I get the application working but running as root, which is not a good thing accordingly to the application itself.
So it'd be a permission problem, but I have no clue which one.
Any hint?

Question information

English Edit question
Ubuntu xsane Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Uqbar (uqbar) said :

While doing a backup I have found out that some xsane related directories where showing wrong permissions.
My colleague run a simple
sudo chown -R uqbar.uqbar ~
which fixed everything but left me with no knowledge about the wrong permissions.
As a proof I simply deleted the ~/.sane directory and started xsane again.
No problem showed up.
The only thing I've done with root permissions has been to install the current version of the package "libsane-extras"
after having tried to run xsane for the first time and before installing a needed firmware file.