getting xsane to work with deskjet f4272

Asked by john on 2008-10-11

Ubuntu 8.04 with HP Deskjet F4272. The printer works well, and so does the copier, but the scanner does not. Xsane was installed and worked once but now, when I want to scan xsane does not open properly - the preview window crashes - and the scan produces nothing.

Question information

English Edit question
Ubuntu xsane Edit question
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Last query:
Last reply:

Please run xsane from terminal and please post any error or warning here.

Open a Terminal from the menu Applications → Accessories → Terminal and type:


Thank you

john (jaytee1937) said : #3

Thank you Marcobra for your response.

xsane in the terminal open up the application: it recognises the all in
one printer. When I press scan there is activity in the printer but
nothing else appears - no preview page. Then I get an Error message:
'Failed to start scanner: error during device I/O.'

john (jaytee1937) said : #4

Thank you. I have already been to question 45015 but unfortunately not to any avail. I still need some help.

john (jaytee1937) said : #5

Since these last emails, I have had one of those lengthy system checks before the full boot up. I went to try again with xsane and, not really knowing the application, went about clicking the buttons to see what they do. I was able to locate the Preview window and obtain a preview of a document. This I was able to print. So all seems well with Deskjet F4272 and Ubuntu 8.01. I am grateful, once again for the support and help this website gives. Thank you.