Please Help... issues after installing an HP Deskjet F4280

Asked by AFarris01 on 2008-10-06

I just recently purchased a new printer for my computer, because my old Lexmark Z705 doesn't work well under linux, and it's semi-important to me to be able to have good quality, and accurate, printouts, which the lexmark simply didnt do (the fact that the ink costs more than a tank of gasoline didn't help it's case either). additionally, i desired a scanner, because my old scanner, a Visioneer 6100 recently failed on me.

So, after doing much searching, and hearing many nice things about HP printer support under linux, i decided on a HP Deskjet F4280 all-in-one printer, which is shown as having good support under the openprinting.org database, as well as underHP's HPLIP utility. So, i installed HPLIP from a fresh copy from the HP website, because the one in the ubuntu repos didnt support my printer (too old), but now i have a few issues.

The first issue that i'm having, which may or may not be related to this printer, is that any time i try to start xsane, it segfaults and crashes for no apparent reason. here's all that happens:

andrew@BEC-LIN:~$ xsane
Segmentation fault
andrew@BEC-LIN:~$

however, if i run xsane with the printer not connected/on, nothing outputs and it simply tells me that no device is available. I suspect this may have something to do with the fact that i had to manually add a driver/support for my old scanner, but i don't remember how to remove it. I've tried purging/reinstalling xsane, which didnt help.

the second issue that i'm positive has to do with the installation of HPLIP is that my printer management window under "System >> Administration >> Printing" is gone. i have no idea where the menu item went, and im positive that i did not install it. therefore, im almost certain that the HPLIP installation removed it, but all i really want to know it how to get it back.

Any help on these issues would be greatly appreciated!
Thanks!

Andrew

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xsane Edit question
Assignee:
No assignee Edit question
Solved by:
AFarris01
Solved:
2008-10-06
Last query:
2008-10-06
Last reply:
2008-10-06
AFarris01 (afarris01) said : #2

thanks for the tip, arochester, but unfortunately, that doesn't help my problem...

my main problem is that I cant scan, but icant scan because xsane keeps crashing whenever i try to run it, possibly because its trying to load drivers for my old visioneer scanner.

additionally, ihave no idea why my "System >> Administration >> Printing" icon is gone, but i'm working on that.

do you happen to know how i could find out what is actually causing xsane to segfault? is there a way to run it in some sort of verbose mode, so i can get a backtrace?

Thanks!

Andrew

AFarris01 (afarris01) said : #3

I've figured out the xsane problem- i had to install some viceo-sane backends so i could use my old visioneer scanner, but i found the package file i used to install it, and just ran dpkg deinstall and xsane works now.

Additionally, i looked on my laptop to see what program was removed whenever HPLIP was installed, and it turned out that it removed the 'system-config-printer' program. a simple visit to synaptic, and the /usr/bin/ folders confirmed this, so i re-installed it, and now i'm good to go!

Problem Solved!