Epson scanner GT7000 detected in Ubuntu 7.10 but not in Ubuntu 8.04

Asked by KGFMH on 2008-08-09

How do I regain use of my Epson scanner GT 7000 which was detected in 'Gutsy' but not in 'Hardy'?

Many thanks for help.

Ken

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xsane Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2008-08-20
Last query:
2008-08-20
Last reply:
2008-08-18
KGFMH (kgfmh1) said : #1

With a clean install of 8.04 from CD my scanner is not detected. It is detected in 7.10. I've had a lot of trouble upgrading to 8.04 via Web upgrade but have finally succeeded. See 'Answers' 41936. But I don't know how valid this is as a general solution to a common problem.

To try to find your scanner...
Open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo apt-get update
sudo apt-get install xsane

Then using the just installed xsane packages related tool, type:

sudo sane-find-scanner

give your user password when requested, you don't see nothing when you type it, then press enter.

if your scanner is recognized, listed and it is still not recognized by xsane, please try to change the device permission to make xsane recognize your device

For example in my system:

sudo sane-find-scanner
give me
....
found SCSI processor "EPSON SCANNER GT-12000 1.25" at /dev/sg0
...

But xsane still don't recognized it, so i changed permission to /dev/sg0 with terminal:

chmod 777 /dev/sg0

And all goes fine.

Hope this helps

KGFMH (kgfmh1) said : #3

Thanks marcobra, that solved my question.