cndrvsane-dr2020u_1.00-4_i386.deb not installed yet -> USB scanner (vendor=0x1083, product=0x1625, chip=GL846?) at libusb:002:002 - device `canondr:libusb:002:002' is a Canon DR-2020U sheetfed scanner -> scanner not working in 12.04.4 LTS

Asked by Gerlof Brinck on 2014-03-12

I have a Canon imagedrive formula DR-2020u working perfect under windows xp (desktop Fujitsu Siemens scaleo p). I have installed Ubuntu 12.04.01 (with all the updates). I have found drivers for my Canon scanner through the Ubuntu Software centre (working under SANE). I have installed the software. After installing Ubunt says than the installation is oké. But it does not work. I have connected my scanner (usb) through an extra PCI UBS 2.0 card (4 external USB busses). The card itself works oké. My external harddisk is also connected through the same card and is working perfect.

Than the read me first documents which are included with the packedge
When I look at the read me first document :"Canon Electronics Scanner Drive for LInux version 1.00" At the end of this document is written: At installing on Ubuntu Desktop with Ubuntu Software Centre, the installation may fail. So please install this driver package via console UI.
dpkg -i cnrvsane-dr2020u_1.00-X_i386.deb".

So I have tried that as well without any result.
In Ubuntu I see my external harddisk but not my scanner.
I hope someone is able to help me.

Thanks
Kindly Regards

Gerlof Brinck.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xsane Edit question
Assignee:
No assignee Edit question
Solved by:
Gerlof Brinck
Solved:
2014-03-14
Last query:
2014-03-14
Last reply:
2014-03-14

The Canon site doesnt show drivers for the device.

http://www.sane-project.org/sane-mfgs.html also shows it as unsupported in SANE

Gerlof Brinck (brinck) said : #3

Dear Adrew Woodhead,

Thank you for your fast reaction. But Iám afraid it not solve the problem. I have scanned (in Windows) the pages about how to build and install scanner driver and Canon Electronics Scanner Driver for Linux version 1.00 in pdf. is there a way I can send them to you by E-mail?

Kindly regards

Gerlof Brinck

Gerlof Brinck (brinck) said : #4

Dear Andrew Woodhead, hereby the contens of this documents.

Kindly regards

Gerlof Brinck

Bestand: /home/gerlof/.cache/.fr-mhXjJ.,.e/doc/cndrvsane-d12020u/README Pagina 1 van 1
This file gives a brief description on how to build and instalt Scanner driver
modules
Int roduction:
This package is the scanner driver modules for Canon Electronicns scanners.
These modules are used with SANE (SANE - Scanner Access Now Easy).
This package consists of five modules:
*1 libsane-canondr module
This is a SANE backend module.
*2 canondr_backendd r2020u modute
This is a SANE backend common modute.
*3 canondr_com_usb modute
This is a USB connection module.
*4 canondr.conf file
This is a setting file for SANE.
This package supports the scanners;
( see README-dr2020u-x, xx. txt file)
*5 Configuration files
This is a setting file for a scanner device.
Licensing:
This package consists of five modules as described above.
No.3,4 are subject to GNU Generat Pubtic License (GPL) (see COPYING file)
No.1,2, 5 are subject to Canon Electronics Inc's License (see
LICENSE-dr2020u-x. xx. txt tile) .
Note that licensing term may vary from file to fite. Ptease consult
each files for the exact licensing conditions.
Requirments:
t< tibusb-devel (0,1.8 or above)
'k automake (L.9 .2 o r above )
{< libtool (1.5.6 or above) * sane backend sou rce code ( 1 . 0 . 19 )
Instatt:
To buitd and instalt Scanner driver modulês, run make at
directory of this pakage source trees as follows:
Ptease put sane-backends-L.0.19.tar.gz in the ptace same
$ tar -xzvf sane-backends-L.0. 19.tar.gz
$ cd sane - backends - 1 .0 . 19
$ ./conf igure - -pref Lx=/ usr - -sysconfdir=letc
$ make
Change the top-levet directory of this pakage source trees,
$ make
$ su
# make instatt
the top-tevet
as top-levet directo ry .
Bestand: /home/gerlof/.cache/.fr-FeHri...12020u/README-d12020u-1.00.txt Pagina 1 van 2
Canon
PLEASE
Elect ronics
READ THIS
Scanne r
DOCUMENT
D rive r fo r Linux Ve rsion 1 , 00
CAREFULLY
Tradema rks
SANE
CONTENTS
Before Starting
1. Introduction
2. Distribution File Structure of the Canon Etectronics Scanner Driver for Linux
3. Hardware Requirements
4. Cautions, Limitations, and Restrictions
1.. Introduction
Thank you for using the Canon Electronics Scanner Driver for Linux. This scanner
driver provides scanning functions for Canon Electronics scanners operating under
the SANE (Scan Access Now Easy) environment, a scanning system that operates on
Linux operating systems.
2. Distribution Fite Structure of the Canon Electronics Scanner Driver for Linux -----
The Canon Etectronics Scanner Driver for Linux distribution files are as follows:
Furthermore, the file name for the SANE driver common module and scanner driver
module differs depending on the version.
- README-dr2020u-L.00,txt (This document)
Describes supptementary information on the Canon Electronics Scanner Driver for Linux.
- LICENSE-dr2020u- 1. 00x. txt
Describês User License Agreement on the Canon Electronics Scanner Driver for Linux.
- cndrvsane-dr2020u-1.00-X.i386, rpm (for 32-bit)
- cndrvsane-dr2020u 1.00-X i386,deb (for Debian 32-bit)
Instatlation packagE for the Canon Electronics Scanner Driver for Linux.
3. Hardware Requirements -
This Scanner driver can be used with the fottowing hardware environment.
Hardware: Computer that is enable to operate Linux, with x86 compatible CPU
( 32- bit )
Supported Scanner: DR-2020U
4. Cautions, Limitations, and Restrictions ---
This Scanner driver is tested on the following 0S environment.
Debian GNU Linuxs.0
Debian GNU Linux6.0
Ubuntu 11.04 Desktop
Ubuntu 11. 10 Desktop
Ubuntu 12.04 Desktop
Ubuntu L2.Lg Desktop
Fedo ra L4
Fedo ra 15
Fedo ra 16
Fedo ra L7
SUSE Linuxl1. 3(openSUSE)
SUSE LinuxLI.4 ( openSUSE )
SUSE Lin uxL2. 1 ( openSUSE )
,r-- Elertqngi /hrome/eerror/.cache/.fr-FeHri...12020u/README-dr2020u-L.00.txt Pagina 2 van 2
At installing on Ubuntu Desktop with Ubuntu Software Center, the installation may fail.
So, ptease instatl this Scanner driver package via consote UI.
dpkg -i cndrvsane- dr2020u_1.00-X_i386.deb
Suppo rt
This Software and Related Information are independently developed by Canon and
distributed by Canon locat company. Canon as manufacturer of scanners supporting
the Software and Related Information ("Canon Scanners"), and Canon local company
as selling agency of Canon Scanners, do not receive any user support call and
/or request or any requests for information about the Software and Retated
Information. Any demand for information about Canon Scanners inctuding
information about the repair and suppties for Canon Scanners should be directed
to Canon local company.
Copyright CANON ELECTR0NICS INC. 2013

Manfred Hampl (m-hampl) said : #5

What is the output of the following terminal commands:

uname -a
lsb_release -a
dpkg -l | grep cnrv
lsusb

Gerlof Brinck (brinck) said : #6

Dear Manfred,

Thank you for your reation.
I'am new to Ubuntu the software etc. Sorry I do not know were to look. If you can tell me were to look I will give you the answers.

Kindly Regards

Gerlof.

Manfred Hampl (m-hampl) said : #7

Open a terminal (e.g. by simultaneously pressing ctrl-alt-t)
issue the commands as given above (mark the four lines with pressed mousebutton that they are shown in reverse, switch to the terminal window and press the middle mouse button and finally press the enter key).
and then select all output (using the terminal's menu entry "edit - select all"), copy it ("edit - copy") and paste everything into the "Message:" box of this Launchpad question document.

Gerlof Brinck (brinck) said : #8

gerlof@gerlof-D1740:~$ uname -a
Linux gerlof-D1740 3.2.0-60-generic-pae #91-Ubuntu SMP Wed Feb 19 04:14:56 UTC 2014 i686 i686 i386 GNU/Linux
gerlof@gerlof-D1740:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.4 LTS
Release: 12.04
Codename: precise
gerlof@gerlof-D1740:~$ dpkg -l | grep cnrv
gerlof@gerlof-D1740:~$ lsusb

Manfred Hampl (m-hampl) said : #9

Ok. Your output shows that the driver package from canon is NOT yet installed.

Try the following:

Locate the cnrvsane-dr2020u_1.00-X_i386.deb file on your system
open a terminal and change directory to the directory where that file is (something like "cd /home/gerlof/Downloads")
issue the terminal command
sudo dpkg -i cnrvsane-dr2020u_1.00-X_i386.deb
(adapt file name and directory name to your real situation)

Gerlof Brinck (brinck) said : #10

Dear Manfred,

Thank for your help.
In my situation the name of the file is cndrvsane etc.
Oké,
I have followed your instructions. I have found the directory and this is what has happened:

bash: /home/gerlof/Downloads: Is een map
gerlof@gerlof-D1740:~$ sudo dpkg -i cndrvsane-dr2020u_1.00-4_i386.deb
dpkg: fout bij afhandelen van cndrvsane-dr2020u_1.00-4_i386.deb (--install):
 kan archief niet benaderen: Bestand of map bestaat niet
Fouten gevonden tijdens behandelen van:
 cndrvsane-dr2020u_1.00-4_i386.deb

I will tranlate the dutch to english for you:
Is een map: is a directory

fout bij afhandelen van cndrvsane ....: Error by handling of cndrvsane..
kan archief niet benaderen: can not reach archive

Bestand of map bestaat niet: file or directory does noet exsist.

Fouten gevonden tijdens behandelen van:
Errors found during dealing of:

In my directory /home/gerlof/Downloads I have the following files for my scanner:
2020LINUX_V10.zip
Unpacked gives:
Read me first.pdf
cndrvsane-dr2020u_1.00-4_i386.deb
cndrvsane-dr2020u-1.00-4.i386.rpm
cndrvsane-dr2020u-1.00-4.tar.gz

The text in the read me first is as follows:

Readme for the DR-2020U Linux Driver
Canon does not provide any technical support for this Driver at all.
Canon does not guarantee the specifications of this Driver at all.
Canon does not guarantee the merchantability of this Driver at all.
Canon does not guarantee that this Driver has no bugs or problems at all.
Canon does not accept any liability for any damages caused in using this Driver at all.
Linux Driver 1.0
This DR-2020U Driver for Linux is compatible with SANE (Scanner Access Now
Easy). SANE provides standardized access via API between scanner devices and scanning
applications in the Linux environment. With the SANE Driver, scanning configuration
should be set on the scanning application since it does not have any setting dialogs.

System Requirements
This Driver supports the following environments:
1. Supported CPU
Linux OS and software are designed to work with a specific type of CPU. This
Driver can work on the system with Intel type x86 32bit CPU.
2. Supported Linux Distribution
Typical Linux software supports specific Linux Distributions. This Driver supports
the following Linux Distributions.




Ubuntu: 10.10, 11.04, 11.10, 12.04
Debian: 5.0, 6.0
Fedra: 13, 14, 15, 16
OpenSUSE: 11.3, 11.4, 12.1
Driver Specifications
The specifications of this Driver are as follows.
NOTE: Other functions which ARE NOT DESCRIBED BELOW are not available.





Resolution: 100 / 150 / 200 / 240 / 300 / 400 / 600dpi
Color Mode: B/W / Grey / Color / Error Diffusion / Advanced Text Enhancement II
Scan Mode: Duplex / Simplex
Paper Size: Defined: LTR / LGL / A4 / A5 / A5R / A6 / A6R / B5(JIS) /
B6(JIS) / B6R(JIS)
Others: User Defined / Auto Size Detection, Maximum Deskew
NOTE: The SANE Driver DOES NOT have the capability to adjust image quality, due
to the SANE standard specifications. Therefore, image quality adjustment, such as
Brightness, Contrast, etc., must be processed on the application side.
Important Notice for this Driver
1. Scanning Speed
• The scanning speed with this Driver is reduced approximately 90% than if using
the ISIS/TWAIN Driver for Windows.
2. Installation

The SANE driver for Linux and other Canon released SANE drivers for Linux,
CANNOT co-exist on the same computer.

-------------
So far. I hope you can help me out.
Thamks anyway for you help so far.

Kindly Regards

Gerlof.

Manfred Hampl (m-hampl) said : #11

The commands given by me were not sufficient for your situation, and you ommited two characters.

Try again, open a terminal and issue

cd /home/gerlof/Downloads
pwd
ls
unzip 2020LINUX_V10.zip
ls
sudo dpkg -i cndrvsane-dr2020u_1.00-4_i386.deb

and finally copy/paste all output into this question document as done before.

Gerlof Brinck (brinck) said : #12

gerlof@gerlof-D1740:~$ cd /home/gerlof/Downloads
gerlof@gerlof-D1740:~/Downloads$ pwd
/home/gerlof/Downloads
gerlof@gerlof-D1740:~/Downloads$ ls
2020LINUX_V10.zip ok400pcl_oel.tar_tcm3-116700.gz
Canon DR 2020 U OK400PCL.ppd
cndrvsane-dr2020u_1.00-4_i386.deb OKi B410DN
cndrvsane-dr2020u-1.00-4.i386.rpm OKi C310dn
cndrvsane-dr2020u-1.00-4.tar.gz READMEFIRST.pdf
Dymo 310
gerlof@gerlof-D1740:~/Downloads$ unzip 2020LINUX_V10.zip
Archive: 2020LINUX_V10.zip
replace cndrvsane-dr2020u-1.00-4.i386.rpm? [y]es, [n]o, [A]ll, [N]one, [r]ename: y

Manfred Hampl (m-hampl) said : #13

I see that you already have unpacked that zip file in this directory. You need not do that a second time and can canel the unzip command with "N".

continue with
sudo dpkg -i cndrvsane-dr2020u_1.00-4_i386.deb

Gerlof Brinck (brinck) said : #14

Oké I have don this, I hope it is okë..

gerlof@gerlof-D1740:~/Downloads$ unzip 2020LINUX_V10.zip
Archive: 2020LINUX_V10.zip
replace cndrvsane-dr2020u-1.00-4.i386.rpm? [y]es, [n]o, [A]ll, [N]one, [r]ename: n
sudo d] invalid response [ls
replace cndrvsane-dr2020u-1.00-4.i386.rpm? [y]es, [n]o, [A]ll, [N]one, [r]ename: error: invalid response [pkg -i cn]
replace cndrvsane-dr2020u-1.00-4.i386.rpm? [y]es, [n]o, [A]ll, [N]one, [r]ename: error: invalid response [drvsane-d]
replace cndrvsane-dr2020u-1.00-4.i386.rpm? [y]es, [n]o, [A]ll, [N]one, [r]ename: new name: replace 00-4_i386.debn? [y]es, [n]o, [A]ll, [N]one, [r]ename: n
replace cndrvsane-dr2020u-1.00-4.tar.gz? [y]es, [n]o, [A]ll, [N]one, [r]ename: n
replace cndrvsane-dr2020u_1.00-4_i386.deb? [y]es, [n]o, [A]ll, [N]one, [r]ename: n
replace READMEFIRST.pdf? [y]es, [n]o, [A]ll, [N]one, [r]ename: n
gerlof@gerlof-D1740:~/Downloads$ sudo dpkg -i cndrvsane-dr2020u_1.00-4_i386.deb
[sudo] password for gerlof:
(Database inlezen ... 171928 files and directories currently installed.)
Voorbereiden om cndrvsane-dr2020u 1.00-4 te vervangen (door cndrvsane-dr2020u_1.00-4_i386.deb) ...
Uitpakken van vervangende cndrvsane-dr2020u ...
Instellen van cndrvsane-dr2020u (1.00-4) ...
gerlof@gerlof-D1740:~/Downloads$

Manfred Hampl (m-hampl) said : #15

Ok, the driver seems correctly installed. now try the terminal commands

sane-find-scanner
scanimage -L

If everyithing has worked as planned, you should see that the scanner is identified. If that is the case, you should be able to scan images from your device with xsane or gimp or other applications that can use the scanner.

Gerlof Brinck (brinck) said : #16

gerlof@gerlof-D1740:~$ sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x1083, product=0x1625, chip=GL846?) at libusb:002:002
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.
gerlof@gerlof-D1740:~$ scanimage -L
device `canondr:libusb:002:002' is a Canon DR-2020U sheetfed scanner
gerlof@gerlof-D1740:~$

---------------------
This are the results, thanks. But now if i understand you correctly I have to download xsane or gimp?

Kindly regards

Gerlof.

Manfred Hampl (m-hampl) said : #17

As you can see, the scanner is correctly identified.

There are several applications that now can use the scanner for importing images. xsane is one of them, and it usually is already pre-installed with a standard Ubuntu installation. If not, you can install it with the terminal command
sudo apt-get install xsane
or using software-center, searching for xsane and clicking on 'install that package'. Another psooibility is installing the gimp package (e.g. with 'sudo apt-get install gimp' or again with software-center). With gimp you can import a picture from the scanner and immediately start working with it (lots of modifications possible, and converting into several formats). It very much depends on what you want to achieve.

see also
https://help.ubuntu.com/community/Scanners
https://help.ubuntu.com/community/ScanningHowTo
https://help.ubuntu.com/community/OCR
https://help.ubuntu.com/community/TheGIMP
etc.etc.

Gerlof Brinck (brinck) said : #18

Dear Manfred,

Many thanks for all your help!
I'am just back and have xsane installed. It has found my scanner!!!

So you realy have solved my problem!!

I have made a testscan, oké!

Thanks again.

Kindly Regards

Gerlof.

Marcel Thomas (marcel-thomas) said : #19

Hi Manfred,

similar Problem here.

Same Scanner.

Found USB Connectionn via sane-find-scanner but not with scanimage -L?

What to do now?

Thank for Help
Marcel

@Marcel: the thread status here is "solved", so nobody will look at your question here.

Please create your own question here:

https://answers.launchpad.net/ubuntu/+source/xsane/+addquestion

This new thread will have the status "open" and people will look into it.