Xsane will not work why ? 12.10

Asked by Lynne Stevens on 2012-10-22

Well It started in 12.04 with the printer not printing I deleted the printer HP 1522nf MPF and turned off the computer . . restartd the laptop and installed the printer BUT Xsane will not work . . I have up graded to 12.10 and re did the same thing Still XSANE will not work . . Says it can't find the connetion ! . . WHY . . It worked in 10.10, 11.04, and 11.10 . . Same USB port same printer . .
I really need the scanner working so I can scan pictures or copy things to the computer

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xsane Edit question
Assignee:
No assignee Edit question
Last query:
2012-10-23
Last reply:
2012-10-23

Have you tried grabbing the latest HPLIP from the HPLIP site?

Lynne Stevens (jackie40d) said : #2

HP says they NO LONGER SUPPORT Ubuntu . . And I have the latest installed hplip 3.12.10 downloaded and Installed . . So as I said before What did you do to Ubuntu to make HP stop supporting you ?
http://hplipopensource.com/hplip-web/models/laserjet/hp_laserjet_m1539dnf_mfp.html

I didn't do anything....

Lynne Stevens (jackie40d) said : #4

hahaha Oh well some where some one did something . . maybe your changing things to fast for them to keep up LOL ! ..As HP is kinda slow to change things . . I sent in a thing about the USB ports some ways back as they ask about them . . and the ONLY 2 things were the USB printer and a USB optical mouse the other two USB ports were a PCMICA ports ( 2 each USB ports type 1 USB's )
I am going to remove ALL of the HPLIP ( 4 items ) and the Printer and re start the computer tonight and then plug it in and let it find the printer and download the hp thing and install it . .IF that does not work I am going back to 11.04 . .As EVERYTHING worked then, and I need the Scanner working . . ! ! ( Printer goes into scanning to PC andabout that time Xsane gets dark and drops offthe screen thenI get a error box with it saying could not connect can't find device something . . will not let me do a copy and paste to a page )

Lynne Stevens (jackie40d) said : #5

I have stumbled on the reason for the problem wandering around inside of HPLIP in the NEW CUPS 1.6 HP-LaserJet-M1522nf-MFP is not there I went thru all 561 pages looking for my printer .. NOT there waaaaaaaaaaaaaaaaaaaaaaa !
I can print but NOTHING ELSE scanner will never will not work if HPLIP does not see it and since it is not in the 1.6 version of CUPS . . I added all of the HPLIP I could find except the color 35x printer stuff * about 14 items in the ubuntu Software Center
Still HPLIP wil not see the printer as a scanner or fax . . It says I would have to manually set it up . . Now there is something I could use a bit of help there , ,

I suggest you report a bug

Tony Mansson (tony-mansson) said : #7

Not sure this bug was handled correctly. It appears it ended up in CUPS(?) The original problem was that Xsane stopped working, and it definitly stopped working for me too (HP Photosmart c309a). I have no problem whatsoever printing with this printer. It's scanning that stopped working in 12.10. Xsane finds the scanner connected over both USB and IP. (I can print both ways.)
But when I try to scan I get this error message:
 "Failed to open decvice 'hpaio:/usb/Photosmart_309a_series_?serial<serial_no>: End of file reached.

Can you help with this problem?

Provide an answer of your own, or ask Lynne Stevens for more information if necessary.

To post a message you must log in.