Brother MFC-7340 not recognised by XSane after upgrade to 10.04

Asked by kiriath-arba

I have a friend who had a Brother MFC-7340 printer / scanner working well with the 32 bit version of Ubuntu 9.04. The upgrade of his desktop machine to 9.10 and subsequently to 10.04 appeared to all go fine. However, the following error message now appears when attempting to use XSane with this Brother scanner:

no devices available

Possible reasons:
1) There really is no device that is supported by SANE
2) Supported devices are busy
3) The permissions for the device file do not allow you to use it - try as root
4) The backend is not loaded by SANE (man-dll)
5) The backend is not configured correctly (man sane-"backendname")
6) Possibly there is more than one SANE version installed

Is it just a case of working through the original installation instructions as set out on the Brother website?

I assume the MFC-7340 is still printing fine under 10.04 but will check.


Question information

English Edit question
Ubuntu xsane Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
kiriath-arba (pjrobinson-kol-deactivatedaccount) said :

Is the correct approach for option 3 above to run xsane as root from the terminal? A message appears immediately to warn that this is really dangerous. Was not keen to proceed without understanding the risk first.

Revision history for this message
kiriath-arba (pjrobinson-kol-deactivatedaccount) said :

Problem solved, basically involved working through the installation process again...

I noticed on the Brother website that there is a newer release of the scanner driver out now, so the old driver was first uninstalled:
sudo dpkg -P brscan3

Downloaded the new driver from the Brother website to the Desktop, see

Installed new driver:
sudo dpkg -i --force-all ~/Desktop/brscan3-0.2.11-2.i386.deb

Made the following change as suggested by Brother in "Scanner Setting for normal user"
Ubuntu 9.10, 10.04
    1. Open "/lib/udev/rules.d/40-libsane.rules" file.
    2.Add the following two lines to the end of the device list. (Before the line "# The following rule will disable ..."):

    The lines to be added---------------------------

    # Brother scanners
    ATTRS{idVendor}=="04f9", ENV{libsane_matched}="yes"

    3. Restart the OS.

Also checked the situation here (although perhaps it wasn't really necessary for 10.04):
Ubuntu 9.04
    1. Open "/lib/udev/rules.d/50-udev-default.rules" file.
    2. Edit "0664" to "0666" in "libusb device nodes" section.

    Before the edit---------------------------------

    # libusb device nodes
    SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ... , MODE="0664"

    After the edit----------------------------------

    # libusb device nodes
    SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ... , MODE="0666"

    3. Restart the OS.

Very happy to be back in business with a working scanner.