Problems getting Epson V30 to work in Ubuntu 9.10 x64 with Avasys drivers

Asked by levicivita on 2010-05-06

I just received a brand new Epson V30. I run Ubuntu 9.10 64bit. I downloaded iscan_2.24.0-4.ltdl7_amd64.deb from http://www.avasys.jp/lx-bin2/linux_e/scan/DL1.do. I installed sane ('sudo apt-get install sane') and installed the driver using 'sudo dpkg -i iscan_2.24.0-4.ltdl7_amd64.deb'.

I can see the scanned as being connected:

$ lsusb | grep -i epson
Bus 005 Device 004: ID 04b8:0131 Seiko Epson Corp.

$ sane-find-scanner | grep 0x04b8
found USB scanner (vendor=0x04b8 [EPSON], product=0x0131 [EPSON Scanner]) at libusb:005:004

However, for the life of me scanimage cannot detect it (whether I run it with sudo or not):

$ scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

Any ideas? I am considering returning the scanner given these issues...

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xsane Edit question
Assignee:
No assignee Edit question
Solved by:
levicivita
Solved:
2010-05-06
Last query:
2010-05-06
Last reply:

How stupid! I just noticed a second download at the Avasys website ('esci-interpreter-gt-f720_0.0.1-2_amd64.deb'). I installed that and now everything works like a charm.

Can I give myself credit for solving this issue? :)