How get the sources of gtkdatabox xoscope, to compile

Asked by Ian Carr-de Avelon

I'm moving to Ubuntu from Slackware and I've got a problem compiling a program I want to hack. The program is xoscope and requires gtkdatabox. The configure for gtkdatabox does not find glade3
 Install glade-3 module: no

although I've intalled anything I guessed might be relevant. Also it can't compile what configure expects it to, giving lots of warning and an error:
gtkdatabox.c: In function ‘gtk_databox_realize’:
gtkdatabox.c:594:4: warning: implicit declaration of function ‘GTK_OBJECT_FLAGS’ [-Wimplicit-function-declaration]
gtkdatabox.c:594:4: error: lvalue required as left operand of assignment

I guess that things are simply not in the expected place but I'm outside my comfort zone working out what.

There is xoscope in the Ubuntu software centre, so someone has solved this. How do I get access to their source code to see how they did it, in the same way that I can look on the source disc or the patch on Slackbuild when using Slackware?

Question information

English Edit question
Ubuntu xoscope Edit question
No assignee Edit question
Solved by:
Ian Carr-de Avelon
Last query:
Last reply:
Revision history for this message
Ian Carr-de Avelon (carrdeavelon) said :

I've now found that I can use
sudo apt-get source xoscope
to get what I need