can't load ATI proprietary driver in Ubuntu 8.10

Asked by cali30us on 2009-02-14

This seems to be a problem that affects many others, so I'm hoping someone can help shed some light on this. My aim is to get Ubuntu 8.10 to work with my video card (ATI Radeon 9500 Pro) so that I can eventually install Compiz (and get those cool video effects).

After performing a fresh install of Ubuntu (no upgrade), the generic ATI driver leaves me with display resolutions that I don't want and the only refresh rate is 60Hz (flickers on my CRT). The monitor is listed as Unknown, and clicking on Detect Displays does nothing to change this (I have an NEC Accusync 95F 19" multisync monitor). Hardware Drivers lists nothing. I tried installing all ~250 Security and Recommended updates for Ubuntu, but this had no effect.

I found Bug #284408 (https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/284408), dated Oct-08, which says fglrx-installer 2:8.543-0ubuntu4 doesn't work with R300-based adapters (like mine), and to just use the generic driver.

But then I found the ATI Catalyst 9.1 driver (http://ati.amd.com/support/drivers/linux/linux-radeon.html), dated 1-29-09, whose Release Notes say "This release of ATI Catalystâ„¢ Linux introduces support for the following new operating system: Ubuntu 8.10 production support." They provide installation instructions, but I found the best instructions at the Ubuntu Intrepid Installation Guide for ATI drivers (http://wiki.cchtml.com/index.php/Ubuntu_Intrepid_Installation_Guide).

After following those instructions, though, I still get errors at startup, basically No Screens Found". I'm attaching my Xorg.0.log and xorg.conf files so you can see just what's going on.

If anyone has an idea how to get this working, I, and the others in the same boat, would be very appreciative. I'm new to Linux, so it might just be a simple error on my part. I'm also not sure about the difference between fglrx-installer and the Catalyst driver; are they the same, does the Catalyst driver include the installer, do I just use the previous version of the installer, or what?

Thanks!

XORG.LOG file:
X.Org X Server 1.5.2
Release Date: 10 October 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-19-server i686 Ubuntu
Current Operating System: Linux mypc 2.6.27-11-generic #1 SMP Thu Jan 29 19:24:39 UTC 2009 i686
Build Date: 24 October 2008 08:00:16AM
xorg-server 2:1.5.2-2ubuntu3 (<email address hidden>)
 Before reporting problems, check http://wiki.x.org
 to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
 (++) from command line, (!!) notice, (II) informational,
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Feb 7 13:59:25 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "aticonfig Layout"
(**) |-->Screen "aticonfig-Screen[0]-0" (0)
(**) | |-->Monitor "aticonfig-Monitor[0]-0"
(**) | |-->Device "aticonfig-Device[0]-0"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
 Entry deleted from font path.
(==) FontPath set to:
 /usr/share/fonts/X11/misc,
 /usr/share/fonts/X11/100dpi/:unscaled,
 /usr/share/fonts/X11/75dpi/:unscaled,
 /usr/share/fonts/X11/Type1,
 /usr/share/fonts/X11/100dpi,
 /usr/share/fonts/X11/75dpi,
 /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
 If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Loader magic: 0x81d9a40
(II) Module ABI versions:
 X.Org ANSI C Emulation: 0.4
 X.Org Video Driver: 4.1
 X.Org XInput driver : 2.1
 X.Org Server Extension : 1.1
 X.Org Font Renderer : 0.6
(II) Loader running on linux
(++) using VT number 7

(--) PCI:*(0@3:0:0) ATI Technologies Inc Radeon R300 NE [Radeon 9500 Pro] rev 0, Mem @ 0xd0000000/0, 0xe5000000/0, I/O @ 0x0000a000/0, BIOS @ 0x????????/131072
(--) PCI: (0@3:0:1) ATI Technologies Inc Radeon R300 [Radeon 9500 Pro] (Secondary) rev 0, Mem @ 0xd8000000/0, 0xe5010000/0
(II) System resource ranges:
 [0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
 [1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
 [2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
 [3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
 [4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
 [5] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(II) "extmod" will be loaded by default.
(II) "dbe" will be loaded by default.
(II) "glx" will be loaded by default.
(II) "freetype" will be loaded by default.
(II) "record" will be loaded by default.
(II) "dri" will be loaded by default.
(II) LoadModule: "extmod"

(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
 compiled for 1.5.2, module version = 1.0.0
 Module class: X.Org Server Extension
 ABI class: X.Org Server Extension, version 1.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"

(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
 compiled for 1.5.2, module version = 1.0.0
 Module class: X.Org Server Extension
 ABI class: X.Org Server Extension, version 1.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"

(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
 compiled for 7.4.0, module version = 1.0.0
 ABI class: X.Org Server Extension, version 1.1
(**) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "freetype"

(II) Loading /usr/lib/xorg/modules//fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
 compiled for 1.5.2, module version = 2.1.0
 Module class: X.Org Font Renderer
 ABI class: X.Org Font Renderer, version 0.6
(II) Loading font FreeType
(II) LoadModule: "record"

(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
 compiled for 1.5.2, module version = 1.13.0
 Module class: X.Org Server Extension
 ABI class: X.Org Server Extension, version 1.1
(II) Loading extension RECORD
(II) LoadModule: "dri"

(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
 compiled for 7.4.0, module version = 1.0.0
 ABI class: X.Org Server Extension, version 1.1
(II) Loading extension XFree86-DRI
(II) LoadModule: "fglrx"

(II) Loading /usr/lib/xorg/modules/drivers//fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
 compiled for 1.4.99.906, module version = 8.57.2
 Module class: X.Org Video Driver
(II) Primary Device is: PCI 03@00:00:0
(WW) Falling back to old probe method for fglrx
(II) ATI Proprietary Linux Driver Version Identifier:8.57.2
(II) ATI Proprietary Linux Driver Release Identifier: 8.573
(II) ATI Proprietary Linux Driver Build Date: Jan 13 2009 23:21:39
(WW) This ATI Proprietary Linux Driver does not guarantee support of video driver ABI higher than 2.0
(WW) Video driver ABI version of the X server is 4.1
(II) AMD ASIC control file status: R12 S1 B313 N313 T312
(WW) fglrx: No matching Device section for instance (BusID PCI:0@3:0:1) found
(EE) No devices detected.

Fatal server error:
no screens found

END XORG.LOG

XORG.CONF FILE:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
 Identifier "aticonfig Layout"
 Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "Monitor"
 Identifier "aticonfig-Monitor[0]-0"
 Option "VendorName" "ATI Proprietary Driver"
 Option "ModelName" "Generic Autodetecting Monitor"
 Option "DPMS" "true"
 Option "HorizSync" "31-96"
 Option "VertRefresh" "55-160"
EndSection

Section "Device"
 Identifier "aticonfig-Device[0]-0"
 Driver "fglrx"
 Option "UseFastTLS" "1"
 BusID "PCI:3:0:0"
EndSection

Section "Screen"
 Identifier "aticonfig-Screen[0]-0"
 Device "aticonfig-Device[0]-0"
 Monitor "aticonfig-Monitor[0]-0"
 DefaultDepth 24
 SubSection "Display"
  Viewport 0 0
  Depth 24
  Modes "1280x1024" "1024x768" "800x600" "1152x870"
 EndSubSection
EndSection

END XORG.CONF FILE

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xorg Edit question
Assignee:
No assignee Edit question
Solved by:
cali30us
Solved:
2009-02-15
Last query:
2009-02-15
Last reply:
2009-02-14
peter b (b1pete) said : #1

first question

- did you install the driver via system --> admin --> hardware drivers ?

if yes then did you notice ......'Note that when Visual Effects (Compiz) are active, flickering and artifacts may occur in OpenGL applications and hardware accelerated video windows (particularly with R300 chipset). To prevent this, disable Visual Effects. '.....? on

http://wiki.cchtml.com/index.php/Ubuntu_Intrepid_Installation_Guide

that should not have been enabled when hardware drivers were activated/installed as described above.

I'd recommend to deactivate the driver first, reboot, disable visual effects (should be none), then reactivate the hardware drivers as above, reboot.

tell us what happened.

peter b

george (gk-joimail) said : #2

I have found, you MUST deactivate the "Proprietary Driver" first before the installing of the 9.1 ATI driver. The downloading of the new driver and installation needs to be done in low graphics mode. It took some time for me to get the thing running correctly, but finally did, once installed do not activate the Proprietary driver, just let the new driver do it's stuff. Once done the Compiz effects do all work. Here is what my xorg.conf looks like now.

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg
# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Generic Keyboard"
# Driver "kbd"
# Option "XkbRules" "xorg"
# Option "XkbModel" "pc105"
# Option "XkbLayout" "us"
#EndSection
# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Configured Mouse"
# Driver "mouse"
# Option "CorePointer"
#EndSection

Section "ServerLayout"
 Identifier "Default Layout"
 Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "Monitor"
 Identifier "aticonfig-Monitor[0]-0"
 Option "VendorName" "ATI Proprietary Driver"
 Option "ModelName" "Generic Autodetecting Monitor"
 Option "DPMS" "true"
EndSection

Section "Device"
 Identifier "aticonfig-Device[0]-0"
 Driver "fglrx"
 BusID "PCI:1:0:0"
EndSection

Section "Screen"
 Identifier "aticonfig-Screen[0]-0"
 Device "aticonfig-Device[0]-0"
 Monitor "aticonfig-Monitor[0]-0"
 DefaultDepth 24
 SubSection "Display"
  Viewport 0 0
  Depth 24
 EndSubSection
EndSection

Plus when the install was done, I ended up with a new "Catalyst Control Center (super user)"

Hope this helps
George

cali30us (hythere2) said : #3

No, I did not install through System-Admin-Hardware Drivers. That actually had no drivers listed at all, and didn't seem to have a way to install a driver not listed.
Visual effects were not enabled.
I installed the Catalyst driver manually according to Ubuntu Intrepid Installation Guide for ATI drivers (http://wiki.cchtml.com/index.php/Ubuntu_Intrepid_Installation_Guide).

I decided to install Hardy, instead, and lo and behold, Hardware Drivers listed a proprietary driver, which I installed. I had to add refresh rates in my xorg.conf file, then all was good. BTW, the format
Option "HorizSync" "31-96"
doesn't work in Hardy. It must be listed as
HorizSync 31-96
in order to work. At least on my system.
Thanks for your responses. I guess Intrepid just wasn't in the cards for my system.
-Cali30us

george (gk-joimail) said : #4

come to think about it, when I installed 8.1 I couldn't get things to operate correctly either. So I installed 8.04 first then updated to 8.1 through update manager. After doing that 8.1 worked and had no issues, other than the ones I created.

If you are brave you might just do a update from 8.04 to 8.1

George