ATI video driver

Asked by joe pellouchoud on 2008-12-28

I am trying to get my video card and monitor working properly.
I have an ATI Radeon 2600HD card and it is driving a Gateway VX1100 19 inch crt monitor.
I have done apt-get install xorg-driver-fglrx
and now the book says I should edit xorg.conf and change the driver line to fglrx.
I am afraid to make things worse, at least now I can read the screen.
Has anyone made a similar configuration work?

My xorg.conf file shows:

Section "Device"
        Identifier "Configured Video Device"
        Driver "vesa"
EndSection

Section "Monitor"
        Identifier "Configured Monitor"
EndSection

Section "Screen"
        Identifier "Default Screen"
        Monitor "Configured Monitor"
        Device "Configured Video Device"
EndSection

I assume that the “fglrx” replaces “vesa”
I don't know what to put in place of “configured monitor”

Thanks....joe

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xorg Edit question
Assignee:
No assignee Edit question
Solved by:
peter b
Solved:
2008-12-28
Last query:
2008-12-28
Last reply:
2008-12-28
Arnaudus (a-lerouzic) said : #1

Hi,

I have the same card, and here is an extract of my xorg.conf :

--------------------------------------
Section "Module"
        Load "glx"
EndSection

Section "Device"
        Identifier "Configured Video Device"
        Driver "fglrx"
EndSection
--------------------------------------

I must say I'm not sure the first part is necessary. Don't change anything for the monitor.

What is really important is to copy the old file somewhere. In case of problem, boot in safe mode and just copy it back to its original location.

Hope this helps!

Best peter b (b1pete) said : #2

joe, just go to System --> Administration --> Hardware Drivers and enable/activate the driver; the driver will be downloaded and installed. you'd have to reboot after that; there is no need to fiddle with xorg.conf.

I'd recommend, just to be on the safe side, to remove first the driver that you installed as noted on your post BEFORE activating the new driver mentioned above.

peter b

joe pellouchoud (llepeoj) said : #3

Thanks

joe pellouchoud (llepeoj) said : #4

It is working after a fashion. Still not quite where I think it should be. I cannot change screen resolution without garbling the display. It seems to come up OK when I reboot. Thanks for ideas.