default resolution on Intrepid Ibex

Asked by Daftword on 2008-11-05

Upgrading from 8.04 into Intrepid has caused havoc!
My Monitor has a maximum resolution of 1024x768 however the new default seems to be higher.
I get through grub loader ok, however at the login screen the screen greys, my monitor self adjusts from 700x400 to 1024x768 @71Hz
I have connection the machine to a monitor with a higher res and it works fine.
Any suggestions before I go retro?

Thanks,

Andrew

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xorg Edit question
Assignee:
No assignee Edit question
Solved by:
kenden
Solved:
2008-11-06
Last query:
2008-11-06
Last reply:
2008-11-06
Best kenden (kenden) said : #1

Hi,

You should be able to change the resolution in System > Preferences > Screen Resolution.
OR try to press CTRL+ALT+"+" and/or CTRL+ALT+"-" to dynamically change video frequency.

If that doesn't work, maybe your old conf from Ubuntu 8.04 is causing an issue.
The X-server devs have made the file xorg.conf almost unnecessary. Ubuntu now autodetects the proper configuration.
Try to rename your file /etc/X11/xorg.conf, so the X-server doesn't find it
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak.post.intrepid
and restart the computer.
Check the System > Preferences > Screen Resolution again if necessary.
(If you can't see the desktop at all, press CTRL-ALT-F1 to get the console and rename the file from there)

If that doesn't help, try:
Type "sudo dpkg-reconfigure xserver-xorg"
Try will recreate the xorg.conf file with fresh settings. Restart. If you still have the problem, you probably need to edit the xorg.conf file manually.
Type "sudo gedit /etc/X11/xorg.conf" to view it and modify it.
You need to configure the "Monitor" part with your monitor settings (check the vendors manual, or their website).
Here is an example:

Section "Monitor"
    Identifier "CM752ET"
    HorizSync 31-101
    VertRefresh 60-160
EndSection

And from the Display part , delete any Modes the computer does not support.

If that doesn't help, which graphic card do you have in the computer?

Daftword (daftword) said : #2

Thanks for your prompt reply.
Unfortunately to no avail. A few more details of my machine may help.
As the acer works with other monitors the screen I am attempting to connect with is :
[url]http://www.avatec.com.au/LCDAC_brochure.pdf[/url] (an LG panel with a modified soundcard.
I agree with your diagnosis of xorg, here are my results.
renaming xorg.conf = " mv: cannot stat ' /etc/x11/xorg.conf ' no such file or directory.
then I attempted to edit as suggested, (gedit:5927): Gtk WARNING ** Cannot open display.

thanks again... any further suggestions??

Daftword (daftword) said : #3

Hi Kenden,

Thanks for your prompt reply.
Unfortunately to no avail. A few more details of my machine may help.
As the acer works with other monitors the screen I am attempting to connect
with is : http://www.avatec.com.au/LCDAC_brochure.pdf (an LG panel with a
modified soundcard.
I agree with your diagnosis of xorg, here are my results.
renaming xorg.conf = " mv: cannot stat ' /etc/x11/xorg.conf ' no such file
or directory.
then I attempted to edit as suggested, (gedit:5927): Gtk WARNING ** Cannot
open display.

thanks again... any further suggestions??

On Thu, Nov 6, 2008 at 3:20 PM, kenden
<email address hidden>wrote:

> Your question #50317 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/50317
>
> Status: Open => Answered
>
> kenden proposed the following answer:
> Hi,
>
> You should be able to change the resolution in System > Preferences >
> Screen Resolution.
> OR try to press CTRL+ALT+"+" and/or CTRL+ALT+"-" to dynamically change
> video frequency.
>
> If that doesn't work, maybe your old conf from Ubuntu 8.04 is causing an
> issue.
> The X-server devs have made the file xorg.conf almost unnecessary. Ubuntu
> now autodetects the proper configuration.
> Try to rename your file /etc/X11/xorg.conf, so the X-server doesn't find it
> sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak.post.intrepid
> and restart the computer.
> Check the System > Preferences > Screen Resolution again if necessary.
> (If you can't see the desktop at all, press CTRL-ALT-F1 to get the console
> and rename the file from there)
>
> If that doesn't help, try:
> Type "sudo dpkg-reconfigure xserver-xorg"
> Try will recreate the xorg.conf file with fresh settings. Restart. If you
> still have the problem, you probably need to edit the xorg.conf file
> manually.
> Type "sudo gedit /etc/X11/xorg.conf" to view it and modify it.
> You need to configure the "Monitor" part with your monitor settings (check
> the vendors manual, or their website).
> Here is an example:
>
> Section "Monitor"
> Identifier "CM752ET"
> HorizSync 31-101
> VertRefresh 60-160
> EndSection
>
> And from the Display part , delete any Modes the computer does not
> support.
>
> If that doesn't help, which graphic card do you have in the computer?
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/50317/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/50317
>
> You received this question notification because you are a direct
> subscriber of the question.
>

kenden (kenden) said : #4

Hi Daftword,

First you need to create the xorg.conf with:
"sudo dpkg-reconfigure xserver-xorg"
Does this go fine? This program configures xorg.conf, asking you questions along the way.

You can check you have a new xorg.conf afterwards with:
"ls -i /etc/X11/xorg.conf"

You can test if the X server starts fine at this point (try "startx", or restart the machine). It should work.

If not, we need to edit the xorg.conf...
I think the command "sudo gedit /etc/X11/xorg.conf... returned an error before ("gedit:5927: Gtk WARNING ** Cannot
open display") because gedit is a Gnome program, which needs the display, which you don't have!

So lets use another editor that works in the console, like nano:
"sudo nano /etc/X11/xorg.conf"

Hope this helps!

Daftword (daftword) said : #5

Thanks Kenden,
You've done wonders for me.
Thats got to count as your good deed for the day!

Cheers,

Andrew