Unable to change the refresh rate of the monitor

Asked by Renan Araujo Rischiotto on 2014-09-04

The xrandr does not work with the proprietary NVIDIA drivers, and in Unity and "NVIDIA X Server Settings" there is no option to change the refresh rate of the monitor and I need to change.

Ubuntu 14.04.1
Xorg 1.15.1
Driver 331.38

 Theads on Ubuntu forums (without solution):


Question information

English Edit question
Ubuntu xorg Edit question
No assignee Edit question
Last query:
Last reply:

What is the output of:

sudo lshw -C display




renan@ubuntu:~$ sudo lshw -C display
[sudo] password for renan:
       description: VGA compatible controller
       product: GT218 [GeForce 8400 GS Rev. 3]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:45 memory:fd000000-fdffffff memory:e0000000-efffffff memory:de000000-dfffffff ioport:ec00(size=128) memory:fe000000-fe07ffff


If you run:

sudo nvidia-settings; sudo gedit /etc/X11/xorg.conf

You can set the refresh rate in xorg.conf and reboot. If you get no X then press CTRL+ALT+F1 and rename the xorg.conf and reboot. You can then copy back and retry.

I already tried that. create a file "xorg.conf" by "nvidia-settings". See the topics created in the Ubuntu forums.

Actually, I do not know how to change the refresh rate of the monitor in "xorg.conf", did not inform me there in the forums. I tried it myself searching the internet and adding some things in the file, but it did not work.

Can you show your xorg.conf please. Copy and paste the file as an update. There is no length limit :-)

Can you show your xorg.conf please. Copy and paste the file as an update. There is no length limit :-)

michael (yellupcm-gmail) said : #9

On NVIDIA X Server Settings
X Server Display Configuration
Is it set on Auto? If so, change to a resolution, the next box to right will allow change of refresh rate.

michael (yellupcm-gmail)

Wow! That simple! Had never tried it! Thank you!

actionparsnip (andrew-woodhead666)

Thank you man for your disposal, attention and help!

Well, it worked, but every time I boot my system I have to configure. How to make the setting becomes permanent?

Hello everyone,

I'm having the same problem. I've tried Ubuntu 14.04 with Unity and Gnome 3 (Ubuntu Gnome).
I work with vision research and keeping the refresh rate is really important (so I don't have to worry about it every time I perform a data collection).
After searching the internet for a while I find some bugs that might be related to the problem, but I not so shure about it (e.g.: https://bugs.launchpad.net/ubuntu/+source/gnome-system-monitor/+bug/1303079).
The only 'solution' I found was downgrading to 12.04, because there everything works fine (the config is kept after reboot). I just had to save a xorg.conf from the nvidia-settings.
As every release brings improvements, it would be really nice if I could perform my experiments using a possibly more precise grapchis system (Ubuntu 14.04 with new nvidia drivers).
I would be glad to perform tests and report any information required to help.

Best wishes,

Can you help with this problem?

Provide an answer of your own, or ask Renan Araujo Rischiotto for more information if necessary.

To post a message you must log in.