Xorg via ssh: Unable to focus child windows

Asked by Dan on 2014-02-25

This is strongly related to this bug report:
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/362359

Annoying problem, seems to be around for quite a while and i don't really understand where it stems from:

When i run an application (Matlab r2013b) via ssh -X or -Y, and open 1 (problem occurs sometimes) or more (occurs always) child windows within it (e.g. editor, figures) the focus will get stuck to one of those windows while the other(s) are unfocusable.
By this I mean that I can still drag&drop each of the unfocusable windows to the top, but when i then click anyhwere else inside these windows (other than the drag&drop bar) I will only select the focussed window lying in the back.

From the above mentioned bug report and other sources, I have gathered that this seems to occur regardless of distro, desktop and hardware.

Additional info:
* Ubuntu 12.04, Unity
* Using a laptop, problem occurs regardless of using touchpad or usb mouse
* intel graphics and nvidia (bumblebee)

Thanks for any advice!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xorg Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2014-02-26
Last query:
2014-02-26
Last reply:
2014-02-26

Have you tried in the Unity2D session which is selectable on the login page?

Dan (juncu-d) said : #2

Many thanks! In Unity 2D this problem doesn't seem to exist. So is it dependent on the desktop environment after all? Should i maybe switch to gnome or something else?

No, the desktop environment is still Gnome, just as it is in the 3D session. The difference is the window manager. 3D uses Compiz wheras the 2D one uses Metacity. If you installed the Ubuntu ISO then you are using Gnome. Unity is not a desktop environment and does not replace Gnome. Unity is nothing more than a plugin for Compiz like wobbly-windows.

If it works as expected then there is a bug with Compiz and I suggest you report a bug. Personally I think Compiz is garbage and should be dropped but people like the redundant eye candy it gives.

I recommend you stick to the 2D session, it uses fewer resources too.

Dan (juncu-d) said : #4

Thanks actionparsnip, that solved my question.

Dan (juncu-d) said : #5

And thanks for the explanation!