video driver

Asked by pete on 2014-02-09

i cant seem to get a video driver to load

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: xorg 1:7.7+1ubuntu6
ProcVersionSignature: Ubuntu 3.11.0-17.31-generic 3.11.10.3
Uname: Linux 3.11.0-17-generic i686
.tmp.unity.support.test.0:

ApportVersion: 2.12.5-0ubuntu2.2
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Sun Feb 9 19:41:40 2014
DistUpgraded: 2013-10-31 10:06:17,994 DEBUG enabling apt cron job
DistroCodename: saucy
DistroVariant: ubuntu
DkmsStatus:
 nvidia-304, 304.88, 3.11.0-13-generic, i686: installed
 nvidia-304, 304.88, 3.11.0-14-generic, i686: installed
 nvidia-304, 304.88, 3.11.0-15-generic, i686: installed
 nvidia-304, 304.88, 3.11.0-17-generic, i686: installed
ExtraDebuggingInterest: I just need to know a workaround
GraphicsCard:
 Intel Corporation 82G33/G31 Express Integrated Graphics Controller [8086:29c2] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0238]
InstallationDate: Installed on 2013-06-26 (227 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release i386 (20130424)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-17-generic root=UUID=e72f995f-0341-47a9-9695-b927a0c74fbb ro drm.debug=0xe plymouth:debug
SourcePackage: xorg
UpgradeStatus: Upgraded to saucy on 2013-10-31 (101 days ago)
dmi.bios.date: 09/20/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.0.16
dmi.board.name: 0CU409
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: OEM
dmi.modalias: dmi:bvnDellInc.:bvr1.0.16:bd09/20/2008:svnDellInc.:pnVostro200:pvr:rvnDellInc.:rn0CU409:rvr:cvnDellInc.:ct3:cvrOEM:
dmi.product.name: Vostro 200
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
version.libdrm2: libdrm2 2.4.52+git1401311830.128e74~gd~s
version.libgl1-mesa-dri: libgl1-mesa-dri 10.2~git1402090730.356aff~gd~s
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.2~git1402090730.356aff~gd~s
version.xserver-xorg-core: xserver-xorg-core 2:1.14.5-1ubuntu2~saucy1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3+git1401241930.8de6f7~gd~s
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.909+git1402061930.823382~gd~s
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10+git1311070905.480f09~gd~s
xserver.bootTime: Sun Feb 9 19:33:09 2014
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input G-Tech CHINA USB Wireless Mouse & KeyBoard V1.01 KEYBOARD, id 8
 input G-Tech CHINA USB Wireless Mouse & KeyBoard V1.01 KEYBOARD, id 9
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 22114
 vendor GSM
xserver.version: 2:1.14.5-1ubuntu2~saucy1

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xorg Edit question
Assignee:
No assignee Edit question
Last query:
2014-02-10
Last reply:
2014-02-11

This question was originally filed as bug #1278160.

So you had nvidia-173 installed as well??? Sigh...

Converting to a question since you have all kinds of third-party and conflicting drivers installed, and your changes are unsupported by Canonical. Quite frankly, it seems you mucked up the system and it's beyond my personal level of patience to help you straighten it out

Good luck.

What is the output of:

sudo lshw -C display; apt-cache policy `dpkg -l | grep nvidia | awk {'print $2'}`

Thanks

pete (peterhall347) said : #3

hey don't blame me .. the problems started after upgrading to 13.10 ...suppose it was my fault though for taking a chance with it .. cant wait for the next lts to be available ..
i will do another bug report now nvidia should be gone

pete (peterhall347) said : #4

*-display
       description: VGA compatible controller
       product: 82G33/G31 Express Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 02
       width: 32 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:42 memory:fdf00000-fdf7ffff ioport:ff00(size=8) memory:d0000000-dfffffff memory:fdb00000-fdbfffff
Usage: awk [POSIX or GNU style options] -f progfile [--] file ...
Usage: awk [POSIX or GNU style options] [--] 'program' file ...
POSIX options: GNU long options: (standard)
 -f progfile --file=progfile
 -F fs --field-separator=fs
 -v var=val --assign=var=val
Short options: GNU long options: (extensions)
 -b --characters-as-bytes
 -c --traditional
 -C --copyright
 -d[file] --dump-variables[=file]
 -e 'program-text' --source='program-text'
 -E file --exec=file
 -g --gen-pot
 -h --help
 -L [fatal] --lint[=fatal]
 -n --non-decimal-data
 -N --use-lc-numeric
 -O --optimise
 -p[file] --profile[=file]
 -P --posix
 -r --re-interval
 -S --sandbox
 -t --lint-old
 -V --version

To report bugs, see node `Bugs' in `gawk.info', which is
section `Reporting Problems and Bugs' in the printed version.

gawk is a pattern scanning and processing language.
By default it reads standard input and writes standard output.

Examples:
 gawk '{ sum += $1 }; END { print sum }' file
 gawk -F: '{ print $1 }' /etc/passwd
{print $2}: command not found
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu/ saucy/main i386 Packages
     release v=13.10,o=LP-PPA-oibaf-graphics-drivers,a=saucy,n=saucy,l=Updated and Optimized Open Graphics Drivers,c=main
     origin ppa.launchpad.net
 500 https://download.01.org/gfx/ubuntu/13.10/main/ saucy/main i386 Packages
     release o=ubuntu,n=saucy,l=ubuntu/saucy repository,c=main
     origin download.01.org
 500 http://dl.google.com/linux/chrome/deb/ stable/main i386 Packages
     release v=1.0,o=Google, Inc.,a=stable,n=stable,l=Google,c=main
     origin dl.google.com
 500 http://archive.ubuntu.com/ubuntu/ saucy-proposed/universe Translation-en_GB
 500 http://archive.ubuntu.com/ubuntu/ saucy-proposed/universe Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy-proposed/restricted Translation-en_GB
 500 http://archive.ubuntu.com/ubuntu/ saucy-proposed/restricted Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy-proposed/multiverse Translation-en_GB
 500 http://archive.ubuntu.com/ubuntu/ saucy-proposed/multiverse Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy-proposed/main Translation-en_GB
 500 http://archive.ubuntu.com/ubuntu/ saucy-proposed/main Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy-proposed/universe i386 Packages
     release v=13.10,o=Ubuntu,a=saucy-proposed,n=saucy,l=Ubuntu,c=universe
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ saucy-proposed/multiverse i386 Packages
     release v=13.10,o=Ubuntu,a=saucy-proposed,n=saucy,l=Ubuntu,c=multiverse
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ saucy-proposed/restricted i386 Packages
     release v=13.10,o=Ubuntu,a=saucy-proposed,n=saucy,l=Ubuntu,c=restricted
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ saucy-proposed/main i386 Packages
     release v=13.10,o=Ubuntu,a=saucy-proposed,n=saucy,l=Ubuntu,c=main
     origin archive.ubuntu.com
 500 http://extras.ubuntu.com/ubuntu/ saucy/main i386 Packages
     release v=13.10,o=LP-PPA-app-review-board,a=saucy,n=saucy,l=Application Review Board PPA,c=main
     origin extras.ubuntu.com
 500 http://archive.canonical.com/ubuntu/ saucy/partner i386 Packages
     release v=13.10,o=Canonical,a=saucy,n=saucy,l=Partner archive,c=partner
     origin archive.canonical.com
 500 http://archive.ubuntu.com/ubuntu/ saucy-security/universe Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy-security/restricted Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy-security/multiverse Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy-security/main Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy-security/multiverse i386 Packages
     release v=13.10,o=Ubuntu,a=saucy-security,n=saucy,l=Ubuntu,c=multiverse
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ saucy-security/universe i386 Packages
     release v=13.10,o=Ubuntu,a=saucy-security,n=saucy,l=Ubuntu,c=universe
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ saucy-security/restricted i386 Packages
     release v=13.10,o=Ubuntu,a=saucy-security,n=saucy,l=Ubuntu,c=restricted
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ saucy-security/main i386 Packages
     release v=13.10,o=Ubuntu,a=saucy-security,n=saucy,l=Ubuntu,c=main
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ saucy-backports/universe Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy-backports/restricted Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy-backports/multiverse Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy-backports/main Translation-en
 100 http://archive.ubuntu.com/ubuntu/ saucy-backports/multiverse i386 Packages
     release v=13.10,o=Ubuntu,a=saucy-backports,n=saucy,l=Ubuntu,c=multiverse
     origin archive.ubuntu.com
 100 http://archive.ubuntu.com/ubuntu/ saucy-backports/universe i386 Packages
     release v=13.10,o=Ubuntu,a=saucy-backports,n=saucy,l=Ubuntu,c=universe
     origin archive.ubuntu.com
 100 http://archive.ubuntu.com/ubuntu/ saucy-backports/restricted i386 Packages
     release v=13.10,o=Ubuntu,a=saucy-backports,n=saucy,l=Ubuntu,c=restricted
     origin archive.ubuntu.com
 100 http://archive.ubuntu.com/ubuntu/ saucy-backports/main i386 Packages
     release v=13.10,o=Ubuntu,a=saucy-backports,n=saucy,l=Ubuntu,c=main
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ saucy-updates/universe Translation-en_GB
 500 http://archive.ubuntu.com/ubuntu/ saucy-updates/universe Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy-updates/restricted Translation-en_GB
 500 http://archive.ubuntu.com/ubuntu/ saucy-updates/restricted Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy-updates/multiverse Translation-en_GB
 500 http://archive.ubuntu.com/ubuntu/ saucy-updates/multiverse Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy-updates/main Translation-en_GB
 500 http://archive.ubuntu.com/ubuntu/ saucy-updates/main Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy-updates/multiverse i386 Packages
     release v=13.10,o=Ubuntu,a=saucy-updates,n=saucy,l=Ubuntu,c=multiverse
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ saucy-updates/universe i386 Packages
     release v=13.10,o=Ubuntu,a=saucy-updates,n=saucy,l=Ubuntu,c=universe
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ saucy-updates/restricted i386 Packages
     release v=13.10,o=Ubuntu,a=saucy-updates,n=saucy,l=Ubuntu,c=restricted
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ saucy-updates/main i386 Packages
     release v=13.10,o=Ubuntu,a=saucy-updates,n=saucy,l=Ubuntu,c=main
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ saucy/universe Translation-en_GB
 500 http://archive.ubuntu.com/ubuntu/ saucy/universe Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy/restricted Translation-en_GB
 500 http://archive.ubuntu.com/ubuntu/ saucy/restricted Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy/multiverse Translation-en_GB
 500 http://archive.ubuntu.com/ubuntu/ saucy/multiverse Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy/main Translation-en_GB
 500 http://archive.ubuntu.com/ubuntu/ saucy/main Translation-en
 500 http://archive.ubuntu.com/ubuntu/ saucy/multiverse i386 Packages
     release v=13.10,o=Ubuntu,a=saucy,n=saucy,l=Ubuntu,c=multiverse
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ saucy/universe i386 Packages
     release v=13.10,o=Ubuntu,a=saucy,n=saucy,l=Ubuntu,c=universe
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ saucy/restricted i386 Packages
     release v=13.10,o=Ubuntu,a=saucy,n=saucy,l=Ubuntu,c=restricted
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ saucy/main i386 Packages
     release v=13.10,o=Ubuntu,a=saucy,n=saucy,l=Ubuntu,c=main
     origin archive.ubuntu.com
Pinned packages:

And the output of :

dpkg -l | grep nvidia

Thanks

pete (peterhall347) said : #6

dpkg -l | grep nvidia

no output

Ok, what is the output of:

uname -a

And we can get a driver installed for you.

Also run:

wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg -O - | sudo apt-key add -
wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg-2 -O - | sudo apt-key add -

To import some keys.

pete (peterhall347) said : #8

Linux pete-Vostro-200 3.11.0-17-generic #31-Ubuntu SMP Mon Feb 3 21:53:31 UTC 2014 i686 i686 i686 GNU/Linux

i don't understand importing keys as the links open in the browser such as this ...

-BEGIN PGP PUBLIC KEY BLOCK-----
Version: SKS 1.1.0

mQENBFEuWW8BCADETo6UXCg3GXHjUZ41NzJZ/oPr1FyrAXwK0q0jqHGyYxbVwSdVYZm0SCBp
djMNQBouIzVV9damLq0bQFXH9RwD42wO9UmEx9shZsIHAwxl85rN81Gh5Vih3CXJFibuvT2Y
NSqCKm1x+ECmb/8G75V9NZxXUyc8DWFb9rOzlbIN/dKdWt1NfD+MB8LPiVrp3KHyqiBPbkyI
9uALsH6LHn3c0wbHuOXE2KOiYawdOWZEfI0af12HibuQ+rLUxhMoSbdXz2c2bAXfoEUsMgC0
ajFI7BjdiVauZpZsJVDW4HcLoP/6Zk/BvqDvn9PcW7RQBSJvHDkrvDSBl36i10k5kgATABEB
AAG0PFJvZHJpZ28gVml2aSAoSW50ZWwgTGludXggR3JhcGhpY3MpIDxyb2RyaWdvLnZpdmlA
aW50ZWwuY29tPokBPgQTAQIAKAUCUS5ZbwIbAwUJCWYBgAYLCQgHAwIGFQgCCQoLBBYCAwEC
HgECF4AACgkQqQLdo3XlI2ZCvgf/cggOJuJfg5Do8cMjub6q50yvRgqOO7hcTuHjJuv8Obtx
6L6IACrpe4TP1rTQbshhEqGuBcg+yhxvTdzo1ecfjtMMXKsz4GSI2pRUS+kgFCHqqBzppmt6
CvONXNJzvzXueBrZULemYNN3HTHw6e2+ldHnhN4OJPYZVduesT6AKzHmKwXq5xgMhDfdwrIa
jegaPE3DbIMLLq6oIDjj0KVO8yv6w7T3uSwojBTHzwAAp/9DfmM4n+eg/Ks4uoF+/7o2ZXBM
XqGYErFcIYYlFXOaTT6ZHgx4z6lvYTqmbOM55jOxrkZG29WI+acl+IeDWuwE9Oaw2rcytZkf
Ki6J1Qil4rkBDQRRLllvAQgAx8qMycm1n2+ST0osqX/VQwNA+kbWqU+wHMHZTzuJbP5+NbjX
hsWSBp1o5Snuc/LoovHKLYLTNFRhftxNp4PncwSU9UALuJj61fomh23i3HRKwTiRceExmRQX
DTHaWMiViFLDupUv+ixT3x6LYzmswCCFzPE03TAqUGzRdUVy4niWtsRFJqCWfpMm67hg/yux
xFRpMF2ZENaeYc8Yp7L/RH69P9FLpbjUWm+kY/IECsqUqljIto0PH9IaVqQpMI9a6WZeHc3a
6BIsfrr9BpWTen6GbGolkgVS+1CD5OztLmIh43oL4n+WhecIMG9fDLY9C3iFmYQ9/8ZSTyo9
VIi4zQARAQABiQElBBgBAgAPBQJRLllvAhsMBQkJZgGAAAoJEKkC3aN15SNmrigH/0SX8XbZ
+T252I+WUpl2EJN/vNgzkvuCYnnfXdD/QTqnkVvTAhB4Yd21xsk8uXfxu8rVfDiCbxb+BLpg
TCzEFBQ41RLivuUYYTZcB7QkgYL9v9rmLJw1fw+qLmwsvS08Q8vuMtb8yzIcdLnW5JBkg28n
K647VYP2lqB85kW7fTeJ2FHGH5Rk59/sLHOIlZBbEoQTBbZWiXvK/Ap9NxtT2qhk3amaJB/Y
OM2aY2j7QqBi0lN39kwAkAikRT39cstiIFByJWC0Kj5UFQUUZbVMUooQWQnOaOVBYpgubIOy
xQTpv01Zp0ad1DkDTjCxSjgSK8mZgE+rziqYuFIoH7ewPpY=
=D2Wa
-----END PGP PUBLIC KEY BLOCK-----

YOu don't click the links, they are 2 commands. Just because your browser puts aa blue underline on a URL does not ALWAYS mean it is a link, in this case it is a file to download and install. OIf you copy and paste the 2 lines I gave and run them in the terminal it will work. Look with your mind, don't just see a blue hyperlink and click it without thinking or you will get this situation. Note the bit where I said "Also run:"

Too obvious?

Can you RUN the 2 commands in #7, then run (Not click the link):

wget https://download.01.org/gfx/ubuntu/13.10/main/pool/main/i/intel-linux-graphics-installer/intel-linux-graphics-installer_1.0.3_i386.deb; sudo dpkg -i ./intel-linux-graphics-installer_1.0.3_i386.deb

And it will install for you

pete (peterhall347) said : #10

i get
gpg: no valid OpenPGP data found. ...for both key adds

then run latest command and got
(Reading database ... 562959 files and directories currently installed.)
Preparing to replace intel-linux-graphics-installer 1.0.3 (using .../intel-linux-graphics-installer_1.0.3_i386.deb) ...
Unpacking replacement intel-linux-graphics-installer ...
Setting up intel-linux-graphics-installer (1.0.3) ...
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus ...
Processing triggers for mime-support ...

pete (peterhall347) said : #11

i get
gpg: no valid OpenPGP data found. ...for both key adds

then run latest command and got
(Reading database ... 562959 files and directories currently installed.)
Preparing to replace intel-linux-graphics-installer 1.0.3 (using .../intel-linux-graphics-installer_1.0.3_i386.deb) ...
Unpacking replacement intel-linux-graphics-installer ...
Setting up intel-linux-graphics-installer (1.0.3) ...
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus ...
Processing triggers for mime-support ...

ok, now is there an application in Dash to run the installer?

pete (peterhall347) said : #13

i can only find the application that i installed yesterday "intel graphics installer for linux"

it runs but doesn't seem to install anything

pete (peterhall347) said : #14

i run the installer then run system update then rebooted and run system test..same problem ..
graphics/driver_version FAILED ERROR: No video driver loaded! Possibly in failsafe mode!

Ubuntu is not Windows. Trying to install drivers that way (downloading from GPU manufacturer site) is not a good idea. I don't normally recommend reinstalls, but in your case, it may be the best thing to do a fresh install of 13.10

It seems you've tried to install a bunch of different intel/nvidia drivers, and unless you can tell people exactly what you've done, it's very difficult for them to help you undo it, especially when log files run contrary to the error messages you're giving...

pete (peterhall347) said : #16

i am fully aware linux isnt windows .that's why i run it instead of .
the system seems to be stable enough right now as it happens .
i was thinking a fresh install might be the best fix .
i think i will wait for the next lts version then do a back up and fresh install .
i did a fresh bug report but it was marked as a duplicate .the reason i did this was to save any confusion after i changed some things .

Can you help with this problem?

Provide an answer of your own, or ask pete for more information if necessary.

To post a message you must log in.