unity_support_test crashed

Asked by Alan German on 2013-06-26

In Ubuntu 12.04, an intermittent error pops up as “System Problem Detected”, but the system refuses to send an error report. The relevant parameters are:

Problem type: Crash

Title: unity_support_test crashed with SIGSEGV in xcb_glk_query_server_string_string_length()

The computer is equipped with a Radeon HD 6450 video card for which the FGLRX driver has been installed. This was necessary since, although a live-CD functioned correctly, once Ubuntu 12.04 was installed on the hard drive, the system failed to boot correctly into the GUI.

Occasionally, with the proprietary video driver, after booting, short horizontal dashed lines are displayed across the upper portion of the screen. A workaround to the latter issue seems to be to log out and log back into the system. It is not known if the dashed lines problem is related to the above-noted sytem problem.

Neither the system problem nor the dashed lines problem were present when using Ubuntu 10.04.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xorg Edit question
Assignee:
No assignee Edit question
Solved by:
Alan German
Solved:
2013-06-27
Last query:
2013-06-27
Last reply:
2013-06-27

Have you tried Unity 2D session. It is installed by default

Alan German (alan-german) said : #2

> Have you tried Unity 2D session. It is installed by default

I guess I didn't say that I don't use Unity at all. I have installed gnome-session-fallback and always run the Gnome Classic user interface

N1ck 7h0m4d4k15 (nicktux) said : #3

I suggest to report a bug about this. If you ask "How ?" because of apport refuses to send the report, there is an alternative option, always.

http://bugs.launchpad.net/ubuntu/+source/unity/+filebug?no-redirect

make the report, include as much informations you can collect manually.. some commands that might help listed below

    lspci -nnk | cat >> lspci.txt
    dmesg >> dmesg.txt
    cat /var/log/Xorg.0.log >> Xorg.log.txt

Upload all the txt files with your report and wait for the developers to get involved with you.

By the way.. is this your blog ? :P
http://linuxnorth.wordpress.com/2013/06/26/less-precise-than-ever/

Regards
 NikTh

Alan German (alan-german) said : #4

NikTh:

Thanks for the bug report suggestion; however, LinuxNorth (http://linuxnorth.wordpress.com) is indeed my blog and as you may have noted from the last 2-3 entries, I have been struggling with Ubuntu 12.04 and the Radeon HD 6450 for several weeks.

This is the first problem with Ubuntu that I have been unable to resolve - or at least work around in a reasonable manner. However, I think I now have a "fix". I have installed Linux Mint 13, a derivative of Precise which, for some strange reason, installs flawlessly, and runs my video card without any issues. Since Mint is really close to Ubuntu, and the Mate interface is even closer to the Gnome GUI (or can be so configured), I am going to give this system a whirl and see if it continues as it started out - i.e. no problems!

Given that I haven't experienced any issues over the past day, I am going to mark this thread solved.

A weird "solution" - given that it really is a non-Ununtu fix - but it's the best that I can do.

Alan

By any chance did you upgrade from 10.04 to 12.04 using the web upgrade tool?

Alan German (alan-german) said : #6

>By any chance did you upgrade from 10.04 to 12.04 using the web upgrade tool?

Andrew - I didn't upgrade. I always do clean installs of new versions - Alan