cannot set resolution of external monitor (TV) on laptop

Asked by peter smout on 2013-04-20

 Hi,

I have been trying without success to get my ubuntu precise (upgraded from oneric) to accept the same resolution on my tv as 10.04 (Lucid) did. (I still have lucid on a spare hdd so I can check settings).

The Problem:
TV (when connected via VGA (Out on laptop)- VGA (PC input)on TV)
On Lucid resolution was 1360 x 768 (16:9) 60hz. which worked perfectly well (with virtually zero input from me).
On Precise i get 1024 x 768 (6:9) 60hz. Which means that I have an ugly 2inch gap down the left of the screen, and the bottom couple of inches below the edge of the physical screen. (I hope this makes sense)

This confusing problem led me on a google-thon and I have got this far.

The Output from xandr in terminal with TV connected:

pete@petes-lappy:~$ xrandr

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192

LVDS1 connected (normal left inverted right x axis y axis)

   1280x800 60.0 +

   1024x768 60.0

   800x600 60.3 56.2

   640x480 59.9

VGA1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm

   1024x768 60.0*

   800x600 60.3 56.2

   848x480 60.0

   640x480 59.9

TV1 disconnected (normal left inverted right x axis y axis)

As you can see 1360 x 768 (or anything close is *not* an option) so I am left trying to devise a way of getting it!

i have run gtf in terminal and get the following:

pete@petes-lappy:~$ gtf 1360 768 60

  # 1360x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 84.72 MHz

  Modeline "1360x768_60.00" 84.72 1360 1424 1568 1776 768 769 772 795 -HSync +Vsync

Which gave me the idea of constructing a script to create the modeline (which if necessary I can run every time I plug the TV in)

The script I devised:

#This line adds modeline from output of gtf command

# 1368x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 85.86 MHz

xrandr --VGA1 "1368x768_60.00" 85.86 1368 1440 1584 1800 768 769 772 795 -HSync +Vsync

#This line adds the mode as it is not default

xrandr --addmode VGA1 1368x768_60

#This line sets resolution on VGA1

xrandr --output VGA1 --mode 1368x768_60

Returns the following error:

pete@petes-lappy:~$ /home/pete/Desktop/tv.bash

usage: xrandr [options]

  where options are:

  -display <display> or -d <display>

  -help

  -o <normal,inverted,left,right,0,1,2,3>

            or --orientation <normal,inverted,left,right,0,1,2,3>

  -q or --query

  -s <size>/<width>x<height> or --size <size>/<width>x<height>

  -r <rate> or --rate <rate> or --refresh <rate>

  -v or --version

  -x (reflect in x)

  -y (reflect in y)

  --screen <screen>

  --verbose

  --current

  --dryrun

  --nograb

  --prop or --properties

  --fb <width>x<height>

  --fbmm <width>x<height>

  --dpi <dpi>/<output>

  --output <output>

      --auto

      --mode <mode>

      --preferred

      --pos <x>x<y>

      --rate <rate> or --refresh <rate>

      --reflect normal,x,y,xy

      --rotate normal,inverted,left,right

      --left-of <output>

      --right-of <output>

      --above <output>

      --below <output>

      --same-as <output>

      --set <property> <value>

      --scale <x>x<y>

      --transform <a>,<b>,<c>,<d>,<e>,<f>,<g>,<h>,<i>

      --off

      --crtc <crtc>

      --panning <w>x<h>[+<x>+<y>[/<track:w>x<h>+<x>+<y>[/<border:l>/<t>/<r>/<b>]]]

      --gamma <r>:<g>:<b>

      --primary

  --noprimary

  --newmode <name> <clock MHz>

            <hdisp> <hsync-start> <hsync-end> <htotal>

            <vdisp> <vsync-start> <vsync-end> <vtotal>

            [+HSync] [-HSync] [+VSync] [-VSync]

  --rmmode <name>

  --addmode <output> <name>

  --delmode <output> <name>

xrandr: cannot find mode "1360x768_60"

xrandr: cannot find mode 1360x768_60

If any one can tell me where I am going wrong (or an easier way of going about it) please let me know!!

Regards

Pete Smout

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xorg Edit question
Assignee:
No assignee Edit question
Solved by:
peter smout
Solved:
2013-04-23
Last query:
2013-04-23
Last reply:
2013-04-21

Does the system have a make and model?

peter smout (psmouty) said : #2

Hi,
Yes sorry the laptop is a Acer Aspire 5720 with 3gb ram, tv is a Panasonic 26in LCD HD tv (sorry I do not have the model no. to hand).

The resolution I am trying to achive is based on Ubuntu Lucid so I know the TV supports that resolution.

Same TV same Laptop (different HDD)

peter smout (psmouty) said : #3

Hi,
TV is a Panasonic Viera TX-L26X10 26in LCD TV

peter smout (psmouty) said : #4

Hi,
as you can see from the attached table
https://dl.dropboxusercontent.com/u/80216532/10392-panasonicl26x10specs.gif got from http://www.trustedreviews.com/Panasonic-Viera-TX-L26X10-26in-LCD-TV_TV_review_feature-table_Page-4
The resolution 1366x768 is available in I assume that the 1360x768 was lucid adjusting itself to 'exact' fit

Note this is a feture that was no hassle, simply boot the machine with the TV attached once and it knew for ever more, WHY has this feature DOWNGRADED on the newer version?

I have looked in /etc/X11/ for an xorg.conf file and it does not exist, unlike in Lucid, this seems odd to me but perhaps it is not needed anymore? (copying xorg.conf from lucid into /etc/X11 had no effect at all...... oh well back to the script idea!

Regards Pete

What is the output of:

sudo lshw -C display; lsb_release -a; uname -a

Thanks

peter smout (psmouty) said : #6

Hi,
sorry for the delay,

as requested.

thanks

Pete

pete@petes-lappy:~$ sudo lshw -C display; lsb_release -a; uname -a
[sudo] password for pete:
  *-display:0
       description: VGA compatible controller
       product: Mobile GM965/GL960 Integrated Graphics Controller (primary)
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:45 memory:d4000000-d40fffff memory:c0000000-cfffffff ioport:5110(size=8)
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile GM965/GL960 Integrated Graphics Controller (secondary)
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: pm cap_list
       configuration: latency=0
       resources: memory:d8500000-d85fffff
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04.2 LTS
Release: 12.04
Codename: precise
Linux petes-lappy 3.2.0-41-generic #65-Ubuntu SMP Wed Apr 10 18:23:37 UTC 2013 i686 i686 i386 GNU/Linux
pete@petes-lappy:~$

peter smout (psmouty) said : #7

Hi,
SOLVED IT! Thanks go to: http://www.tolaris.com/2009/04/14/enabling-1080p-video-on-the-shuttle-x27d-htpc/
for pointing me in the right direction!

Thanks to all who read this question, for anyone following this thread with there own issue the solution is there (with work)

Regards

Pete

peter smout (psmouty) said : #8

Hi,
For anyone wishing to see an Example of the script I run when I plug my telly into my laptop please see https://dl.dropboxusercontent.com/u/80216532/TVBashScript

NOTE Intended as a guide not a solution other hardware configs will differ follow link in previous thread for how I got to this point

Regards

Pete