Display problems. Big graphics

Asked by Rich.b on 2013-01-16

Dell Dimension 2400 PC 1GB Ram
Running Ubuntu 12.04
Verto nVidia GeForce 6200 256MB DDR2 PCI DVI VGA TV-Out Graphics Card Video,
Linux Display Driver - x86
Version:285.0509
Release Date:Wed Oct 05, 2011
Operating System:Linux 32-bit
Language:English (UK)
File Size:32.04 M

I have this window on screen that said the following:- (If I got it wrote down correctly)

Could not apply the selected modes were compatible with the possible modes

CRTC 640 X 480 @Hz50 With output 1024 X 768 @50Hz (pass 0)
CRTC 320- X 240 @Hz50 With output 1024 X 768 @50Hz (pass 0)
CRTC 640 X 480 @Hz50 With output 1024 X 768 @50Hz (pass 1)
CRTC 320 X 240 @Hz50 With output 1024 X 768 @50Hz (pass 1)

Rebooted 2/3 times, still the same. Switch OFF every thing and restarted. Still the same.

Checked leads by pushing to wiggling.....this seam to cured the fault.

Please advise.

Could it be a problem with the graphics card connection to main broad?

thanks

Rich.b

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xorg Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2013-01-20
Last query:
2013-01-20
Last reply:
2013-01-20
N1ck 7h0m4d4k15 (nicktux) said : #1

Probably a problem with the nvidia-driver you have installed.

Try to remove it and install it again. Boot into Ubuntu normally , even in low graphics and open a terminal (CTRL+ALT+T) and I hope you can see to write the commands below

sudo apt-get purge nvidia-*
sudo rm /etc/X11/xorg.conf
sudo apt-get install nvidia-current
sudo nvidia-xonfig

Then reboot your system.

Thanks

Rich.b (aybi30) said : #3

You are still having a problem:
sudo apt-get purge nvidia-*
sudo rm /etc/X11/xorg.conf
sudo apt-get install nvidia-current

ALL above worked OK

sudo nvidia-xonfig <<<<< This did not

Can you help please?

Here is part of what was in terminal:-

DKMS: install completed.
Setting up nvidia-settings (295.33-0ubuntu1) ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.2.0-36-generic
richard@richard-desktop:~$ sudo nvidia-xonfig
sudo: nvidia-xonfig: command not found
richard@richard-desktop:~$

N1ck 7h0m4d4k15 (nicktux) said : #4

Yes , that was my bad.

The correct command is

sudo nvidia-xconfig

It will create a file that nvidia graphics driver needs , a file inside /etc/X11/ folder , called xorg.conf

Thanks

Rich.b (aybi30) said : #5

Please could tell me how to check graphics driver version that I have installed.

Thanks

What is the output of:

sudo dmidecode -t 1; sudo lshw -C display; lsb_release -a; uname -a; dpkg -l | grep nvidia

Thanks

Rich.b (aybi30) said : #7

richard@richard-desktop:~$ sudo dmidecode -t 1; sudo lshw -C display; lsb_release -a; uname -a;
[sudo] password for richard:
Sorry, try again.
[sudo] password for richard:
Sorry, try again.
[sudo] password for richard:
# dmidecode 2.11
SMBIOS 2.3 present.

Handle 0x0100, DMI type 1, 25 bytes
System Information
 Manufacturer: Dell Computer Corporation
 Product Name: Dimension 2400
 Version: Not Specified
 Serial Number: 8SMMX0J
 UUID: 44454C4C-5300-104D-804D-B8C04F58304A
 Wake-up Type: Power Switch

  *-display UNCLAIMED
       description: Display controller
       product: 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:d0000000-d7ffffff memory:feb80000-febfffff
  *-display
       description: VGA compatible controller
       product: NV44A [GeForce 6200]
       vendor: NVIDIA Corporation
       physical id: 4
       bus info: pci@0000:01:04.0
       version: a1
       width: 32 bits
       clock: 66MHz
       capabilities: pm vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=248 maxlatency=1 mingnt=5
       resources: irq:16 memory:fc000000-fcffffff memory:e0000000-efffffff memory:fd000000-fdffffff memory:fea00000-fea1ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux richard-desktop 3.2.0-36-generic #57-Ubuntu SMP Tue Jan 8 21:41:24 UTC 2013 i686 i686 i386 GNU/Linux
richard@richard-desktop:~$

Does the system have an onboard GPU?

Rich.b (aybi30) said : #9

It standard Dell 2400 Dimension + 1GB ram + Nvidia Graphic card.

N1ck 7h0m4d4k15 (nicktux) said : #10

Here it seems as you have dual card.. intel & Nvidia.

You must use bumblebee project to enable the dicreat card.. (nvidia)

If you want to see the version of driver then ..

dpkg -l | grep -i nvidia

and you will see, or give the output back here.

To install bumblebee see the instructions here
https://wiki.ubuntu.com/Bumblebee

Thanks

Rich.b (aybi30) said : #11

I have only one card fitted, are you saying that there is an intel GPU "on board" the main PCB?

Yes, if you can, disable it in BIOS

Rich.b (aybi30) said : #13

Not sure how to do this.

Would I Change "Primary Video Controller:- ONBOARD or AUTO ?

OR I am in the wrong area ?

Rich.b (aybi30) said : #14

First I type terminal:- sudo apt-get update

richard@richard-desktop:~$ sudo apt-get install bumblebee bumblebee-nvidia
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package bumblebee
E: Unable to locate package bumblebee-nvidia
richard@richard-desktop:~$

 ?

N1ck 7h0m4d4k15 (nicktux) said : #15

I think the correct option is AUTO. The ONBOARD graphics card should be Intel.

Have you added the repository correctly ? Check again the site..

Thanks

Rich.b (aybi30) said : #16

Well it seams that I have installed Bumblebee OK.

I have a number of problems:-

1/ VLC starts but is stuck at start and will not run, just the first frame is frozen.

2/ Can't remove VLC icon's from top of screen.

3/ The picture is less saturated colour.

4/ I can stream from the BBC web site OK

Any advise please.

Rich.b

N1ck 7h0m4d4k15 (nicktux) said : #17

Try

optirun vlc

and see if plays better , maybe vlc wants configuration ? See the settings..

If your graphics display is ok now , then your primary problem is solved..

VLC is one program and maybe it needs some configuration to work well. Try smplayer also. (is like VLC).

Thanks

Rich.b (aybi30) said : #18

Tried optirun vlc

and this what happened

richard@richard-desktop:~$ optirun vlc
[ 217.219670] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ 217.219770] [ERROR]Could not connect to bumblebee daemon - is it running?
richard@richard-desktop:~$

Rich.b (aybi30) said : #19

Works OK with SMPLAYER thanks.

How would I set up VLC to it work, just out interest ?

Rich.b

Best N1ck 7h0m4d4k15 (nicktux) said : #20

I don't know the settings of VLC , but is some settings , I'm sure. I use Smplayer so I recommended you this.

Search the settings of VLC , for GPU acceleration or something ..

If your primary problem solved, please mark the question as solved (by marking the answer that solved it).

Thanks

Rich.b (aybi30) said : #21

Thanks NikTh, that solved my question.