Post install Ubuntu Server : screen not readable

Asked by James McCall on 2013-01-12

Just installed Ubuntu Server 12.04.1 LTS (planning to make it a home digital assistant with Amahi).
The system has a really old PCI graphics card (VGA out) but as a headless server I don't need it other than to install.
The installation was perfectly visible but after reboot into the OS the screen is all white with traces of characters showing in black. Those I can make out appear to be mirrored.

I assume it is asking me for a user name and password and entering them blind I get a bunch of output. I figured I'd try entering the Amahi install "wget" command so I could use the browser management console from another PC but I guess it is prompting me for something.

Some potentially relevant points:
1. I have reinstalled a couple of times, seeing if I missed an option
2. Very early in the install there is a message about unrecognized graphics or video or something along those lines. It gives me about 16 different screen options, like 36x80 VGA, 40x60 BIOS (just throwing some numbers down here, all very small resolutions).
3. No matter what I choose in step 2 I get a perfectly acceptable character based GUI through the install process
4. Possibly unrelated: towards the end of the install it hangs at configuring English language base pack at 94% ... I got past this by unplugging the network cable just before it gets there and plugging it back in right after.
5. I previously had OpenMediaVault installed on this machine and was able to see the command line fine.

Is there any way to access this remotely? Per Amahi instructions I did not install anything but the default Ubuntu so I guess there is no Telnet or SSH or VNC running on it. I certainly wasn't able to access it using PuTTY.

Alternatively, any idea how I can make this thing use the graphics driver that it used during install?!

Thanks in advance.
James

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xorg Edit question
Assignee:
No assignee Edit question
Solved by:
James McCall
Solved:
2013-01-12
Last query:
2013-01-12
Last reply:
2013-01-12

Add the boot option:

nomodeset

You can then install openssh-server and get remote access

James McCall (jim-mccall) said : #2

Thanks for the input.
Once I read up about nomodeset I was convinced this would fix my problem.
It did not but while I was toying around with GRUB editor I wondered if starting in recovery mode then continuing normal boot without doing anything would have the same effect.
It did.