4:3 aspect ration on widescreen display

Asked by Red on 2007-12-23

I have a Viewsonic widescreen display (VA2012wb) which has a optimal resolution of 1680x1050. I have been moving it between two systems. One is a Powerspec with a Nvidia graphics adapter and the other a Dell with an ATI graphics adapter. The display works properly on either system when running Windows. But, when running Ubuntu, the display takes on what appears to be a 4:3 aspect ratio in the center with about an inch and a half wide black space down each side.

1) Works right with Windows XP and Windows Vista.
2) Fails when running Ubuntu 7.10, either the desktop edition (live) or the server edition (64bit AMD, installed).
3) Fails on two different computer manufactures and with two different graphic card manufactures.
4) No KVM is involved.

The Viewsonic's on-screen display states the following when running either Windows or Ubuntu:

  Horizontal Frequency 65.3 KHz
  Vertical Frequency 60.0 Hz
  Resolution 1680x1050

However, when running Windows, the Pixel Clock is 146.2 MHz while, when running Ubuntu, the Pixel Clock is 120.1.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xorg Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Olivier (olivier-lacroix) said :
#1

Hi !

please post here your /etc/X11/xorg.conf file.

Have you tried to hit the "auto button" of your screen once booted with ubuntu ?

Revision history for this message
Red (mabee) said :
#2

The Auto Image Adjust on the display has no affect.

My xorg.conf file is listed below:

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "us"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ImPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "stylus"
 Option "Device" "/dev/input/wacom"
 Option "Type" "stylus"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "eraser"
 Option "Device" "/dev/input/wacom"
 Option "Type" "eraser"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "cursor"
 Option "Device" "/dev/input/wacom"
 Option "Type" "cursor"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
 Identifier "ATI Technologies Inc ES1000"
 Driver "ati"
 BusID "PCI:1:8:0"
EndSection

Section "Monitor"
 Identifier "VA2012wSERIE"
 Option "DPMS"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Device "ATI Technologies Inc ES1000"
 Monitor "VA2012wSERIE"
 DefaultDepth 24
 SubSection "Display"
  Modes "1680x1680" "1680x1050" "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
 EndSubSection
EndSection

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "Default Screen"
 InputDevice "Generic Keyboard"
 InputDevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
EndSection

Revision history for this message
Olivier (olivier-lacroix) said :
#3

OK. enter in a terminal

sudo gedit /etc/X11/xorg.conf

and replace this line

Modes "1680x1680" "1680x1050" "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"

with
Modes "1680x1050"

and append every resolution you want. save, close. hit ctrl+alt+backspace

Tell me if it worked or not

Revision history for this message
Red (mabee) said :
#4

The change made no difference.

Revision history for this message
Olivier (olivier-lacroix) said :
#5

What is the output of the following command ?

sudo xrandr

Revision history for this message
Red (mabee) said :
#6

administrator@Ubuntu-Server:~$ sudo xrandr
Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 1680 x 1200
VGA-0 connected 1680x1050+0+0 (normal left inverted right) 433mm x 270mm
   1680x1050 60.0*+ 74.9
   1600x1200 75.0 59.9
   1400x1050 74.9 60.0
   1280x1024 75.0 59.9
   1280x960 59.9
   1152x864 75.0 74.8
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 75.0 72.8 66.7 60.0
   720x400 70.1
administrator@Ubuntu-Server:~$

Revision history for this message
Olivier (olivier-lacroix) said :
#7

From the xrandr output, the resolution is the right one, ie 1680x1050

I think your problem can be solved throught the screen OSD.

Revision history for this message
cue (keino) said :
#8

Hi,

I have a similar problem please help me.

My related hardware is:
Graphic Card: ATI Technologies Inc R480 [Radeon X850XT Platinum (PCIE)]
Display: DELL 2407WFP

My related xorg.conf sections:
----------------
Section "Device"
 Identifier "ATI Technologies Inc R480 [Radeon X850XT Platinum (PCIE)]"
 Driver "ati"
 BusID "PCI:1:0:0"
 Option "UseFBDev" "true"
EndSection
Section "Monitor"
 Identifier "DELL 2407WFP"
 Option "DPMS"
 HorizSync 30-81
 VertRefresh 56-60
EndSection
Section "Screen"
 Identifier "Default Screen"
 Device "ATI Technologies Inc R480 [Radeon X850XT Platinum (PCIE)]"
 Monitor "DELL 2407WFP"
 DefaultDepth 24
 SubSection "Display"
  Modes "1920x1200" "1600x1200" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
 EndSubSection
EndSection
-----------------

I do not load any modules in xorg.conf.

Console output:
sudo xrandr
Screen 0: minimum 320 x 200, current 1600 x 1200, maximum 1920 x 1200
VGA-0 connected 1600x1200+0+0 (normal left inverted right) 432mm x 324mm
   1600x1200 60.0*+ 59.9
   800x600 56.2
   640x480 60.0
S-video disconnected (normal left inverted right)
DVI-0 connected 1600x1200+0+0 (normal left inverted right) 519mm x 324mm
   1920x1200 60.0 +
   1600x1200 59.9*
   1680x1050 60.0
   1280x1024 75.0 59.9
   1152x864 74.8
   1024x768 75.1 60.0
   800x600 75.0 60.3
   640x480 75.0 60.0
   720x400 70.1

THE PROBLEM:
general:
I cannot select the monitors native resolution of 1920x1200. It simply is not selectable neither under System->Preferences->Screen Resolution nor under System->Administration->Screens and Graphics.

What I did so far:
- 1 I installed the restricted driver which went well according to the resolution but not according to 3D acceleration, 3D Desktop Effects and my intention to use free software only. The restricted driver has been removed after the attempt already.
- 2 I tried the following modification in the Section "Monitor" of xorg.conf:
------------
Section "Monitor"
 Identifier "DELL 2407WFP"
 Option "DPMS"
# HorizSync 30-81
# VertRefresh 56-60
# Modeline "1920x1200" 154.128 1920 1968 2000 2080 1200 1203 1209 1235 +hsync -vsync
 Modeline "1920x1200@60" 210.68 1920 1952 2752 2784 1200 1224 1236 1261 +hsync -vsync
EndSection
------------
Interesting here was, that as soon as I commented out the HorizSync and VertRefresh lines after adding one Modeline (and a ctrl-alt-backspace) under System->Administration->Screens and Graphics the Monitor name was mentioned correctly instead of "custom1" and a lot of additional resolutions were selectable.
Anyway, I selected the resolution 1920x1200 and hit the TEST button. The test went well and I confirmed. Back to the initial dialog I hit the OK button and my display went into sleep mode.
So I again used ctrl-alt-backspace to restart xorg server and was back to a login screen with resolution of 1600x1200.

I realy would appreciate having the current ati driver work with my desired native resolution.

Please if someone has an idea let me know.

I am very happy with the ubuntu distribution otherwise so thank you anyway!

Revision history for this message
Olivier (olivier-lacroix) said :
#9

From the xrandr output, you seem to be using 2 screens. Is that right ? are you sure your card can handle that many pixels ?

Revision history for this message
cue (keino) said :
#10

yes, I have a dual boot system and under XP it all runs fine!
I made an own issue also under:
https://answers.launchpad.net/ubuntu/+source/xorg/+question/25230

Please help when you can.

Can you help with this problem?

Provide an answer of your own, or ask Red for more information if necessary.

To post a message you must log in.