Ubuntu

Support for Lenovo A720: black screen after Grub2 menu?

Asked by Jorge Coelho on 2012-07-30

I just purchased a Lenovo A720 and I tried to install Ubunto 12.04 LTS from a CD ROM, and it didn't work.

The screen did not display anything beyond the initial grub message.

It seems that Ubuntu is not compatible with the display used in the all-in-one Lenovo A720 system.

Is this something that is on the development radar?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xorg Edit question
Assignee:
No assignee Edit question
Last query:
2012-07-30
Last reply:
2012-08-10

Seems to have a switchable video chip. I suggest you use the boot option:

nouveau.blacklist=1

You may find this helps:
https://help.ubuntu.com/community/HybridGraphics

I've never seen a success story with switchable video chips

Thomas (tom-rosary) said : #2

had the same problem with Ideacentre A720
1. If grub starts you can press "c" and edit the entry by adding "nomodeset"
then the system should start
 2.Afterwards I edited /etc/default/grub by adding "nomodeset" --> GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
and then "sudo update-grub"
3.I could start the system but I had to fill my /etc/apt/sources.list manually with the official sources, maybe my fault in the installation???
4.In the end I installed the nvidia-drivers from this source https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

I hope it's usefull for you

Looks like there is no good support and experience for the A720 Ideacentre right now :-(
I'm still not able to use WLAN (Broadcom 4313) and Bluetooth as well the touchscreen doesn't work.

Can you help with this problem?

Provide an answer of your own, or ask Jorge Coelho for more information if necessary.

To post a message you must log in.