Touch Screen Troubleshooting multiple xorg.conf files in the xorg Directory

Asked by openick on 2012-03-28

Hello

I am trying to follow the instuctions at page http://www.conan.de/touchscreen/evtouch.html#download but have two problems:

1. I can't find "/etc/X11/XF86Config-4" or "/etc/X11/xorg.conf". But a search for xorg.conf shows the following:

tv0user@ttv0:/etc/X11$ locate xorg.conf
/usr/share/X11/xorg.conf.d
/usr/share/X11/xorg.conf.d/10-evdev.conf
/usr/share/X11/xorg.conf.d/11-evdev-quirks.conf
/usr/share/X11/xorg.conf.d/11-evdev-trackpoint.conf
/usr/share/X11/xorg.conf.d/50-synaptics.conf
/usr/share/X11/xorg.conf.d/50-vmmouse.conf
/usr/share/X11/xorg.conf.d/50-wacom.conf
/usr/share/X11/xorg.conf.d/51-synaptics-quirks.conf
/usr/share/man/man5/xorg.conf.5.gz
tv0user@ttv0:/etc/X11$ cd /usr/share/X11

Which one of the above files is to be taken as xorg.conf for the purpose of configuring evtouch?

2. I have made a few attempts to make touch screen work, It works with a poor response, hangs, cursor is always visible, possibly by instructions from evdev.conf ? The file I have downloaded and extracted is /touchscreen/evtouch-0.8.8.tar.gz from conan.de Should I delete evdev.conf or key in an instruction to remove evdev.conf or keyin an instruction to uninstall evdev or remove the new file and reconfigure xorg.conf? This brings up Question 1 again.

Thank you

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xorg Edit question
Assignee:
No assignee Edit question
Last query:
2012-03-31
Last reply:
2013-03-26

There is no /etc/X11/xorg.conf by default but if you make one it will be used.

openick (openick) said : #2

Hello Andrew Woodhead,

Thank you for your attention and response.

I made one and on restart, the computer is confused :) The grub menu appeared, then the boot screen, after that nothing, it is black, I must have made a serious error.

I created /etc/X11/xorg.conf roughly as follows:

Section "InputDevice"
    Identifier "touchscreen"
    Driver "evtouch"
    Option "Device" "/dev/input/event1"
    Option "DeviceName" "touchscreen"
    Option "MinX" "98"
    Option "MinY" "43"
    Option "MaxX" "940"
    Option "MaxY" "925"
    Option "ReportingMode" "Raw"
    Option "Emulate3Buttons"
    Option "Emulate3Timeout" "50"
    Option "SendCoreEvents" "On"
     Identifier "dummy"
    Driver "void"
    Option "Device" "/dev/input/mice"
EndSection
Section "ServerLayout"
InputDevice "touchscreen" "CorePointer"
EndSection

The new problem has something to do with the way I organized the contents of the xorg.conf file, or due to the conflicts between an already present configuration files from among:

/usr/share/X11/xorg.conf.d
/usr/share/X11/xorg.conf.d/10-evdev.conf
/usr/share/X11/xorg.conf.d/11-evdev-quirks.conf
/usr/share/X11/xorg.conf.d/11-evdev-trackpoint.conf
/usr/share/X11/xorg.conf.d/50-synaptics.conf
/usr/share/X11/xorg.conf.d/50-vmmouse.conf
/usr/share/X11/xorg.conf.d/50-wacom.conf
/usr/share/X11/xorg.conf.d/51-synaptics-quirks.conf
/usr/share/man/man5/xorg.conf.5.gz

What should I do?

Thank you.

openick (openick) said : #4

Dear Sam,

Thank you. But the instructions on page http://www.viitalat.net/index.php/htpc/2010/07/15/lg-1730sf-on-ubuntu-10-04 are not clear, for example, it says "In addition to the MatchDevicePath directive you can put all the usual evtouch configuration here as well." What is the 'usual evtouch configuration' ?

The author gives the output of a log file beginning "(II) LoadModule: "evtouch", " and for the output of the log file to look like this log file, what should the xorg.conf file look like?

And the log file in the post also shows

"(II) Module evtouch: vendor="Kenan Esau"
        compiled for 1.7.6, module version = 0.8.8
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 7.0"

This would differ from comuputer to computer? And if so, how to I find the details and where do I say it?

Thank you for responding to my question.

openick (openick) said : #5

Dear Andrew Woodhead

Deleted the xorg.conf file that does created a login probelem and am back to the original state. Now I must find the right set of instructions for xorg.conf, after finding the version of the evtouch, vendor name etc, if required.

Thank you.

Ubfan (ubfan1) said : #6

Try starting with the xorg.conf that the X server generates.
Go to a virtual terminal (ctrl-alt-f2) login, kill the X server, and run
sudo X --configure
which should create an xorg.conf.new file for a starting point.
Restart the X server, (startx should do it?) or just reboot
sudo shutdown -r -t0 now
...

openick (openick) said : #7

Ubfan, thank you. I get the virtual terminal, but it does not take the login information both as user + password and as root + password. Also, how do I exit the virtual terminal?

What is the command to type to kill the X server please?

Thank you

Ubfan (ubfan1) said : #8

The username/password is the same as you use to log in normally (cannot log
into root anyway).
Exit the virtual terminal with alt-F7 (no control key needed on the exit).
Find the X server process with the command:
ps auxw
and look for the line containing /usr/bin/X,
the first number on that line is the PID (xxx below) which you politely
suggest it die with
sudo kill xxx
If that does not kill it (check with ps again), then blast it with
sudo kill -9 xxx

openick (openick) said : #9

Dear Ubfan

Found the process number and on the virutal terminal killed the process, the x server automatically restarted to the Ubuntu desktop login window, moved back to the virtual terminal and on "sudo X --configure" the following error is persistent

Fatal Server error
Unrecognized option: --configure

Pleaseconsutl wiki.x.org

ddxSigGiveUp: Closing log

openick (openick) said : #10

In addition to the steps in #9 tried "sudo X -configure" with a single hyphen instead of a double hyphen, and the visible part of the screen shows a list of video drivers, and then shows the following errors:

(EE) Failed to load module "vmwgfx" (module does not exist, 0)
EE vmware: Please ignore the above warnings about not being able to to load module/driver vmwgfx
(++) Using config file: /home/tuser/xorg.conf.new
(++) Using system config directory "/usr/share/X11/xorg.conf.d"
Number of created screens does not match number of detected devices
Configuration failed
ddxSigGiveUp: Closing log

Ubfan (ubfan1) said : #11

Sorry, the command was Xorg, here's a cut and paste so no more bad memory
on my part:
In a virtual terminal,

user@ubuntu ~# sudo service gdm stop

This command will stop the X.

Now we need to generate the xorg.conf file:

user@ubuntu ~# sudo Xorg -configure

This has generated the file in ~/xorg.conf.new.

We need to make the X using it so we have to put this file inside /etc/X11/

user@ubuntu ~# sudo mv ~/xorg.conf.new /etc/X11/xorg.conf

After moving this file to the proper location you can start the X again and
see what happens:

user@ubuntu ~# sudo service gdm start

But there was a caution that this does not work on some platforms. google
xorg.conf generate ubuntu and look at first link for more info

openick (openick) said : #12

Dear Ubfan

Thank you for your reply again.

gdm: unrecognized service

So, I identified process number and stopped Xorg with sudo kill -9 xxx

sudo Xorg -configure returned the same errors as in #10

(This is possibly because sudo kill -9 xxx automatically brought up the Desktop login screen and I switched back to the virtual terminal to issue the "sudo Xorg -configure" The log in screen in the background - does that amount to the Xorg process already restarted ? Is this the reason why the configuration failed?")

I looked at the first file on a google search for xorg.conf generate ubuntu as you suggested which did not give more information, and it was meant for release 9.10.

In the thread http://ubuntuforums.org/showthread.php?t=1878412 I found a solution to the unrecognized gdm command. In 11.10, another command works "sudo service lightdm stop". I tried it, it worked, the login screen automatically did not appear, but "sudo Xorg -configure" returned the same errors as in #10

I have taken the output of the log file and hwinfo and xrandr -q output at

http://paste.ubuntu.com/907781/

Thank you.

Ubfan (ubfan1) said : #13

Looks like the xorg.conf.new file was written to your home directory, see line in #10
(++) Using config file: /home/tuser/xorg.conf.new

I did this myself and found the same claim of failure, but the file was written to my home directory, even though I had a current work dir of /tmp.
My file looked like overkill though.
Here's a little xorg.conf for a touchscreen device that may be helpful to you, it uses another touchscreen device/library which you may replace with your touchscreen info. This xorg.conf file works under Debian.

Section "Device"
    Identifier "Chumby Video Device"
    Driver "fbdev"
    Option "UseFBDev" "true"
    #Option "ShadowFB" "off"
    #Option "fbdev" "/dev/fb0"
EndSection

Section "InputDevice"
         Identifier "Touchscreen"
         Driver "tslib"
         Option "Width" "800"
         Option "Height" "600"
         Option "CorePointer" "true"
         Option "SendCoreEvents" "true"
         #Option "TslibDevice" "/dev/input/event0"
         #Option "Device" "/dev/input/event2"
         # use the by-id since the device changes depending upon what's present
         Option "Device" "/dev/input/by-id/soc-noserial-event-ts"
         Option "Protocol" "Auto"
         #Option "EmulateRightButton" "1"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
        Option "Device" "/dev/tty0"
 Option "XkbRules" "xorg"
# Option "XkbModel" "pc104"
 Option "XkbLayout" "us"
EndSection

Section "ServerLayout"
        Identifier "Base layout"
        Screen "Chumby Screen"
        InputDevice "Touchscreen"
        InputDevice "Generic Keyboard"
EndSection

Section "ServerFlags"
        Option "BlankTime" "0"
        Option "StandbyTime" "0"
        Option "SuspendTime" "0"
        Option "OffTime" "0"
         Option "AutoAddDevices" "false"
EndSection

Section "Monitor"
        Identifier "Chumby Monitor"
# Option "DPMS"
EndSection

Section "Screen"
        Identifier "Chumby Screen"
        Device "Chumby Video Device"
        Monitor "Chumby Monitor"
EndSection

openick (openick) said : #14

Dear Ubfan

Thank you for going though the lengthy log files and for the configuration. This should solve my problem if I do it right.

1. I need to identify the touch screen, so I got the xinput list as follows:

⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Hanvon 10.1 id=9 [slave pointer (2)]
⎜ ↳ Logitech USB Optical Mouse id=12 [slave pointer (2)]
⎜ ↳ HID 04f3:0103 id=10 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=13 [slave keyboard (3)]
    ↳ HID 04f3:0103 id=11 [slave keyboard (3)]

1. Hanvon 10.1 id=9 and / or HID 04f3:0103 are probably the entries that denote touch screen, but which one?
2. You also said something about using another device/library, I am not sure how to find the information and what to do.
3. Should I leave the xorg.conf.new at /home/tuser and leave the name unchanged?

(and a search for Hanvon 10.1 leads to a page with interesting information http://ubuntuforums.org/showthread.php?t=1697947 and http://ollie-reardon.co.cc/?p=182 which gives the download instructions for the drivers from git. Should I download these drivers and specify the drivers as enac drivers (as named in these documents)? )

Thank you.

Ubfan (ubfan1) said : #15

The tslib files are directly available through the Ubuntu package manager. Not sure they are your best bet though.
Google for a setup like yours and see what they did. That will at least give you a good starting point, sometimes you only find a set up for an earlier release, and things need some slight changes (Like the tsLibDevice needed to be changed to Device in what I found to start my Debian setup).
You seem to have 3 devices, /dev/input/event4, ...event5, and ...event6 for the touchscreen. No idea which to use or what they are for.
I would have thought that leaving the xorg.conf.new in your home directory, edit it, and copy to the /etc/X11/xorg.conf file would be a way to test things out, since you don't have a working xorg.conf anyway, but from your posted logs, it looks like the xorg.conf.new got picked up anyway, and if you didn't explicitly use it as the conf file when you started X, then I guess it's picked up where it is -- which I find strange.

openick (openick) said : #16

Dear Ubfan,

Thank you again.

1. Installed tslib files. I now have libts-bin, libts-dev, xserver-xorg-input-tslib, tsconf, libts and libts-debug.

2. I don't have any clue about events 1 - 6, so have done nothing.

3. created /etc/X11/xorg.conf as seen at the pastepin http://paste.ubuntu.com/909245/

4. Also cloned git://git.lii-enac.fr/linux-input/ubuntu-multitouch.git and git://git.lii-enac.fr/linux-input/drivers.git in a directory named hanvon (probable name of the touch screen, but did not make and make install due to errors, so this action does not have any effect.

5. Now trying the xserver kill and restart sequence that you have outlined earlier.

Thank you.

openick (openick) said : #17

adding to #16

6. moved to a virtual terminal, idssued commands "sudo lightdm stop", SKIPPED sudo xorg -configure, as I thought it would create a new xorg.conf file in place of the file created with the edits as shown in http://paste.ubuntu.com/909245/, sudo lightdm start started the process, but did not have the desktop, shutdown and restarted, nothing happens except a black screen after choosing the version from grub menu

7. the xorg.conf.new file at home/tv0user directory is left unchanged in the same place.

Is there a conflict between the two files, or is it something that has to do with the xorg.conf contents at /etc/X11 ? I notice that there are three screens screen 0, 1, and 2. (This is a tablet pc is one screen) ; Also in the xorg.conf module section I added

Load "intel_drv"
Load "evtouch_drv"

This I did on my own, though none of the help files I have seen suggested this.

I didn't use the xorg.conf contents that you have suggested because I didn't know how to change device identifier, device driver and monitor identifier.

Don't know what to do.

Paula Doird (paula-diord) said : #18

We are talking about touchscreen?
Dont we use touchscreens most often to avoid keyboards?
Using a virtual touchscreen keyboard?

Why then shoudl we go to a virtual terminal?????
In virtual terminal there is neither touch nor touch-keyboard!!!

The use of Xorg -configure only works in virtual terminal!!??

So this way of solving this problem is a little bit unreal.

Can you help with this problem?

Provide an answer of your own, or ask openick for more information if necessary.

To post a message you must log in.