If a full-screen game crashes there is no way to recover.

Asked by Timmmm on 2011-12-15

This is a MAJOR MAJOR usability bug that has existed in Linux for as long as I remember, however Ubuntu has some settings that make it worse.

If a full-screen game freezes but remains running, there is absolutely no way to kill it and return to your desktop. The only way out is a hard reset!

This problem is caused by the fact that unlike windows, X11 doesn't treat alt-tab, (or ctrl-alt-del) as special keys, so if the game freezes you cannot alt-tab away from it. Even worse, ubuntu has disabled ctrl-alt-backspace so you can't simply kill X and start again. Finally, for me ctrl-alt-F1 et al do not work due to an unrelated bug with (I believe) plymouth.

The fix is clear: change X11 so that it treats alt-tab like it treats ctrl-alt-f1 (or alternatively create a proper ctrl-alt-delete thingy).

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xorg Edit question
Assignee:
No assignee Edit question
Last query:
2011-12-15
Last reply:
2011-12-16
Fabio Marconi (fabiomarconi) said : #1

System settings -> keyboard -> shortcuts -> windows -> fullscreen
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Timmmm (tdhutt) said : #2

I will try it, but I highly doubt that will work, because the game takes almost full control of the keyboard. Only very special keys get through (ctrl-alt-something generally).

Those shortcuts are intercepted too late in X's input processing pipeline to be activated. For example I tried both Alt-F4 and Ctrl-Alt-Del, neither of which had any effect.

delance (olivier-delance) said : #3

"ubuntu has disabled ctrl-alt-backspace" : I read somewhere you can reactivate this option, and find it! Keyboard preferneces->Options->Kill X server.
Else you can use Ctrl+Alt+F1 to get a console, login and kill game process, which will release the screen. Use Ctrl+Alt+F7 to return to X11 session.
For what I know, game on Linux can't get full control of keyboard.
You have to forget Windows shortcuts and learn X11 ones.

Timmmm (tdhutt) said : #4

"I read somewhere you can reactivate this option, and find it! Keyboard preferneces->Options->Kill X server."

All the same, killing the X server is a rubbish solution -- what if I have some unsaved work open?

"Else you can use Ctrl+Alt+F1 to get a console, login and kill game process,"

Better, but still a poor solution. And I can't do this, since the console video mode doesn't work for me (some bug in plymouth/nvidia drivers).

"For what I know, game on Linux can't get full control of keyboard.
You have to forget Windows shortcuts and learn X11 ones."

Linux games can get more exclusive control than windows ones -- so much control that there are no *GUI* shortcuts which aren't blocked by games. (By "gui shortcuts" I mean ones that don't kill/leave X.)

This should be fixed properly. It's hard to take linux really seriously otherwise. However I seriously doubt anyone will fix it in X, simply because so few people even understand that code... Hopefully wayland won't make the same mistakes as X did, but I'm not holding my breath!

Can you help with this problem?

Provide an answer of your own, or ask Timmmm for more information if necessary.

To post a message you must log in.