best way to access ubuntu (X) from windows

Asked by ZioNemo on 2010-10-05

I need a working x-server for win (vista+win7) to access my ubuntu machines.
The machines have sshd (OpenSSH) installed and working (I can access each server from the others and I can launch X programs over the tunnel).

I have PuTTY installed on the win (vista) machine and I can access the servers in terminal mode.
I also installed certificates so I do not need passwords.

So far so good.

I tried Xming and VcXsrv, but I cannot connect to the servers.
The server starts, some time passes and finally a box appears stating I cannot connect to server.
No further explanation.
I tried following the instructions (for XMing, I didn't find any documentation for VcXsrv!)), but obviously I'm doing something wrong and I cannot understand what.

Can some kind soul point me to a *sure* and *verified* procedure to display a nice xterm on a win machine?

Thanks a lot in advance
ZioNemo

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xorg Edit question
Assignee:
No assignee Edit question
Solved by:
ZioNemo
Solved:
2010-10-13
Last query:
2010-10-13
Last reply:
2010-10-05

There is no "Best way" to achieve anything, there are options but none are "best"

http://www.math.umn.edu/systems_guide/putty_xwin32.html

Shows how to configure putty to use x forwarding. If you put the putty.exe in %WINDIR% then you can run it from the run box very easily. You must have xming running (xming requires zero config, just have it in the tray). You can then connect with:

putty -X user@server

once you authenticate you can run commands like:

gedit &

and such, note the ampersand, this is to give you control of the terminal after the gui app has executed. I use x forwarding to run spotify so the sound comes out of the server but is controllable on my laptop. Its sweet :)

ZioNemo (zionemo) said : #2

Thanks for Your answer.
Unfortunately this does not seem to work for me :(

I start xming.
Connect via PuTTY
Verify X redirection is on (echo $DISPLAY -> localhost:10.0)
Start xterm

... and nothing happens!
ssh console does not return to prompt (so xterm is running somehow), but no window pops up anywhere.
If I go to the server i can see:

27674 pts/12 Ss 0:00 -bash
27697 pts/12 S+ 0:00 xterm

xterm was started, but I can't see it and I find *NO* trace of errors in the logs (neither server-side nor client-side).

What should I check?
Regards
ZioNemo

ZioNemo (zionemo) said : #3

After a few reboots the thing magically works ...
Sorry for the time lost.