ubuntu not starting after screen resolution change

Asked by spiepie on 2010-08-04

Hi aaaaaaaghhhhhhhhhhh
Bought a new system , loaded Lynx but had a problem with the screen resolution
so changed a file recommended by forum to get 1440x900 resolution

restarted pc but it now hangs at the ubuntu sign on boot.

can any one help please
I am spending many hours trying to resolve this monitor issue monitor unknown.



Question information

English Edit question
Ubuntu xorg Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
François Tissandier (baloo) said : #1

You mean that you log in, then it comes back to this screen and never show your desktop ?
Which file did you change ?

spiepie (spiepie) said : #2

When I restart the pc ubuntu begins loading but hangs at the Ubuntu sign

the file I changed?! i added mode 1440x900 to ............. file oops did not write it down and cant check as cant get back in:)

live and learn

spiepie (spiepie) said : #3

Thanks for the response is there any way I can get back into ubuntu without having to reinstall?

spiepie (spiepie) said : #4

I think it was the
xorg.cof file I added mode 144x900 as suggested on forum

can anyone help my new system is going out of the window soon!!!!!!!!!!

yours desperately!!


François Tissandier (baloo) said : #5

First thing is to get you back in. To edit the xorg.conf file is always dangerous.

Start the computer, wait until the login screen.
Press CTRL +ALT + F1, you should get a terminal in fullscreen.
Enter your login, password

type "sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.broken" + enter
it will ask for your password, enter it.

It will make a copy of this xorg.conf file and delete it.

type "sudo reboot now" (to reboot the computer), and pray ;)

That will probably not give you the right resolution, but at least, you should get in.

spiepie (spiepie) said : #6

Hi thanks for your time with my problem
The boot is not reaching the login screen just Ubuntu brandname screen maybe 5 seconds and freezes.

tried ctr alt f1 no luck!
 any other ideas?

François Tissandier (baloo) said : #7

You have to use the recovery mode then. Boot the computer, press 'ESC' when you see the screen with the two icons at the bottom. It should give you a menu, select the option with "recovery" in its name (I think it's recovery... not 100% sure).

It will start Ubuntu in a terminal. Then you can type my commands.

spiepie (spiepie) said : #8

Hi thanks

I have tried this for some reason the escape key does nothing?

spiepie (spiepie) said : #9


i mamged to change the xorg.conf file using live cd

mount the drive
terminal sudo gedit
then the system files can be changed

so all is well back to the begining of the problem widescreen monitor resolution

must try to find out why the escape key did not take me into recovery mode?

thanks again for your time

François Tissandier (baloo) said : #10

For your screen problem: which graphical card do you have? Did you install a driver for it ?

For the escape key, i'm not 100% sure if it's escape, maybe it's another one?
I found this: "If you have Grub 2 set to boot without displaying the menu at all, hold the SHIFT key down until the menu displays. (In Grub it was the ESC key.)"

Worth a try...

Or maybe you didn't press it at the right moment? Or maybe you have a USB keyboard and it's not ready yet when the icons are displayed?

spiepie (spiepie) said : #11

I was thinking that it may be due to my USB wireless keyboard!!

I have learnt a lot over the last 48 hours Thanks for your help!

I came across an excellent driver resource called ATi catalyst control centre which works brilliantly, I now have 2 shiney new LCD monitors beaming out at me.

thanks again