Why Google Earth doesn't work in Ubuntu Intrepid Ibex

Asked by Sergio Rubio

Launching google earth, weird artifacts appear on screen with some graphic cards (I've tested this with Intel X3100/GM965)

Question information

English Edit question
Ubuntu xorg-server Edit question
No assignee Edit question
Solved by:
Sergio Rubio
Last query:
Last reply:
Revision history for this message
Sergio Rubio (rubiojr) said :

Try to disable "Visual Effects" (system->preferences->appearance).

Revision history for this message
David Pearce (halzia) said :

This bug seems to be linked to older Intel graphics. I get it with a 82852/82855 GM/GME/PM/GMV
Visual effects are turned off.
On my machine many characters are missing, notably "a", "l" and digits

Revision history for this message
gccradioscience (gccradioscience) said :

Does not work with Ubuntu 9.10. It starts up and then closes out on me.