Tildes: pressing "~" then "a" results in "~a" and not "ã", as it should

Asked by Alberto R Mitre on 2011-11-08

The summary says it all... I have a problem with that key. I can get other combinations properly, like: á, à, ä, â... but pressing the combination "Alt gr + 4", writes the tilde "~" all of a sudden. It should wait for another input ("a", for example), and then prompt the result: "ã". Luckily my spanish keyboard has the character ñÑ on it... I guess our portuguese neighbours have the correspondant keys as well, else I don't understand how this error hasn't been reported yet!

The combination doesn't work as expected everywhere: nautilus, firefox, openoffice, unity, etc...

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xkeyboard-config Edit question
Assignee:
No assignee Edit question
Solved by:
delance
Solved:
2011-11-09
Last query:
2011-11-09
Last reply:
2011-11-09
Fabio Marconi (fabiomarconi) said : #1

Answered
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Best delance (olivier-delance) said : #3

Hola!
You have to open Keyboard Preferences and replace "Spanish" keyboard by "Spanish keyboard (including dead key tilda)".
At right top of my screen (but I don't know if it's an old configuration, and so you have also), I have an icon screen on which you can select such properties.

Alberto R Mitre (armitre) said : #4

Wow, that did solve it! It was my mistake, assuming it was a bug in the keyboard layout. I thought the use of tilde as a dead key was a default, but it looks like it wasn't.

Thank you very much, merci beacoup delance!

Alberto R Mitre (armitre) said : #5

Thanks delance, that solved my question.