what is the xfs port name

Asked by David Tilbrook on 2012-06-10

Ixhowfont -server argument appears to be a mystery.

I have started xfs and /tmp/.font-unix has been created and contains fs7100.

Yet my attempts to run:

       showfont -server tcp/<host>;7100

fails.

How do I determine the correct server name?

Why does sockstat not show a port of 7100?

xfs is running, but lsof shows 3 sockets for xfs, but none are 7100.

-- david

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xfs Edit question
Assignee:
No assignee Edit question
Solved by:
David Tilbrook
Solved:
2012-06-11
Last query:
2012-06-11
Last reply:
2012-06-10

on the server you can run:

netstat -a | grep xfs

May help

You could even use nmap to scan the server for open/listening ports

David Tilbrook (dmtilbrook) said : #3

I already tried netstat, sockstat, and lsof, none of which displayed a socket 7100.

Now I have tried using nmap, but to no avail.

There is no port 1700 in evicence anywhere.

Furthermore, xfs and showfont have the same behaviour on ubuntu, freebsd, and readhat.

What am I missing? Does anyone out there got a working showfont?

-- david

David Tilbrook (dmtilbrook) said : #4

I solved it.

I changed /etc/init.d/xfs

126c126
< start-stop-daemon --start --quiet $SSD_START_ARGS -- -daemon -user debian-xfs -droppriv \
---
> start-stop-daemon --start --quiet $SSD_START_ARGS -- -daemon -user debian-xfs \

i.e., remove -droppriv

Then when xfs restarted, port 7100 exists and

     xfont -server tcp/<host>:7100 -fn <font>

works, but not the way I expected.

I remember, from the distant past, a program that displayed the font
as an array of the characters and their arrtibutes, not:

char #0 0x0000
Left: 0 Right: 6 Ascent: 9 Descent: 0 Width: 7
#-#-##
------
#----#
------
#----#
------
#----#
------
##-#-#

Does anyone out there remember what that program might have been?

-- david

David Tilbrook (dmtilbrook) said : #5

Found it. Its xfd and was there all the time.