TAB key not functional in XFCE4.8

Asked by indium on 2012-08-18

Attached below the output of 'xev' when I use the TAB key in two different windowmanagers: fluxbox works like it should, but XFCE4.8 (standard of ubuntu 12.04) translates it to 'Focus In, Focus Out' (resp. pressing the button and releasing it).

How does XFCE change the key in such a manner that even 'xev' doesn't recognise TAB anymore?

FLUXBOX:
KeyPress event, serial 31, synthetic NO, window 0x2e00001,
    root 0x15d, subw 0x0, time 155561853, (45,-15), root:(768,31),
    state 0x0, keycode 23 (keysym 0xff09, Tab), same_screen YES,
    XLookupString gives 1 bytes: (09) " "
    XmbLookupString gives 1 bytes: (09) " "
    XFilterEvent returns: False

KeyRelease event, serial 31, synthetic NO, window 0x2e00001,
    root 0x15d, subw 0x0, time 155561957, (45,-15), root:(768,31),
    state 0x0, keycode 23 (keysym 0xff09, Tab), same_screen YES,
    XLookupString gives 1 bytes: (09) " "
    XFilterEvent returns: False

XFCE4.8:
FocusOut event, serial 34, synthetic NO, window 0x3800001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 34, synthetic NO, window 0x3800001,
    mode NotifyUngrab, detail NotifyAncestor

I have set the keyboard layouts the same:
[@laptop:~]$ setxkbmap -query
  rules: evdev
  model: pc105
  layout: us

Can someone tell me how this could occur and possibly how to solve it?

thanks!

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu xfce4 Edit question
Assignee:
No assignee Edit question
Last query:
2012-10-27
Last reply:
2012-11-11

Can you give the output of:

lsb_release -a; apt-cache policy xfce4

 Thanks

indium (indium) said : #2

On Sat, Aug 18, 2012 at 06:45:40PM -0000, actionparsnip wrote:
> Your question #206191 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/206191
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> Can you give the output of:
>
> lsb_release -a; apt-cache policy xfce4
>
> Thanks
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+question/206191
>
> You received this question notification because you asked the question.

thank you for your help (in advance)!
I have installed ubuntu on a macbookpro 6,2 (if that matters).

[@laptop:~]$ lsb_release -a; apt-cache policy xfce4
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
xfce4:
  Installed: 4.8.0.3
  Candidate: 4.8.0.3
  Version table:
 *** 4.8.0.3 0
        100 /var/lib/dpkg/status
[@laptop:~]$

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

goofrider (goofrider) said : #4

In case OP still looking for a fix:

http://ubuntuforums.org/showthread.php?p=11107297
http://lunatic-engineer.blogspot.hk/2012/03/xfce-tab-and-auto-complete-terminal-via.html
http://blog.zerosum42.com/2011/10/tech-fixing-tab-key-in-vnc.html
http://madras.ncl.ac.uk/wordpress/?p=90

In short, you can either edit:

~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml

find the line

<property name="&lt;Super&gt;Tab" type="string" value="switch_window_key"/>

and change it to

<property name="&lt;Super&gt;Tab" type="empty"/>

Or go to "Settings->Window Manager", in the "Keyboard" tab, clear the binding of "Switch wndow for same application -> <Super> Tab"

indium (indium) said : #5

thanks! I will try that.

On Tue, Oct 23, 2012 at 06:11:15PM -0000, goofrider wrote:
> Your question #206191 on xfce4 in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/xfce4/+question/206191
>
> goofrider posted a new comment:
> In case OP still looking for a fix:
>
>
> http://ubuntuforums.org/showthread.php?p=11107297
> http://lunatic-engineer.blogspot.hk/2012/03/xfce-tab-and-auto-complete-terminal-via.html
> http://blog.zerosum42.com/2011/10/tech-fixing-tab-key-in-vnc.html
> http://madras.ncl.ac.uk/wordpress/?p=90
>
> In short, you can either edit:
>
> ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
>
> find the line
>
> <property name="&lt;Super&gt;Tab" type="string"
> value="switch_window_key"/>
>
> and change it to
>
> <property name="&lt;Super&gt;Tab" type="empty"/>
>
> Or go to "Settings->Window Manager", in the "Keyboard" tab, clear the
> binding of "Switch wndow for same application -> <Super> Tab"
>
> --
> You received this question notification because you asked the question.

Launchpad Janitor (janitor) said : #6

This question was expired because it remained in the 'Open' state without activity for the last 15 days.