Unable to launch xfce4 desktop

Asked by Lorenzo

I am currently running ubuntu's 14.04 and recently installed the xfce4 desktop by way of apt-get. All went well, however, I am unable to launch. At least based on the various instructions I have searched out. Which are as follows: First I
tried a restart after the install; secondly, clicking on the gear icon on the desktop to see if (xfce4) was there. Next
a log-out to see if I could log into it. I also searched the Dash. Finally, I went to the terminal and ran ‘startxfce4' and
got the following: lorenzo@lorenzo-Latitude-D630:~$ 'startxfce4'
/usr/bin/startxfce4: X server already running on display :0
xfce4-session: Another session manager is already running
Next I installed Dconf with the expectation of reaching and configuring the currently running session manager....no such provisions available. Granted, I am a newbie, but this should be simple...right? At any rate,
I am at a lost for a solution. Could someone please help me.

Question information

English Edit question
Ubuntu xfce4-settings Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
Taras Chernenko (soft-dert38) said :

you tried ctrl+alt+f7?
If X server is already running it coult switch on it

Revision history for this message
actionparsnip (andrew-woodhead666) said :

You need to log off then log in to the XFCE session. You don't run XFCE as you do with gedit.

Revision history for this message
Lorenzo (lojay397) said :

Tried suggestion (ctrl+alt+f7)...no success. As for (log off/log in). When I do log out there is no provisions that I can find, at least, on the log out screen to log in to the xfce4 desktop. Am I suppose to do something special to bring up the xfce4 log-in?

Revision history for this message
actionparsnip (andrew-woodhead666) said :

You can select the session on the login screen. You choose session then login.

Revision history for this message
Daniel Letzeisen (dtl131) said :

You do have xfce4-session package installed, correct?

Revision history for this message
Lorenzo (lojay397) said :

Went to software center and it said (meta-package for the xfce4 light weight desktop was installed as well as all the opt add-ons. Also about xfce4 is installed as well) From this I am assuming the session package is also installed. When I log-out, the only thing on my log-in screen is lorenzo/the password field; then , guest session followed by remote log-in. Under the gear icon there is suspend and shut down. Do you think something may have happened in the initial install that is preventing the usual log in.

Revision history for this message
Best Manfred Hampl (m-hampl) said :

On the login screen you should see an icon besides your name to open a selection box for the different desktop environments to choose from. http://linuxlookup.com/files/imagecache/800x600/ubuntu_11.10_login.png

Revision history for this message
Lorenzo (lojay397) said :

At first attempt with clicking on the icon, nothing happens... so I open and closed Remote. Click back on icon... All is well.

Thanks to all of you.

Revision history for this message
Lorenzo (lojay397) said :

Thanks Manfred Hampl, that solved my question.

Revision history for this message
Begueradj (beg-bill) said :

I had the same problem with the same error message; and I solved it by running this command:

sudo apt-get install xfce4

Hope this will be helpful for others in the future.

Begueradj .