compiz wont start by default on xubuntu startup

Asked by FritoBandito on 2008-03-08

Binary package hint: xorg

I am using Xubuntu 7.10 and I cannot make compiz start by default on startup of Xfce if I used saved sessions

I have replaced these lines in /etc/xdg/xfce4-session/xfce4-session.rc

Client0_Command=xfwm4
with:
Client0_Command=compiz

If i go to ~/.cache/. and delete the sessions folder then compiz will boot the next time I start Xubuntu but the next time I log out and back in compiz will not start.

I have an ATI radeon card which needs xserver-xgl to run compiz

Verson of compiz Compiz-core 1:0.6.2+git20071119-ubuntu1~gutsy1
I did not download compiz as it brings lots of gnome libraries with it so i got compiz-core and the fusion plugins

I would be glad to provide any more information

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xfce4-session Edit question
Assignee:
No assignee Edit question
Last query:
2008-03-08
Last reply:
2008-07-16
Timo Aaltonen (tjaalton) said : #1

guessing the package..

Gauvain Pocentek (gpocentek) said : #2

Does ~/.config/xfce4-session/xfce4-session.rc exist? If so it probably overrides your change in /etc.

nosq (zagga) said : #3

I've noticed the same bug. The keyword seems to be saved sessions.
When SaveOnExit=true and AutoSave=true in ~/.config/xfce4-session/xfce4-session.rc ,
compiz isn't started when logging out and back in. xfwm4 isn't started either.

When SaveOnExit=false and AutoSave=false in ~/.config/xfce4-session/xfce4-session.rc and ~/.cache/session is cleared,
everything works as it should.

Besides, I don't see the difference between SaveOnExit and AutoSave. Autosave is changed when changing the option in Settings Manager->Sessions and startup, while it seems to change the value of SaveOnExit when logging out.

I'm converting this to a question since there are tons of tutorials available on how to properly configure Xubuntu with compiz.

Can you help with this problem?

Provide an answer of your own, or ask FritoBandito for more information if necessary.

To post a message you must log in.